Subject: [dhcwg] I-D Action: draft-ietf-dhc-mac-assign-09.txt

From: [email-masked]
Date: Thu, 03 Sep 2020 07:03:04 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : Link-Layer Addresses Assignment Mechanism for DHCPv6
        Authors         : Bernie Volz
                          Tomek Mrugalski
                          Carlos J. Bernardos
	Filename        : draft-ietf-dhc-mac-assign-09.txt
	Pages           : 20
	Date            : 2020-09-03

Abstract:
   In certain environments, e.g., large scale virtualization
   deployments, new devices are created in an automated manner.  Such
   devices may have their link-layer addresses assigned in an automated
   fashion.  With sufficient scale, the likelihood of a collision using
   random assignment without duplication detection is not acceptable.
   Therefore an allocation mechanism is required.  This draft proposes
   an extension to DHCPv6 that allows a scalable approach to link-layer
   address assignments where preassigned link-layer address assignments
   (such as by a manufacturer) are not possible or unnecessary.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-mac-assign/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-mac-assign-09
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-mac-assign-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-mac-assign-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 3 Sep 2020 15:01:13 +0000

This update addresses comments raised by Robert Wilton's IESG review and makes a small change based on comments from some IEEE reviewers.

The changes are fairly minor and can be viewed using https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-mac-assign-09.

The IEEE reviewers may still not be happy in terms of section 11, bullet 1 as they wanted much strongly language (i.e., MUST ...) - see https://mailarchive.ietf.org/arch/msg/dhcwg/Kib1zR5MiRyKec6ufUraoPR9DAo/ for more details on their original comments. However, that seems a bit strange given that 802c is an optional plan and not mandatory. The abstract from 802c-2017 states:

Abstract:
An optional local medium access control (MAC) address space structure, known as the Structured Local Address Plan (SLAP), is provided in this amendment to IEEE Std 802(R)-2014 in order to allow multiple administrations to coexist. This structure designates a range of local MAC addresses for protocols using a Company ID (CID) assigned by the IEEE Registration Authority. Another range of local MAC addresses is designated for assignment by administrators. The amendment recommends a range of local MAC addresses for use by IEEE 802(R) protocols.

Also, these details are not within the IETF's control, likely best to just given generic advice. And, link-layer addresses are a local issue.

- Bernie

-----Original Message-----
From: dhcwg <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, September 3, 2020 10:03 AM
To: [email-masked]
Cc: [email-masked]
Subject: [dhcwg] I-D Action: draft-ietf-dhc-mac-assign-09.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg