Subject: Re: [dhcwg] Updates on draft-ietf-dhc-slap-quadrant

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 1 Oct 2020 07:11:30 +0000

Roger, Robert, Glenn, and Dorothy,

As the IETF would like to move forward with the publication of this document, may I kindly ask you to quickly review the changes ?

My intent, as responsible Area Director for the DHC WG, is to approve and publish it in a week, Thursday 8th of October, if there is no blocking issues from the IEEE.

Thank you in advance,

Regards

-éric

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Thursday, 1 October 2020 at 08:51
To: Roger Marks <[email-masked]>
Cc: ROBERT GROW <[email-masked]>, Glenn Parsons <[email-masked]>, "Bernie Volz (volz)" <[email-masked]>, ANTONIO DE LA OLIVA DELGADO <[email-masked]>, Eric Vyncke <[email-masked]>, "Stanley, Dorothy" <[email-masked]>, dhcwg <[email-masked]>, "Rob Wilton (rwilton)" <[email-masked]>
Subject: Updates on draft-ietf-dhc-slap-quadrant

Hi Roger, all,

Thanks again for the comments on the draft. I did try to incorporate most of your comments. For the sake of completeness, I'm just summarizing below the changes I made on the draft:

- I applied basically all the suggested edits (on abstract, introduction and terminology sections).
- I made some minor changes to improve the motivation of the problem statement, but note that this was extensively reviewed by the DHC WG. I've modified the text regarding the IoT scenario to better explain the motivation (section 1.1.1). I've also reformulated the text in section 1.1.2 to better explain the rationale behind the recommendations for SLAP quadrant preferences in datacenter scenarios.
- As suggested, I removed the section on Quadrant Selection Mechanisms examples (and put it in an annex).
- I did check all your comments regarding the DHCPv6 extensions section (old section 4, now section 3). This part has been extensively reviewed and approved by the DHC WG and the IETF and represent therefore the IETF consensus. Since it refers to points related to the way the DHCPv6 protocol works, we, the editors of the DHC WG document, do not intend to apply some of your comments.
- I added all the suggested references and made the suggested corrections.

Note that most of the comments were addressed in draft-ietf-dhc-slap-quadrant-10 (posted early August), but I've just posted draft-ietf-dhc-slap-quadrant-11 [1] with some additional changes and small corrections.

Thanks much for providing the comments and feedback on the draft.

Kind regards,

Carlos

[1] https://tools.ietf.org/html/draft-ietf-dhc-slap-quadrant-11

---

From: Roger Marks <[email-masked]>
Date: Fri, 2 Oct 2020 15:36:23 -0600

Carlos and éric,

Since many of the core technical comments were not implemented, I personally still think that the draft is still not effective.  I'll just reiterate that the following remain puzzling to me:

(1) Why a client needs to request a specific quadrant of the local MAC address space, via Solicit (i.e., I don't understand the problem statement).
(2) Why a server is prohibited from offering, in the Advertise, an address outside the requested quadrant.
(3) Given (2), why the server that cannot meet the demand does not provide, in the Advertise, the list of quadrants in which it does have available addresses.
(4) Given (2), why the client can nevertheless (though it SHOULD NOT) Request an address in a quadrant that was not Advertised, and,
(5) Given (4), why the server can nevertheless grant that request, though it was prohibited [per (2)] from admitting that it could do so.

I understand that the editors decided not to make changes in response to the relevant prior comments because the content had already been "extensively reviewed and approved by the DHC WG and the IETF and represent therefore the IETF consensus." However, that explanation doesn't provide me with an understanding of the technical rationale, so I remain puzzled.

Please understand that these comments are from me only, not from IEEE.

Cheers,

Roger

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tue, 6 Oct 2020 22:07:12 +0200

Hi Roger,

Thanks again for your feedback. Please see inline below.

On Fri, Oct 2, 2020 at 11:37 PM Roger Marks <[email-masked]> wrote:

> Carlos and éric,
>
> Since many of the core technical comments were not implemented, I
> personally still think that the draft is still not effective.  I'll just
> reiterate that the following remain puzzling to me:
>
> (1) Why a client needs to request a specific quadrant of the local MAC
> address space, via Solicit (i.e., I don't understand the problem statement).
>

 [Carlos] The mechanism is intended to allow a client (or relay) indicate a
preference for obtaining addresses from a specific quadrant. There are some
examples of scenarios where this might be relevant described in the
document, but there might be others that appear in the future as well.

(2) Why a server is prohibited from offering, in the Advertise, an address
> outside the requested quadrant.
>

[Carlos] This part of the DHCP dialogue (Solicit-Advertise) is meant for
the client to select the best DHCP server to meet its needs (i.e.,
indicated preference). What do you think about the following modification
to address your suggestion?

OLD:
   2.  The server, upon receiving an IA_LL option in Solicit, inspects
       its contents.  For each of the entries in OPTION_SLAP_QUAD, in
       order of the preference field (highest to lowest), the server
       checks if it has a configured MAC address pool matching the
       requested quadrant identifier, and an available range of
       addresses of the requested size.  If suitable addresses are
       found, the server sends back an Advertise message with an IA_LL
       option containing an LLADDR option that specifies the addresses
       being offered.  If the server supports the new QUAD IA_LL-option,
       and manages a block of addresses belonging to a requested
       quadrant, the addresses being offered MUST belong to a requested
       quadrant.  If the server does not have a configured address pool
       matching the client's request, it MUST return the IA_LL option
       containing a Status Code option with status set to NoQuadAvail
       (IANA-2).  If the client specified more than one SLAP quadrant,
       the server MUST only return a NoQuadAvail status code if no
       address pool(s) configured at the server match any of the
       specified SLAP quadrants.  If the server has a configured address
       pool of the correct quadrant, but no available addresses, it MUST
       return the IA_LL option containing a Status Code option with
       status set to NoAddrsAvail.

NEW:
   2.  The server, upon receiving an IA_LL option in Solicit, inspects
       its contents.  For each of the entries in OPTION_SLAP_QUAD, in
       order of the preference field (highest to lowest), the server
       checks if it has a configured MAC address pool matching the
       requested quadrant identifier, and an available range of
       addresses of the requested size.  If suitable addresses are
       found, the server sends back an Advertise message with an IA_LL
       option containing an LLADDR option that specifies the addresses
       being offered.  If the server manages a block of addresses belonging
       to a requested quadrant, the addresses being offered MUST belong
       to a requested quadrant.  If the server does not have a configured
       address pool matching the client's request, it SHOULD return the
       IA_LL option with the addresses being offered belonging to a
       quadrant managed by the server (following a local policy to select
       from which of the available quadrants). If the server has a
configured
       address pool of the correct quadrant, but no available addresses, it
       MUST return the IA_LL option containing a Status Code option with
       status set to NoAddrsAvail.

The client-relay-server part of the spec would also be changed to reflect
the same update. Besides, the following clause suggested by Bernie (thanks
a lot!) would be added, with some minor modifications to ensure the wording
matches the rest of the text in the section:

      For cases where a server may not be configured to have pools for the
      client or relay QUAD preferences, clients and relays SHOULD specify
      all quadrants in the preferences to assure the client gets an address
      (or addresses) -- if any are available. Specifying all quadrants also
      results in a quad option supporting server responding like a non-quad
      option supporting server, i.e., an address (or addresses) from any
      available quadrant can be returned.

> (3) Given (2), why the server that cannot meet the demand does not
> provide, in the Advertise, the list of quadrants in which it *does* have
> available addresses.
>

[Carlos] If we go for the proposed change above, this would not apply.

In any case, I want to provide an explanation why this was not possible
with the current text (if we do not add the change proposed above). This is
because the way DHCP address allocation works (as described in
draft-ietf-dhc-mac-assign for MAC addresses). The server includes in the
Advertise the actual address(es) being offered, not the list of quadrants
that it has available. This is due to the way DHCP works, and therefore
cannot be changed. In any case, the client may send a different Solicit
with more SLAP quadrants, to see/learn which ones are supported by
available servers.

> (4) Given (2), why the client can nevertheless (though it SHOULD NOT)
> Request an address in a quadrant that was not Advertised, and,
>

[Carlos] Again, this might not apply if we adopt the proposed change. But,
let me provide an explanation of why the spec was originally written as it
is, below.

IETF protocols make use of normative capitalized words (like "SHOULD NOT")
in very specific ways, described in RFCs 2119 and 8174. According to RFCs
2119 and 8174, "SHOULD NOT" indicates that "there may exist valid reasons
in particular circumstances when the particular behavior is acceptable or
even useful, but the full implications should be understood and the case
carefully weighed before implementing any behavior described with this
label". Therefore, there might be scenarios, carefully weighed, where a
client requesting a quadrant that was not advertised, might make sense, and
we leave the specification so this can be supported, instead of using "MUST
NOT" which would totally prohibit that.

> (5) Given (4), why the server can nevertheless grant that request, though
> it was prohibited [per (2)] from admitting that it could do so.
>

[Carlos] Note that the server would not have addresses from the indicated
quadrant in this case (otherwise it would have indicated that in the
Advertise message), and therefore it will never allocate addresses from
this quadrant. But the server is allowed to allocate address(es) from a
different quadrant (based on local server policies). And then the client
may decide to use it anyway.

But in any case, this would not apply either.

Thanks one more time.

Carlos

>
> I understand that the editors decided not to make changes in response to
> the relevant prior comments because the content had already been
> "extensively reviewed and approved by the DHC WG and the IETF and represent
> therefore the IETF consensus." However, that explanation doesn't provide me
> with an understanding of the technical rationale, so I remain puzzled.
>
> As the IETF would like to move forward with the publication of this
> document, may I kindly ask you to quickly review the changes ?
>
>
>
> My intent, as responsible Area Director for the DHC WG, is to approve and
> publish it in a week, Thursday 8th of October, if there is no blocking
> issues from the IEEE.
>
>
>
> Thank you in advance,
>
>
>
> Regards
>
>
>
> -éric
>
>
>
> *From:* CARLOS JESUS BERNARDOS CANO <[email-masked]>
> *Date:* Thursday, 1 October 2020 at 08:51
> *To:* Roger Marks <[email-masked]>
> *Cc:* ROBERT GROW <[email-masked]>, Glenn Parsons <
> [email-masked]>, "Bernie Volz (volz)" <[email-masked]>,
> ANTONIO DE LA OLIVA DELGADO <[email-masked]>, Eric Vyncke <
> [email-masked]>, "Stanley, Dorothy" <[email-masked]>, dhcwg <
> [email-masked]>, "Rob Wilton (rwilton)" <[email-masked]>
> *Subject:* Updates on draft-ietf-dhc-slap-quadrant
>
>
>
> Hi Roger, all,
>
>
>
> Thanks again for the comments on the draft. I did try to incorporate most
> of your comments. For the sake of completeness, I'm just summarizing below
> the changes I made on the draft:
>
>
>
> - I made some minor changes to improve the motivation of the problem
> statement, but note that this was extensively reviewed by the DHC WG. I've
> modified the text regarding the IoT scenario to better explain the
> motivation (section 1.1.1). I've also reformulated the text in section
> 1.1.2 to better explain the rationale behind the recommendations for SLAP
> quadrant preferences in datacenter scenarios.
>
> - I did check all your comments regarding the DHCPv6 extensions section
> (old section 4, now section 3). This part has been extensively reviewed and
> approved by the DHC WG and the IETF and represent therefore the IETF
> consensus. Since it refers to points related to the way the DHCPv6
> protocol works, we, the editors of the DHC WG document, do not intend to
> apply some of your comments.
>
> Note that most of the comments were addressed in
> draft-ietf-dhc-slap-quadrant-10 (posted early August), but I've just posted
> draft-ietf-dhc-slap-quadrant-11 [1] with some additional changes and small
> corrections.
>
>
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 9 Oct 2020 15:40:53 +0000

Roger, Robert, Glenn, Dorothy,

Sorry for being pushy again but what do you think about Carlos’ proposed text ? (and thank you again for spotting an ambiguity in the IETF draft)

I would really like to get a reply from you before approving this IETF document

Regards

-éric

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tuesday, 6 October 2020 at 22:07
To: Roger Marks <[email-masked]>
Cc: ROBERT GROW <[email-masked]>, Glenn Parsons <[email-masked]>, "Stanley, Dorothy" <[email-masked]>, Eric Vyncke <[email-masked]>, "Bernie Volz (volz)" <[email-masked]>, ANTONIO DE LA OLIVA DELGADO <[email-masked]>, dhcwg <[email-masked]>, "Rob Wilton (rwilton)" <[email-masked]>, Timothy Winters <[email-masked]>, "Mourad, Alain" <[email-masked]>
Subject: Re: Updates on draft-ietf-dhc-slap-quadrant

Hi Roger,

On Fri, Oct 2, 2020 at 11:37 PM Roger Marks <[email-masked]<mailto:[email-masked]>> wrote:
Carlos and éric,

 [Carlos] The mechanism is intended to allow a client (or relay) indicate a preference for obtaining addresses from a specific quadrant. There are some examples of scenarios where this might be relevant described in the document, but there might be others that appear in the future as well.

[Carlos] This part of the DHCP dialogue (Solicit-Advertise) is meant for the client to select the best DHCP server to meet its needs (i.e., indicated preference). What do you think about the following modification to address your suggestion?

OLD:

NEW:
       from which of the available quadrants). If the server has a configured

The client-relay-server part of the spec would also be changed to reflect the same update. Besides, the following clause suggested by Bernie (thanks a lot!) would be added, with some minor modifications to ensure the wording matches the rest of the text in the section:

In any case, I want to provide an explanation why this was not possible with the current text (if we do not add the change proposed above). This is because the way DHCP address allocation works (as described in draft-ietf-dhc-mac-assign for MAC addresses). The server includes in the Advertise the actual address(es) being offered, not the list of quadrants that it has available. This is due to the way DHCP works, and therefore cannot be changed. In any case, the client may send a different Solicit with more SLAP quadrants, to see/learn which ones are supported by available servers.

[Carlos] Again, this might not apply if we adopt the proposed change. But, let me provide an explanation of why the spec was originally written as it is, below.
IETF protocols make use of normative capitalized words (like "SHOULD NOT") in very specific ways, described in RFCs 2119 and 8174. According to RFCs 2119 and 8174, "SHOULD NOT" indicates that "there may exist valid reasons in particular circumstances when the particular behavior is acceptable or even useful, but the full implications should be understood and the case carefully weighed before implementing any behavior described with this label". Therefore, there might be scenarios, carefully weighed, where a client requesting a quadrant that was not advertised, might make sense, and we leave the specification so this can be supported, instead of using "MUST NOT" which would totally prohibit that.

[Carlos] Note that the server would not have addresses from the indicated quadrant in this case (otherwise it would have indicated that in the Advertise message), and therefore it will never allocate addresses from this quadrant. But the server is allowed to allocate address(es) from a different quadrant (based on local server policies). And then the client may decide to use it anyway.
But in any case, this would not apply either.

Thanks one more time.

Carlos

Cheers,

Roger
On Oct 1, 2020, 1:11 AM -0600, "Eric Vyncke (evyncke)" <[email-masked]<mailto:[email-masked]>>, wrote:

Thank you in advance,

Regards

-éric

From: CARLOS JESUS BERNARDOS CANO <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 1 October 2020 at 08:51
To: Roger Marks <[email-masked]<mailto:[email-masked]>>
Cc: ROBERT GROW <[email-masked]<mailto:[email-masked]>>, Glenn Parsons <[email-masked]<mailto:[email-masked]>>, "Bernie Volz (volz)" <[email-masked]<mailto:[email-masked]>>, ANTONIO DE LA OLIVA DELGADO <[email-masked]<mailto:[email-masked]>>, Eric Vyncke <[email-masked]<mailto:[email-masked]>>, "Stanley, Dorothy" <[email-masked]<mailto:[email-masked]>>, dhcwg <[email-masked]<mailto:[email-masked]>>, "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>
Subject: Updates on draft-ietf-dhc-slap-quadrant

Hi Roger, all,

Kind regards,

Carlos

---

From: Roger Marks <[email-masked]>
Date: Fri, 9 Oct 2020 13:37:30 -0600

Carlos,

Thanks for the response.

Personally, I believe that the changes you indicated (from OLD to NEW, and the clause suggested by Bernie), would address the concerns I raised.

Thanks for taking the time to consider my concerns.

Cheers,

Roger
On Oct 9, 2020, 9:41 AM -0600, "Eric Vyncke (evyncke)" <[email-masked]>, wrote:
> > quote_type
> > quote_type
> > quote_type
> > quote_type
> > quote_type
> > quote_type

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Fri, 9 Oct 2020 22:28:18 +0200

Thanks a lot Roger for all the help.

Kind regards,

Carlos

On Fri, Oct 9, 2020 at 9:38 PM Roger Marks <[email-masked]> wrote:

> Carlos,
>
> Thanks for the response.
>
> Personally, I believe that the changes you indicated (from OLD to NEW, and
> the clause suggested by Bernie), would address the concerns I raised.
>
> Sorry for being pushy again but what do you think about Carlos’ proposed
> text ? (and thank you again for spotting an ambiguity in the IETF draft)
>
>
>
> *Date:* Tuesday, 6 October 2020 at 22:07
> [email-masked]>, "Stanley, Dorothy" <[email-masked]>,
> Eric Vyncke <[email-masked]>, "Bernie Volz (volz)" <[email-masked]>,
> ANTONIO DE LA OLIVA DELGADO <[email-masked]>, dhcwg <[email-masked]>,
> "Rob Wilton (rwilton)" <[email-masked]>, Timothy Winters <
> [email-masked]>, "Mourad, Alain" <[email-masked]>
> *Subject:* Re: Updates on draft-ietf-dhc-slap-quadrant
>
>
>
> Hi Roger,
>
>
>
>  [Carlos] The mechanism is intended to allow a client (or relay) indicate
> a preference for obtaining addresses from a specific quadrant. There are
> some examples of scenarios where this might be relevant described in the

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 9 Oct 2020 20:45:09 +0000

Indeed, thank you Roger for the first quick first review and this reply

Eric
________________________________
From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Sent: Friday, October 9, 2020 10:28:18 PM
To: Roger Marks <[email-masked]>
Cc: Eric Vyncke (evyncke) <[email-masked]>; ROBERT GROW <[email-masked]>; Glenn Parsons <[email-masked]>; Stanley, Dorothy <[email-masked]>; Bernie Volz (volz) <[email-masked]>; ANTONIO DE LA OLIVA DELGADO <[email-masked]>; dhcwg <[email-masked]>; Rob Wilton (rwilton) <[email-masked]>; Timothy Winters <[email-masked]>; Mourad, Alain <[email-masked]>
Subject: Re: Updates on draft-ietf-dhc-slap-quadrant

Kind regards,

Carlos

On Fri, Oct 9, 2020 at 9:38 PM Roger Marks <[email-masked]<mailto:[email-masked]>> wrote:
Carlos,

Thanks for the response.

Cheers,

Roger
On Oct 9, 2020, 9:41 AM -0600, "Eric Vyncke (evyncke)" <[email-masked]<mailto:[email-masked]>>, wrote:

Regards

-éric

Cc: ROBERT GROW <[email-masked]<mailto:[email-masked]>>, Glenn Parsons <[email-masked]<mailto:[email-masked]>>, "Stanley, Dorothy" <[email-masked]<mailto:[email-masked]>>, Eric Vyncke <[email-masked]<mailto:[email-masked]>>, "Bernie Volz (volz)" <[email-masked]<mailto:[email-masked]>>, ANTONIO DE LA OLIVA DELGADO <[email-masked]<mailto:[email-masked]>>, dhcwg <[email-masked]<mailto:[email-masked]>>, "Rob Wilton (rwilton)" <[email-masked]<mailto:[email-masked]>>, Timothy Winters <[email-masked]<mailto:[email-masked]>>, "Mourad, Alain" <[email-masked]<mailto:[email-masked]>>

Hi Roger,

Carlos and éric,

OLD:

NEW:

Thanks one more time.

Carlos

Cheers,

Roger

Thank you in advance,

Regards

-éric

Hi Roger, all,

Kind regards,

Carlos