Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-pd-relay-requirements-02.txt

From: [email-masked]
Date: Wed, 07 Oct 2020 03:19:38 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : DHCPv6 Prefix Delegating Relay
        Authors         : Ian Farrer
                          Naveen Kottapalli
                          Martin Hunek
                          Richard Patterson
	Filename        : draft-ietf-dhc-dhcpv6-pd-relay-requirements-02.txt
	Pages           : 12
	Date            : 2020-10-07

Abstract:
   This memo describes operational problems that are known to occur when
   using DHCPv6 relays with Prefix Delegation.  These problems can
   prevent successful delegation and result in routing failures.  To
   address these problems, this memo provides necessary functional
   requirements for operating DHCPv6 relays with Prefix Delegation.

   It is recommended that any network operator that is using DHCPv6
   prefix delegation with relays should ensure that these requirements
   are followed on their networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-pd-relay-requirements/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-pd-relay-requirements-02
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-pd-relay-requirements-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-pd-relay-requirements-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Wed, 7 Oct 2020 12:25:01 +0200

Hi

We’ve just posted an update to this draft based on the comments received in WGLC. Many thanks for your reviews and suggestions.

The major changes since -01 are:

1. Rewritten abstract section
2. Provided clarification on multi-hop relays
3. Changed text related to handling of unknown messages by relays and removed req. G-2 that covered this.
4. Provided references to sections in CMTS and BNG documents
5. Added section about forwarding loops between clients and relays
6. Updated requirement R-4 to detail on avoiding the loops

I think that all of the WGLC comments are now addressed, with the exception of a question from Ole regarding implementors experience related to requirement R-4. I’ve just sent out a question on v6ops and 6man to see if we can get feedback on this.

One final question. The draft is currently called "DHCPv6 Prefix Delegating Relay” which is not particularly descriptive. We suggest changing it to ‘Requirements for DHCPv6 Prefix Delegating Relays’. Any objections to this?

Thanks,
Ian

> On 7. Oct 2020, at 12:19, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 7 Oct 2020 19:08:29 +0000

Hi:

Thanks Ian for the updates.

I suggest we wait a few days to see if v6ops or ipv6 working groups have any comments (as your emailed them) before I proceed with sending the document on.

In reviewing, I also noticed the following minor items:

Minor nit in section 1?

   Multi-hop DHCPv6 relaying is not affected, as the requirements in
   this document are solely applicable to the DHCP relay agent co-
   located with the first-hop router that the DHCPv6 client requesting
   the prefix is connected to, no changes to any subsequent relays in
   the path are needed.

Would "so no changes" (or thus no changes) be appropriate? It just seems something is missing here. Though two free grammar checkers I used didn't seem to flag it broken (either with or without my changes).

And, in section 3.5:

   If the client loses information about a prefix that it is delegated
   while the lease entry and associated route is still active in the
   delegating relay, then the relay will forward traffic to the client
   which the client will return to the relay (which is the client's
   default gateway (learnt via an RA).  The loop will continue until
   either the client is successfully reprovisioned via DHCP, or the
   lease ages out in the relay.

Missing a second closing parenthesis: (which is the client's default gateway (learnt via an RA)). 

Please do not publish an 03 for now as these issues are very minor. We can see if other comments are raised.

- Bernie

-----Original Message-----
From: dhcwg <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, October 7, 2020 6:25 AM
To: dhcwg <[email-masked]>
Subject: Re: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-pd-relay-requirements-02.txt

Hi

Thanks,
Ian

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 8 Oct 2020 09:51:02 +0200

> Missing a second closing parenthesis: (which is the client's default gateway (learnt via an RA)).

I think (()) works ok in LISP and Scheme but not in English?  One would 
rather use [()]?

Alex

---

From: [email-masked]
Date: Thu, 8 Oct 2020 16:04:36 +0200

Hi Bernie,

Thanks for the comments. Did you have any thoughts about the proposed change to the title?

Please see inline below.

Thanks,
Ian

> On 7. Oct 2020, at 21:08, Bernie Volz (volz) <[email-masked]> wrote:
> 
> Hi:
> 

[if - Re-reading this, the sentence is overlong and the commas make it difficult to parse. I think the following wording clears this up:

  Multi-hop DHCPv6 relaying is not affected.  The requirements in
  this document are solely applicable to the DHCP relay agent co-
  located with the first-hop router that the DHCPv6 client requesting
  the prefix is connected to, so no changes to any subsequent relays in
  the path are needed.
]

> Missing a second closing parenthesis: (which is the client's default gateway (learnt via an RA)). 

[if - OK]

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 8 Oct 2020 14:19:45 +0000

Hi:

>"DHCPv6 Prefix Delegating Relay” which is not particularly descriptive. We suggest changing it to ‘Requirements for DHCPv6 Prefix Delegating Relays’

That or "DHCPv6 Prefix Delegating Relay Requirements" would be fine I think.

- Bernie

-----Original Message-----
From: dhcwg <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, October 8, 2020 10:05 AM
To: Bernie Volz (volz) <[email-masked]>
Cc: dhcwg <[email-masked]>
Subject: Re: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-pd-relay-requirements-02.txt

Hi Bernie,

Please see inline below.

Thanks,
Ian

[if - OK]

> Subject: Re: [dhcwg] I-D Action: 
> draft-ietf-dhc-dhcpv6-pd-relay-requirements-02.txt
> 
> Hi
> 
> 2. Provided clarification on multi-hop relays 3. Changed text related 
> to handling of unknown messages by relays and removed req. G-2 that covered this.
> 4. Provided references to sections in CMTS and BNG documents 5. Added 
> section about forwarding loops between clients and relays 6. Updated 
> requirement R-4 to detail on avoiding the loops
>