Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-12.txt

From: [email-masked]
Date: Fri, 04 Dec 2020 08:04:45 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Authors         : Yong Cui
                          Linhui Sun
                          Ian Farrer
                          Sladjana Zechlin
                          Zihao He
                          Michal Nowikowski
	Filename        : draft-ietf-dhc-dhcpv6-yang-12.txt
	Pages           : 92
	Date            : 2020-12-04

Abstract:
   This document describes YANG data modules for the configuration and
   management of DHCPv6 servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-12
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Fri, 4 Dec 2020 17:06:49 +0100

Hi,

I’ve just posted an update. The main changes in this version are:

* Addition of RPCs to the server and relay modules for clearing/deleting active lease entries
* The RC8415 option modules have been divided into separate client, relay and server modules. This is to prevent each element from importing modules from each of the other elements.
* Some cleanups in the naming of the leafs to reduce redundancy
* Appendix A (Example option extension) has been extended to describe the augmentation of DHCP option YANG modules at other locations than the ‘option-sets’ when it makes sense.

As ever, all reviews, comments, suggestions etc. appreciated.

Thanks,
Ian

> On 4. Dec 2020, at 17:04, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg