Subject: [dhcwg] Fwd: >> YANG Data Model for DHCPv6 Configuration-16

From: [email-masked]
Date: Tue, 19 Jan 2021 08:37:39 +0100

Resending as the original message didn’t appear on the m/l.

Hi Tom,

Thanks for your comments. Please see inline below.

Ian

> On 14. Jan 2021, at 13:40, t petch <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> Ian
> 
> I do not understand this I-D; I have tracked it for a number of years and my understanding of it is diminishing.
> 
> Currently, it is seven YANG modules: why?

[if - The separation into client/server/relay, and DHCP options has been in the draft since -05 and the changes were presented and discussed at IETF101 - I’ve described the reasoning for this split in the next answer. Beyond that, the common module was added to avoid (well reduce as you point out below) duplication.

The separation of the option modules came at a later stage based on import dependencies of a single options module. When the options module imports the client/server/relay modules so it can augment the relevant module based on identity, an implementation also needs to import these modules and will declare them in it’s capabilities as available even though it doesn’t implement them. Dividing the options modules avoids the need for deviations.

Even though there are 7 modules defined here, the likely hood is that an element implementation would require 3 modules to be implemented (e.g. client, common and client options).]

> 
> Other WG have models with multiple roles and many options and have a single YANG module, using the features of YANG to tailor the module to different configurations.

[if - It’s not really tailoring the module to different configurations, they are for the most part separate functional elements in the network with any device only implementing one of the client, relay or server functions.

However, even in the case that a device is both a server and a client (e.g. a home gateway with a client on the WAN and a server on the LAN), the likelihood is that these will be done using different software implementations, so having separate modules for server and client offers implementation flexibility.

In the case of a monolithic module with the relevant client/relay/server functionality enabled by features, the module would do nothing unless one or more of the features was enabled, and Is unlikely that you’d ever enable more than one. Is this approach used by other WGs? Could you point me to some some examples as I've only seen features been used as relatively small optional extensions used when the bulk of the nodes are common?]

> 
> Here you have modelled the options as YANG grouping. The intent of a grouping is to provide a block of statements that can be reused so avoiding duplication with the attendant problems.  Here you have the same grouping in triplicate in three different YANG modules which seems to me to be the antithesis of a grouping.

[If - We could move the option definitions for "status-code-option-group” (client, server, relay) and “rapid-commit-option-group, vendor-specific-information-option-group; reconfigure-accept-option-group” (client, server) into the common module to resolve the duplication. I didn’t do this previously as the intention was to keep options definitions in the options modules for consistency, but it  would be simple to change. ]

> 
> Likewise I find the specification of server v client v relay unusual.

[If - A similar approach for separated client/server modules is also used in RFC8676, where the client and server have discrete function, as with DHCP.]

> 
> I wonder if it is worth consulting a YANG doctor, NOT to show them the YANG and invite comments, rather outline in an abstract way what it is you want to model and see what they suggest; that might well be a single YANG module.

[if - Yes, I’d be happy to. Is there someone that you have in mind (I’ve not had much luck with getting YANG doctor input outside of the formal review process in the past)?. I’m not opposed to changing the way that the modules are structured on principal, I do however, think that the separation by functional element is logical and simpler for implementers, and I would like to know what the benefits of a single module (or other structure) might be.]

> 
> I do have quite a number of detailed comments but do not think them worth making until the I-D seems to me more stable.

[if - It’d be great if you could supply them as well so I can start going though them and fixing what’s currently fixable in parallel to the discussion above.]
> 
>> 
>> Tom Petch
>> 
>> On 07/01/2021 16:10, [email-masked] <mailto:[email-masked]> wrote:
>>> Hi Tom,
>>> 
>>> Many thanks for the comments. I’ve just uploaded -16 which addresses them.
>>> 
>>> One other change is that the wrong file was being included for the relay module. This is also resolved in this version.
>>> 
>>> Cheers,
>>> Ian
>>> 
>>>> On 6. Jan 2021, at 13:50, tom petch <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> Ian
>>>> 
>>>> Looking at -15, it looks a bit screwy.
>>>> 
>>>> There appear to be six YANG modules which means there must be six prefix registered but IANA Considerations registers the same prefix six times:-(
>>>> 
>>>> The lines have been chopped at 76? characters so that one character appears on a line by itself in several places towards the end in the Appendices
>>>> 
>>>> There is a convention which I find like to use
>>>> RFC XXXX <name of document>
>>>> where a reference is needed to the I-D when it becomes an RFC.  A note to the RFC Editor to replace XXXX with the number assigned is nice to have but I think that the RFC Editor is by now well acquainted with YANG modules. RFC YYYY etc can then be used for other I-D, which there often are although not I think in this I-D.
>>>> 
>>>> Tom Petch
>>>> 
>>>> 
>>>> On 01/01/1970 00:00,  wrote:
>>>>> Hi,
>>>>> 
>>>>> I’ve just updated the draft using the correct file headers so the IETF’s automated YANG checking tools recognise the modules. This got lost a few versions back when we moved to v3 formats.
>>>>> 
>>>>> This also flagged up quite a few gremlins in the modules (mainly leaf orders and line length problems), so these have been fixed as well.
>>>>> 
>>>>> Thanks,
>>>>> Ian
>>>>> 
>>>>>> On 10. Dec 2020, at 14:38, [email-masked] <mailto:[email-masked]> wrote:
>>>>>> 
>>>>>> 
>>>>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>>>>> This draft is a work item of the Dynamic Host Configuration WG of the IETF.
>>>>>> 
>>>>>>        Title           : YANG Data Model for DHCPv6 Configuration
>>>>>>        Authors         : Yong Cui
>>>>>>                          Linhui Sun
>>>>>>                          Ian Farrer
>>>>>>                          Sladjana Zechlin
>>>>>>                          Zihao He
>>>>>>                          Michal Nowikowski
>>>>>> 	Filename        : draft-ietf-dhc-dhcpv6-yang-13.txt
>>>>>> 	Pages           : 97
>>>>>> 	Date            : 2020-12-10
>>>>>> 
>>>>>> Abstract:
>>>>>>   This document describes YANG data modules for the configuration and
>>>>>>   management of DHCPv6 servers, relays, and clients.
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>> The IETF datatracker status page for this draft is:
>>>>>> https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/ <https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/>
>>>>>> 
>>>>>> There are also htmlized versions available at:
>>>>>> https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-13
>>>>>> https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-13
>>>>>> 
>>>>>> A diff from the previous version is available at:
>>>>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-13
>>>>>> 
>>> 
>>> .
>>> 
>

---

From: t petch <[email-masked]>
Date: Wed, 20 Jan 2021 12:24:32 +0000

On 19/01/2021 11:25, tom petch wrote:
> ________________________________________
> From: dhcwg <[email-masked]> on behalf of [email-masked] <[email-masked]>
> Sent: 19 January 2021 07:37
>
> On 14. Jan 2021, at 13:40, t petch <[email-masked]<mailto:[email-masked]>> wrote:
>
>
> Ian
>

Ian

Almost all the YANG models I know of are single module.  For example,
draft-ietf-ospf-yang supports two versions modelled as identity and 28 
options modelled as features.

draft-ietf-tcpm-yang supports client and server as containers with 
if-feature and has other features as well

draft-ietf-pim-igmp-mld-yang supports five versions of two protocol 
using identity

draft-pce-pcep-yang offers the roles of pcc or pce or both using typedef.

And so on and so on.  if-feature, when and suchlike provide the 
necessary customisation.

I think that your problems with options are because the identity are 
defined in the wrong place.  The base, the common module (or part of the 
one and only module) should define what is common, what everyone needs; 
if there are three roles and a dozen options, than that is where they 
need to be defined.

Then there can be an object which is configured with the roles of a 
particular box, client or server or relay, or if required, a combination 
of the there - simpler if that is out of scope as you suggest.

My startng point would be a dhc container with a role and then 
containers for client, relay, server, added by augment and controlled by 
when pointing at the rold.

I will post something to the netmod WG list - there are lots of people 
there with greater exposure than mine who can give better guidance than I.

Tom Petch

> On 07/01/2021 16:10, [email-masked]<mailto:[email-masked]> wrote:
> Hi Tom,
>
> On 6. Jan 2021, at 13:50, tom petch <[email-masked]<mailto:[email-masked]>> wrote:
>
> Ian
>
> On 10. Dec 2020, at 14:38, [email-masked]<mailto:[email-masked]> wrote:
>
>
> https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/
>

---

From: [email-masked]
Date: Thu, 21 Jan 2021 17:29:16 +0100

Hi Tom,

Thanks for starting the discussion on the netmod list. I’ll continue the discussion there for now and update this thread with the outcome.

Ian

> On 20. Jan 2021, at 13:24, t petch <[email-masked]> wrote:
> 
> draft-ietf-ospf-yang supports two versions modelled as identity and 28 options modelled as features.
> 
> draft-ietf-tcpm-yang supports client and server as containers with if-feature and has other features as well
> 
> draft-ietf-pim-igmp-mld-yang supports five versions of two protocol using identity
> 
> And so on and so on.  if-feature, when and suchlike provide the necessary customisation.
> 
> I think that your problems with options are because the identity are defined in the wrong place.  The base, the common module (or part of the one and only module) should define what is common, what everyone needs; if there are three roles and a dozen options, than that is where they need to be defined.
> 
> Then there can be an object which is configured with the roles of a particular box, client or server or relay, or if required, a combination of the there - simpler if that is out of scope as you suggest.
> 
> My startng point would be a dhc container with a role and then containers for client, relay, server, added by augment and controlled by when pointing at the rold.
> 
> I will post something to the netmod WG list - there are lots of people there with greater exposure than mine who can give better guidance than I.
> 
> Tom Petch
>