Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-17.txt

From: [email-masked]
Date: Fri, 29 Jan 2021 07:21:16 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Authors         : Yong Cui
                          Linhui Sun
                          Ian Farrer
                          Sladjana Zechlin
                          Zihao He
                          Michal Nowikowski
	Filename        : draft-ietf-dhc-dhcpv6-yang-17.txt
	Pages           : 85
	Date            : 2021-01-29

Abstract:
   This document describes YANG data modules for the configuration and
   management of DHCPv6 servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-17
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-17

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-17

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Fri, 29 Jan 2021 16:25:40 +0100

Hi,

I’ve just posted -17 of the draft following discussion on the structure on the netmod mailing list. The discussion is here:

https://mailarchive.ietf.org/arch/msg/netmod/uFNY9XfCcNANQNA34HpLVsF_lU8/

A number of changes were discussed and have been incorporated in this update. These are:

* The element specific modules previously had a second module which described options relevant to the node. These options definitions have been incorporated into the relevant element modules. This means there are now total 4 modules in the draft  (instead of 7):

Ietf-dhcvp6-common
Ietf-dhcvp6-client
Ietf-dhcvp6-relay
Ietf-dhcvp6-server

* Options which are applicable to more than one node are now defined in the ‘common’ module to be imported and used by the relevant elements.

* As a result, the identities for each node type is no longer needed, so these has been removed.

* Additional option definition modules no long use ‘RFCXXXX’ in their naming. Short, descriptive names are used instead.

* The appendix example for defining additional option definitions has been updated along with the accompanying text.

* ‘Enable’ nodes have been added to the client, relay and server modules to enable disable overall function. Client and relay modules also have enable nodes for each DHCP interface included.

In addition, there are a number of small wording cleanups. Also,  in the security section, a bullet point about reconfiguring the relay-destination address has been removed. This was a duplicate bullet, copied in error under the read-only security descriptions.

Thanks,
Ian

> On 29. Jan 2021, at 16:21, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg