Subject: [dhcwg] [Errata Held for Document Update] RFC8357 (6008)

From: RFC Errata System <[email-masked]>
Date: Thu, 28 Jan 2021 02:13:16 -0800 (PST)

The following errata report has been held for document update 
for RFC8357, "Generalized UDP Source Port for DHCP Relay". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6008

--------------------------------------
Status: Held for Document Update
Type: Technical

Reported by: Stéphane Bortzmeyer <[email-masked]>
Date Reported: 2020-03-05
Held by: Eric Vyncke (IESG)

Section: 4.2

Original Text
-------------
       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |    OPTION_RELAY_PORT    |         Option-Len                  |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |    Downstream Source Port     |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Corrected Text
--------------
       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |       OPTION_RELAY_PORT       |         Option-Len            |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |    Downstream Source Port     |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Notes
-----
Discrepancy between the diagram and the text noted by draft-mcquistin-augmented-ascii-diagrams-02.

-- Verifier note --
There is clearly an error in the diagram that does not reflect the text. As the text is sensible and used as a reference, implementors will follow the text. Hence, the status of 'hold for document update' as it does not cause significant implementation error.

--------------------------------------
RFC8357 (draft-ietf-dhc-relay-port-10)
--------------------------------------
Title               : Generalized UDP Source Port for DHCP Relay
Publication Date    : March 2018
Author(s)           : N. Shen, E. Chen
Category            : PROPOSED STANDARD
Source              : Dynamic Host Configuration
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 29 Jan 2021 19:20:23 +0000

Yes, the diagram is a bit messed up.

This ERRATA is valid.

- Bernie

-----Original Message-----
From: dhcwg <[email-masked]> On Behalf Of RFC Errata System
Sent: Thursday, January 28, 2021 5:13 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [dhcwg] [Errata Held for Document Update] RFC8357 (6008)

The following errata report has been held for document update for RFC8357, "Generalized UDP Source Port for DHCP Relay". 

Reported by: Stéphane Bortzmeyer <[email-masked]> Date Reported: 2020-03-05 Held by: Eric Vyncke (IESG)

Section: 4.2

Original Text
-------------
       0                   1                   2                   3

Corrected Text
--------------
       0                   1                   2                   3

Notes
-----

-- Verifier note --

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg