Subject: [dhcwg] [Errata Held for Document Update] RFC3315 (5450)

From: RFC Errata System <[email-masked]>
Date: Fri, 5 Feb 2021 01:50:12 -0800 (PST)

The following errata report has been held for document update 
for RFC3315, "Dynamic Host Configuration Protocol for IPv6 (DHCPv6)". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5450

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Nikolai Malykh <[email-masked]>
Date Reported: 2018-08-03
Held by: Éric Vyncke (IESG)

Section: 18.2.5

Original Text
-------------
   The server MUST include a Server Identifier option containing the
   server's DUID in the Reply message.  If the client included a Client
   Identification option in the Information-request message, the server
   copies that option to the Reply message.

Corrected Text
--------------
   The server MUST include a Server Identifier option containing the
   server's DUID in the Reply message.  If the client included a Client
   Identifier option in the Information-request message, the server
   copies that option to the Reply message.

Notes
-----
Incorrect option name

-- Verifier note --
Indeed, minor typo in "Client Identification" rather than "Client Identifier".

--------------------------------------
RFC3315 (draft-ietf-dhc-dhcpv6-28)
--------------------------------------
Title               : Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
Publication Date    : July 2003
Author(s)           : R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney
Category            : PROPOSED STANDARD
Source              : Dynamic Host Configuration
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: Bernie Volz <[email-masked]>
Date: Fri, 5 Feb 2021 07:09:38 -0500

While this is an error, RFC8415 has replaced RFC3315 and that issue does not exit in RFC8415.

- Bernie

> On Feb 5, 2021, at 4:50 AM, RFC Errata System <[email-masked]> wrote:
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 5 Feb 2021 12:16:20 +0000

Agreed Bernie, but, the process (reading the IESG statement on errata https://www.ietf.org/about/groups/iesg/statements/processing-rfc-errata/ ) is to process obsolete document as non-obsolete.

And, for sure, RFC 8415 did not make the same typo ;-) so, thank, you for your confirmation.

-éric

-----Original Message-----
From: Bernie Volz <[email-masked]>
Date: Friday, 5 February 2021 at 13:09
To: RFC Errata System <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Errata Held for Document Update] RFC3315 (5450)

    - Bernie