Subject: [dhcwg] [Editorial Errata Reported] RFC2131 (6618)

From: RFC Errata System <[email-masked]>
Date: Tue, 22 Jun 2021 06:03:09 -0700 (PDT)

The following errata report has been submitted for RFC2131,
"Dynamic Host Configuration Protocol".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6618

--------------------------------------
Type: Editorial
Reported by: Rubén L.M. <[email-masked]>

Section: 3.1

Original Text
-------------
                Server          Client          Server
            (not selected)                    (selected)

                  v               v               v
                  |               |               |
                  |     Begins initialization     |
                  |               |               |
                  | _____________/|\____________  |
                  |/DHCPDISCOVER | DHCPDISCOVER  \|
                  |               |               |
              Determines          |          Determines
             configuration        |         configuration
                  |               |               |
                  |\             |  ____________/ |
                  | \________    | /DHCPOFFER     |
                  | DHCPOFFER\   |/               |
                  |           \  |                |
                  |       Collects replies        |
                  |             \|                |
                  |     Selects configuration     |
                  |               |               |
                  | _____________/|\____________  |
                  |/ DHCPREQUEST  |  DHCPREQUEST\ |
                  |               |               |
                  |               |     Commits configuration
                  |               |               |
                  |               | _____________/|
                  |               |/ DHCPACK      |
                  |               |               |
                  |    Initialization complete    |
                  |               |               |
                  .               .               .
                  .               .               .
                  |               |               |
                  |      Graceful shutdown        |
                  |               |               |
                  |               |\ ____________ |
                  |               | DHCPRELEASE  \|
                  |               |               |
                  |               |        Discards lease
                  |               |               |
                  v               v               v
     Figure 3: Timeline diagram of messages exchanged between DHCP
               client and servers when allocating a new network address

Corrected Text
--------------
                Server          Client          Server
            (not selected)                    (selected)

                  v               v               v
                  |               |               |
                  |     Begins initialization     |
                  |               |               |
                  | _____________/|\_____________ |
                  |/DHCPDISCOVER  | DHCPDISCOVER \|
                  |               |               |
              Determines          |          Determines
             configuration        |         configuration
                  |               |               |
                  |\              |  ____________/|
                  | \_________    | /DHCPOFFER    |
                  |  DHCPOFFER\   |/              |
                  |            \  |               |
                  |       Collects replies        |
                  |              \|               |
                  |     Selects configuration     |
                  |               |               |
                  | _____________/|\____________  |
                  |/ DHCPREQUEST  |  DHCPREQUEST\ |
                  |               |               |
                  |               |     Commits configuration
                  |               |               |
                  |               | _____________/|
                  |               |/ DHCPACK      |
                  |               |               |
                  |    Initialization complete    |
                  |               |               |
                  .               .               .
                  .               .               .
                  |               |               |
                  |      Graceful shutdown        |
                  |               |               |
                  |               |\ ____________ |
                  |               | DHCPRELEASE  \|
                  |               |               |
                  |               |        Discards lease
                  |               |               |
                  v               v               v
     Figure 3: Timeline diagram of messages exchanged between DHCP
               client and servers when allocating a new network address

Notes
-----
alignment

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2131 (no draft string recorded)
--------------------------------------
Title               : Dynamic Host Configuration Protocol
Publication Date    : March 1997
Author(s)           : R. Droms
Category            : DRAFT STANDARD
Source              : Dynamic Host Configuration
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 22 Jun 2021 13:21:17 +0000

Yes, the figure around the "DHCPDISCOVER" and "DHCPOFFER" is not properly aligned for the "Client" column.

- Bernie

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: Tuesday, June 22, 2021 9:03 AM
To: [email-masked]; [email-masked]; Eric Vyncke (evyncke) <[email-masked]>; Bernie Volz (volz) <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC2131 (6618)

The following errata report has been submitted for RFC2131, "Dynamic Host Configuration Protocol".

Section: 3.1

Original Text
-------------
                Server          Client          Server

                  v               v               v
                  |               |               |

Corrected Text
--------------
                Server          Client          Server

                  v               v               v
                  |               |               |

Notes
-----
alignment

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.