Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-21.txt

From: [email-masked]
Date: Mon, 14 Jun 2021 08:01:56 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Author          : Ian Farrer
	Filename        : draft-ietf-dhc-dhcpv6-yang-21.txt
	Pages           : 102
	Date            : 2021-06-14

Abstract:
   This document describes YANG data modules for the configuration and
   management of DHCPv6 (Dynamic Host Configuration Protocol for IPv6)
   servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-21

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-21

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Mon, 14 Jun 2021 17:04:09 +0200

Hi,

I’ve just posted -21 incorporating the comments from Tom and Bernie. Thanks!

As there have been a few emails, here’s a summary of all of the changes in this version:

Tom’s comments -
IANA Considerations corrected for the new prefixes.

Module revision statements updated.

Duid-base description fixed.

Bernies comments - 
All instances of bytes are now octets.

0x is now used instead of leading zeros throughout.

All instances of ‘modelled’ are now ‘modeled’, despite auto-correct’s best efforts. 

Additionally - 

For the client module, prefix delegation is now enabled by a feature (as is the server and relay modules). This is because some largely deployed DHCPv6 client implementations do not support PD.

This has also made me wonder if ia_na and ia_ta should be features so that stateless DHCP client configuration is possible. I’d appreciate any input on this.

Thanks,
Ian

> On 14. Jun 2021, at 17:01, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 14 Jun 2021 16:06:12 +0000

Thanks Ian.

Do you think it should go to WGLC now? Or, did you want to wait a bit? (We probably should avoid running the WGLC during IETF-111, so best to do soon or just after IETF-111).

- Bernie

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, June 14, 2021 11:04 AM
To: dhcwg <[email-masked]>; tom petch <[email-masked]>; Bernie Volz (volz) <[email-masked]>
Subject: Re: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-21.txt

Hi,

Tom’s comments -

Bernies comments - 

Additionally - 

Thanks,
Ian

---

From: tom petch <[email-masked]>
Date: Tue, 15 Jun 2021 10:07:31 +0000

Sent: 14 June 2021 16:04
Hi,

<tp>
I was surprised by an AD the other day when they raised a DISCUSS because the URL were http: and not https: so in the interests of lightening their load, I think that that needs changing at some point in all the places where it appears such as WG Web.

Separately, the examples use assigned enterprise numbers, those of Cisco and NSC; RFC5612 assigns an enterprise number for documentation use which I think should be used instead of '10' but there is only the one number assigned so if two are needed, I am unsure what should be done about '9'.

With Prefix Delegation becoming an feature, then any vendor specific augment for PD will need to reference that.  There are no such examples.  Worth a mention?  probably not.

Tom Petch

Tom’s comments -

Bernies comments -

Additionally -

Thanks,
Ian

---

From: [email-masked]
Date: Fri, 18 Jun 2021 17:05:36 +0200

Hi Bernie,

We’re currently working on a client implementation and there’s some useful learning from this that I need to feed back into the module so there’s going to need to be another update before WGLC.

I’ll change the example Enterprise number as well.

Thanks, Ian

> On 14. Jun 2021, at 18:06, Bernie Volz (volz) <[email-masked]> wrote:
> 
> Thanks Ian.
>

---

From: Timothy Winters <[email-masked]>
Date: Fri, 18 Jun 2021 12:54:16 -0400

Hi Ian,

Thanks for the update, I'll be starting on the shepherd write-up for this
draft after your next revision.

~Tim

On Fri, Jun 18, 2021 at 11:05 AM <[email-masked]> wrote:

> Hi Bernie,
>
> We’re currently working on a client implementation and there’s some useful
> learning from this that I need to feed back into the module so there’s
> going to need to be another update before WGLC.
>
> > Do you think it should go to WGLC now? Or, did you want to wait a bit?
> (We probably should avoid running the WGLC during IETF-111, so best to do
> soon or just after IETF-111).
> >
> > - Bernie
> >
> > For the client module, prefix delegation is now enabled by a feature (as
> is the server and relay modules). This is because some largely deployed
> DHCPv6 client implementations do not support PD.
> >
> > This has also made me wonder if ia_na and ia_ta should be features so
> that stateless DHCP client configuration is possible. I’d appreciate any
> input on this.
> >
> > Thanks,
> > Ian
> >