Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-22.txt

From: [email-masked]
Date: Fri, 02 Jul 2021 05:37:59 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Dynamic Host Configuration WG of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Author          : Ian Farrer
	Filename        : draft-ietf-dhc-dhcpv6-yang-22.txt
	Pages           : 102
	Date            : 2021-07-02

Abstract:
   This document describes YANG data modules for the configuration and
   management of DHCPv6 (Dynamic Host Configuration Protocol for IPv6)
   servers, relays, and clients.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-dhc-dhcpv6-yang-22

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-yang-22

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: [email-masked]
Date: Fri, 2 Jul 2021 14:55:04 +0200

Hi,

I’ve just posted an update which addresses Tom’s most recent comments, plus some additional fixes and optimisations, listed below. With this update, I think the draft is ready for WGLC.

Thanks,
Ian

Changes in this version:

* For examples where an Enterprise number is needed, 32473 is now used, per Tom’s comment. The example XML no longer contains two instances of the vendor specific information option.

* http has been replaced with https, per Tom’s comment.

* Ia-na and ia-ta (as wall as ia-pd) are now enabled by features in the client module. This allows for clients that don’t support ia-ta (e.g. ISC) and also stateless DHCP client configuration.

* Status code option has been removed from configuration as there is no case that this should be configured. In it’s place, a status group is used by the operational nodes to store the last status code/message that has been sent (server) or received (client)

* The relay now does not have any status code information. I’m not aware of any cases where the relay should generate or store status codes for e.g. a pd-lease, but would appreciate feedback if this is incorrect.

* Client lease information common nodes are now a group to avoid duplication.

* Changed high level order in modules to put rpcs before notifications as per RFC8407.

* Changed all rpcs and notifications to use relative paths in their leafrefs (some were absolute)

* Changed the option set example XML to illustrate how new option definitions can be augmented, using the SIP domain name option example from Appendix B.

> On 2. Jul 2021, at 14:37, [email-masked] wrote:
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: tom petch <[email-masked]>
Date: Mon, 5 Jul 2021 10:38:45 +0000

________________________________________
From: dhcwg <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: 02 July 2021 13:55
To: dhcwg
Subject: Re: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-22.txt

Hi,

<tp>

Looks good at first sight.

Tom Petch

Thanks,
Ian

Changes in this version: