Subject: [dhcwg] Murray Kucherawy's No Objection on draft-ietf-dhc-dhcpv6-yang-24: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Wed, 15 Dec 2021 07:55:52 -0800

Murray Kucherawy has entered the following ballot position for
draft-ietf-dhc-dhcpv6-yang-24: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I suggest breaking Section 6 into two subsections, one for each batch of
registry operations.

A possibly ignorant question about YANG modules: Since RFCs 3319 and 8987 are
referenced from within the module itself, shouldn't they be normative
references?

---

From: <[email-masked]>
Date: Fri, 17 Dec 2021 13:25:55 +0000

Hi Murray,

RFC 3319 does not need to be listed as normative as it is cited in an example module. 

RFC 8987 is OK to be cited as informative given that it does only specify a requirement. It does not specify the inputs/outputs. That's consistent with rfc8407#section-3.9:

   If the reference statement identifies an informative reference that
   identifies a separate document, a corresponding informative reference
   to that document MAY appear in the Informative References section. 

BTW, the I-D has to cite 8987 in the core text. 

Cheers,
Med

> -----Message d'origine-----
> De : dhcwg <[email-masked]> De la part de Murray Kucherawy via
> Datatracker
> Envoyé : mercredi 15 décembre 2021 16:56
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]
> Objet : [dhcwg] Murray Kucherawy's No Objection on draft-ietf-dhc-dhcpv6-
> yang-24: (with COMMENT)
> 
> A possibly ignorant question about YANG modules: Since RFCs 3319 and 8987
> are referenced from within the module itself, shouldn't they be normative
> references?
> 
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.