Subject: RE: [Dhcwg] Re: Change to 'seconds' field in DHCP message header

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Mon, 27 Aug 2001 08:46:40 -0500

I supported the change to 1/10th of a second (would even support a change to 1 second as mentioned previously).

I agree with Ralph. I don't see the need to waste the additional bytes.

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]]
Sent: Monday, August 27, 2001 9:12 AM
To: [email-masked]
Subject: [Dhcwg] Re: Change to 'seconds' field in DHCP message header

(Please note that this message has been sent to the new dhc WG mailing list, [email-masked].  The current mailing lists, [email-masked] and [email-masked], will be taken off line tomorrow, Aug 28, around 4PM.  I will arrange for e-mail to the old lists to be forwarded to [email-masked] for a couple of months.  I will also save the archives from the old lists and make them available on line as soon as possible. - RD)

Another alternative for greater range would be to define the units of the data value to be tenths of a second.  My intuition is that tenths of a second should be sufficiently precise...

Can anyone give us the benefit of experience with the 'secs' field in DHCPv4?  There hasn't been any interest in defining a new option with greater range or precision than the current 0-255 seconds measured in seconds.  Has the range or precision in DHCPv4 been inadequate in any specific instance?

- Ralph

At 10:44 PM 8/26/2001 -0400, you wrote:

>> I think 16-bits is enough (with the counter maxing out). If an attempt goes
>> on that long, no server is probably available and the relays (or servers)
>> will likely long have taken alternative actions (which probably failed as
>> well). So, I see little need to make this more than 16-bits.
>
>That's a pretty set of suppositions, but you may well be wrong.   Why
>not make sure that it works if you are?
>
>                               _MelloN_

_______________________________________________
Dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Mon, 27 Aug 2001 10:04:38 -0400

(All - please respond through [email-masked]. - RD)

>From: "Bernie Volz (EUD)" <[email-masked]>
>To: DHCPv6 discussion list <[email-masked]>
>Subject: RE: Change to 'seconds' field in DHCP message header 
>Date: Mon, 27 Aug 2001 08:41:11 -0500
>X-Mailer: Internet Mail Service (5.5.2653.19)
>Reply-To: [email-masked]
>Sender: [email-masked]
>
>Because it wastes several additional bytes for what I believe is very little gain. 
>
>Perhaps there are some bizarre future applications where we want to wait for "long" periods of time, but I can't see any value in this. What this is to be used for is failover type support (either failover protocol or just multiple servers, one which is to be used unless the other fails).
>
>If we're really concerned about being able to store long times, why don't we just make this seconds? I can't see any need to make the resolution 100ths of seconds and with seconds we can store many hours worth of time.
>
>- Bernie 
>
>From: Ted Lemon [<mailto:[email-masked]>mailto:[email-masked]] 
>Sent: Sunday, August 26, 2001 10:44 PM 
>To: DHCPv6 discussion list 
>Subject: Re: Change to 'seconds' field in DHCP message header 
>
>

dhcwg mailing list
[email-masked]