Subject: [dhcwg] Error code option

From: Ralph Droms <[email-masked]>
Date: Thu, 20 Sep 2001 10:43:26 -0400

From the issues list generated at the WG meeting in London:

    * Add an "error code" option, to indicate errors
      not connected with a specific option

      WG consensus: yes; should allow inclusion of text message

What error codes do we know of today that should be defined for
this option?  Please respond to me or to the mailing list...

- Ralph

_______________________________________________
dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Thirumalesh Bhat" <[email-masked]>
Date: Thu, 20 Sep 2001 08:59:48 -0700

The error code option can be defined as follows:

+-----+-----+-----+-----+-----+-----+-----+-----+ ...
|    opt no |   length  |   error   |  miscellaneous info such as err
string 
+-----+-----+-----+-----+-----+-----+-----+-----+ ...

We should define a basic set of error codes that can be extended by the
implementation.

Some of the error codes I can think of are:

a) The server is out of addresses
b) The server is not able to service the client request (Need for
multiple error codes?)
c) Invalid request for address
d) Requested option not available
e) The client could not be authenticated 

thx

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Thursday, September 20, 2001 7:43 AM
To: [email-masked]
Subject: [dhcwg] Error code option

- Ralph

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 20 Sep 2001 14:11:50 -0500

I think Ralph's previous drafts (-19) had a good set of error codes as a base.

One other item ... I rather like the structure of error codes such as used by FTP and SMTP. By this I mean that having ranges of error code that indicate degrees of failure or status are nice. That way, if a new code is added, a client need not necessarily understand that explicit code to still behave properly.

For my concepts of Confirm processing, there will need to be some type of response from a server that tells the client "the prefixes are OK but I can't confirm the individual addresses" - this really is more of a status.

- Bernie

-----Original Message-----
From: Thirumalesh Bhat [mailto:[email-masked]]
Sent: Thursday, September 20, 2001 12:00 PM
To: Ralph Droms; [email-masked]
Subject: RE: [dhcwg] Error code option

thx

-----Original Message-----
From: Ralph Droms [mailto:[email-masked]] 
Sent: Thursday, September 20, 2001 7:43 AM
To: [email-masked]
Subject: [dhcwg] Error code option

- Ralph