Subject: [dhcwg] Overconstraining

From: "Guja, ArturX" <[email-masked]>
Date: Fri, 21 Sep 2001 09:32:55 +0200

Hello,

One thing I noticed while implementing draft 19.
It says, that after failing to get a REPLY to a REQUEST,
the client MUST abort configuration attempt. Isn't it a bit harsh
on the poor soul :)))

After all, the server, whose ADVERTISE the client chose to answer,
could have been shutdown or disconnected in the meantime.
Shouldn't we allow the client to select another ADVERTISE and try again.
I'd even risk allowing it to send a SOLICIT again, although I appreciate it
could
lead to perpetual flood of SOLICITS.

But If a client got more than one ADVERTISE, it COULD select another one
and try again, possibly with a different server.

What do you think?

Artur G.
(TUG student)

_______________________________________________
dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Jim Bound <[email-masked]>
Date: Fri, 21 Sep 2001 23:52:19 -0400 (EDT)

If it was a SHOULD would that be fine?  I don't think going back to
solicit in the spec is prudent though?

/jim

---

From: Artur Guja <[email-masked]>
Date: Sat, 22 Sep 2001 12:59:01 +0200

JB> If it was a SHOULD would that be fine?  I don't think going back to
JB> solicit in the spec is prudent though?

Of course, going back to SOLICIT is a bit wierd.

But if the client got more than one advertise,
it chooses the best one. If this one fails,
it could settle on a less preferable one.
Of course, it there was only one ADVERTISE,
or the rest of them were unacceptable, the client
MUST abort (in my opinion), or else we could get an
infinite loop of SOLICITs.

Artur

---

From: Jim Bound <[email-masked]>
Date: Sat, 22 Sep 2001 12:23:55 -0400 (EDT)

ralph and I got input and it will be clear in the next rev that the client
can go use less preferred advertise if it chooses.  making it a SHOULD
would permit implementors to do this.  SHOULD means do this unless you
have a really good reason to not do this.

/jim