Subject: [dhcwg] DHC WG last call for DHCPv6

From: Ralph Droms <[email-masked]>
Date: Wed, 09 Jan 2002 13:38:35 -0500

If you've reviewed the most recent rev of the DHCPv6 spec 
<draft-ietf-dhc-dhcpv6-22.txt>, please post your comments to [email-masked] 
- even if your comments are as brief as "looks ready for submission for 
Proposed Standard"...

- Ralph Droms

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 10 Jan 2002 16:34:36 -0600

Here are some comments regarding the 22 draft.

First off, I think this should pass WG Last Call. We should issue a revised -23 to fix some of the typographical errors and insert minor clarifications before submitting to IESG Last Call. I don't believe there are any significant issues with -22.

Ralph, et al, I'm sorry if I repeat some of the earlier reported items.

- The use of "Information-Request" and "Inform" for the single message needs to be cleaned up. The msg-type is "Inform" and the message name is "Information-Request". The text in 18.2.5 and 18.2.8 should be merged.

- Page 10 in the -22 draft is blank.

- I would like to see the text in 18.1.5 changed to not require a client to specify a DUID option. Change the third paragraph to read "The client SHOULD include a DUID option...". We might want to add a sentence here or in 18.2.5/8 that a server is allowed to discard Inform messages that do not contain a DUID (just as server may discard messages that contain a DUID that it does not know or wish to service).

Perhaps another point is that without a DUID a client can not get client specific options.

- In 22.5 (Requested Temporary Addresses (RTA) Option), can the paragraph after the option format be replaced with the following (avoid double negative):

"This option MUST only be sent by a client and only in a Solicit, Request, Renew, or Rebind message. It MUST only appear encapsulated within an Identity Association option. A client MUST only include this option when it wants additional temporary addresses allocated; a client SHOULD NOT send the option if num-requested is 0."

- Before going to the IESG Last Call, should we add a FQDN option? Basically identical to the IPv4 option, but instead of A records, we specify AAAA records are updated? I think this option is fairly important.

- Finally, I'll raise an old issue ... if we use a totally separate option space for DHCPv6 options, we need to make sure that IANA doesn't assign the DUID option an option number that would conflict with the DHCPv4 options used for the DHCID RR - and that would need to apply forever (even if old DHCPv4 option numbers are reclaimed and reused).

Thanks.

- Bernie Volz