Subject: [dhcwg] About draft No. 22

From: "Dany JUNG" <[email-masked]>
Date: Wed, 2 Jan 2002 15:23:59 +0900

Hi all~
 
While I was reading draft-22.txt, I got to have several questions. 
I would like to ask you all and share information as a fellow from now
on.
I have been an observer, although this is a great community.
I would love to work more actively.
 
1. Why does Reply message have DUID option in this chart?
 
 B. Appearance of Options in Message Types
 
   The following table indicates with a "*" the options are allowed in
   each DHCP message type:

        DUID   IA    RTA   ORO  Pref  Time Client Server DSTM  DSTM
                                             Forw.  Forw. Addr  Tunn
Solicit    *     *     *     *
Advert.    *     *     *           *     *                 *     *
Request    *     *     *     *
Confirm     *     *     *     *
Renew      *     *     *     *
Rebind     *     *     *     *
Decline    *     *     *     *
Release    *     *     *     *
Reply      *     *     *           *     *                 *     *
Reconf.    *                 *
Inform.    *                 *
R-forw.                                        *     *
R-repl.                                        *     *

2. What do you configure for reply message's options if you are
questioned to assign IPv6 address and 
IPv4 address for DSTM in request message simultaneously ?

Options of Reply message are as follow
-IA option
-IA Address option
-DSTM Global IPv4 address option
-IA option (for IPv4-mapped IPv6 address)
-IA Address option  (for IPv4-mapped IPv6 address)
 
Is this possible?? 

To work more actively, I am going to ask you more questions, and look
forward to hearing from you.
I will try to reply your questions as many as I can.

Have a nice day !!

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 2 Jan 2002 08:18:00 -0600

RE Question 1, while it may not strictly be needed in the Reply, having the client's DUID may be useful for authentication purposes.
 
RE Question 2, the Reply would have:
 
- IA option (encapsulating the IA Address option) for "regular" addresses
- DSTM Global IPv4 Address option (encapsulating an IA option, which encapsulates the IA Address Option, for the IPv4-mapped IPv6 address).

- Bernie Volz

-----Original Message-----
From: Dany JUNG [mailto:[email-masked]]
Sent: Wednesday, January 02, 2002 1:24 AM
To: [email-masked]
Subject: [dhcwg] About draft No. 22

Hi all~

I would like to ask you all and share information as a fellow from now on.

   each DHCP message type:

                                             Forw.  Forw. Addr  Tunn

Solicit    *     *     *     *

Advert.    *     *     *           *     *                 *     *

Request    *     *     *     *

Confirm     *     *     *     *

Renew      *     *     *     *

Rebind     *     *     *     *

Decline    *     *     *     *

Release    *     *     *     *

Reply      *     *     *           *     *                 *     *

Reconf.    *                 *

Inform.    *                 *

R-forw.                                        *     *

R-repl.                                        *     *

2. What do you configure for reply message's options if you are questioned to assign IPv6 address and 

 

-IA option

-IA Address option

Is this possible?? 

To work more actively, I am going to ask you more questions, and look forward to hearing from you.

 

Have a nice day !!