Subject: RE: [dhcwg] Minutes from meeting in SLC, 12/10

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Mon, 7 Jan 2002 20:41:30 -0600

It is very simple to implement. The check itself is basically one line of code:
	if (secs > threshold) <respond to client>

The configuration of the parameter is likely the more complex!

I will consider this change in the revision of RFC 3074 I'm planning - primarily to incorporate DHCPv6 (DUID).

- Bernie

-----Original Message-----
From: Thomas Narten [mailto:[email-masked]]
Sent: Monday, January 07, 2002 9:16 PM
To: Steve Gonczi
Cc: [email-masked]
Subject: Re: [dhcwg] Minutes from meeting in SLC, 12/10 

> As I recall it did not seem reasonable to mandate 
> site admin policy. There was a discussion on the WG list
> at the time, and we ended up making the _presence_ of this
> knob optional.

Right. If the implementation is optional, the operator may not have
the option to enable, i.e., if the products didn't implement the
feature.

> Perhaps, we should mandate the _support_ of this option
> in implementations, and just allow it to be turned off.

That might have been better. And would it have caused a lot of
hardship to implement?

Thomas

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Mon, 7 Jan 2002 22:44:12 -0500

My only recollection as to why there might have been a reason to make this 
optional was that it was unknown at the time whether all clients actually 
put real values in the secs field of the DHCP packet.   I think it's fine 
to make support for this in agents that implement load balancing mandatory 
anyway, though - all of the major clients of which I am aware do correctly 
support the secs field.