Subject: [dhcwg] About solicit and advertise messages in Dhcpv6

From: "Kyemyung Jung" <[email-masked]>
Date: Mon, 14 Jan 2002 11:26:10 +0900

I am developing Dhcpv6 now and have a piece of questions
I am wondering about solicit and advertise messages.

If a server receives a solicit message, which includes IA with encapsulated IA address option, from client,
does dhcpv6 server have to assign IPv6 address?

If not, what is the main purpose that solicit message includes IA and IA Address option?

I think that server just informs whether it can assign addresses with IA or not, not with IA Address option
Isn't it right?

Thanks for your reading. 
I hope that I receive your definite answer as soon as possible.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Mon, 14 Jan 2002 08:22:15 -0600

I think this is a server policy issue; the server could chose to give the client one or more of the addresses it requested (if not in use by another client) or it could ignore them. The server may also assign additional addresses.

Depending on what the client wants, it can look at the Advertise's received and chose the one that it likes best (for example, the one that gives it the addresses it requested).

- Bernie

-----Original Message-----
From: Kyemyung Jung [mailto:[email-masked]]
Sent: Sunday, January 13, 2002 9:26 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: About solicit and advertise messages in Dhcpv6

Thanks for your reading.