Subject: [dhcwg] Status length

From: Anders Vestlund <[email-masked]>
Date: Wed, 10 Apr 2002 13:42:52 +0200

Hi,

I'm currently implementing a parse function for dhcp ipv6 messages.

While reading draft 23 I noticed that status have different lengths in
different options:
IA option: IA Status = 8 bits
IAADDR option: addr status = 7 bits
STATUS_CODE option:  status-code = 16 bits

Is there a reason for this, or why don't they have the same lengths ?
(It would result in a shorter parse function : ) )

Best Regards
Anders Vestlund
Ericsson ///

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 10 Apr 2002 22:06:08 -0500

This is something we should correct.

As it is likely the T-Bit will disappear from the IA-Address option since we'll likely be adding a Temporary-IA option to carry temporary addresses (RTA option would also go away), I'd suggest we standardize on 8-bit values all around.

Thanks for reporting this.

- Bernie Volz

-----Original Message-----
From: Anders Vestlund [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 7:43 AM
To: [email-masked]
Subject: [dhcwg] Status length

Hi,

Best Regards
Anders Vestlund
Ericsson ///