Subject: [dhcwg] Re: Re: udhcpd Win98 interoperability

From: [email-masked]
Date: Thu, 22 Aug 2002 13:43:47 +0200

Russ Dill <[email-masked]> schrieb am 22.08.02 00:38:23: 
> > Hmm... I looked up RFC2131 and found that the server in fact MUST remain silent if 
it    
> > has no notion of the client AND the network is correct. But if the network is not   
> > correct, the server SHOULD send NAK.    
> >     
> > If you consider a notebook being plugged from time to time to different subnets, 
the   
> > remain silent behavior is quite ugly. The user would have to wait some days for 
the  
> > lease to time out before being able to access the network.  
>  
> ok, I'm actually a little confused, here is my parsing of the rfc 
>  
> If the DHCP server detects that the client is on the wrong  
> net, then the server SHOULD send a DHCPNAK message to the 
> client. 
>  
> If the network is correct, then the DHCP server should 
> check if the client's notion of its IP address is correct. 
>  
> If not, then the server SHOULD send a DHCPNAK message to 
> the client. 
>  
> If the DHCP server has no record of this client, then it 
> MUST remain silent, and MAY output a warning to the 
> network administrator. This behavior is necessary for 
> peaceful coexistence of non-communicating DHCP servers on 
> the same wire. 
>  
> at first, everything is simple 
>  
> if (wrong net) { 
>  should nak; 
> } else { 
>  if (!ok ip) { 
>   should nak; 
>  } 
> } 
>  
> but then the "If the DHCP server has no record of this client" clause is 
> thrown in. At what stage of the block does this go in? I would say this 
> clause would go *before* 'if (wrong net)'. 
>  
> I'll cc this to the Dynamic Host Configuration working group. Hopefully 
> they'll have some answers. 
>  
 
I would replace (!ok ip) by (requested ip is ours but is no longer/has never been 
assigned to the requesting client). Then the conditions (wrong net) and (requested ip 
is ours but...) are mutually exclusive. 
 
So my parsing of the RFC would look loke that: 
 
if (wrong net) { 
  should nak; 
} else if (requested ip is ours but...) { 
  should nak; 
} else { 
  remain silent; 
} 
 
Greetings, 
Christoph 
______________________________________________________________________________
Die clevere Geldreserve: der DiBa-Privatkredit. Funktioniert wie ein Dispo, 
ist aber viel günstiger! Alle Infos: http://diba.web.de/?mc=021104

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Russ Dill <[email-masked]>
Date: 22 Aug 2002 11:25:05 -0700

> } else if (requested ip is ours but...) { 

define 'ours' a little better, do you mean if there is a static mapping
for the address that we take care of?