Subject: RE: [dhcwg] empty CHADDR and DHCPINFORM option 252

From: Max Nitribitt <[email-masked]>
Date: Wed, 30 Jul 2003 08:15:55 -0700 (PDT)

Hi Dirk,

thanks a lot for your quick reply! 

What would you think could be the worst thing to
happen, if I use an empty chaddr field or an unknown
dummy address?  I definitely don't want my application
to screw up the DHCP server (or even worse the network
administrator :)

regards 

Max

--- Van Aken Dirk <[email-masked]> wrote:
> Hi Max, seee a comment inline.
> 
> > -----Original Message-----
> > From: Max Nitribitt [mailto:[email-masked]]
> > Sent: woensdag 30 juli 2003 10:06
> > To: [email-masked]
> > Subject: [dhcwg] empty CHADDR and DHCPINFORM
> option 252
> > 
> > 
> > Hi,
> > 
> > I'm trying to enable a java application for proxy
> > auto-configuration via DHCP. Therefore I'm sending
> a
> > DHCPInform request for parameter (option) 252.
> > Everything works fine so far. There is only one
> > limitation: 
> > 
> > RFC2131 states client's hardware address is needed
> for
> > DHCPInform requests. As accessing the MAC address
> is
> > not a  trivial task in java and requires platform
> > dependent code, I would like to do the request
> without
> > supplying a client hardware address. In our
> companies
> > network I get the information that I want even
> though
> > I send an empty CHADDR. 
> > 
> > My questions are: 
> > * Can I expect DHCP-Servers to send an answer on
> > DHCPInform requests even though I don't supply my
> > Mac-Address, but only my IP (CIADDR)? 
> > * Is there something like a "dummy MAC ADDRESS"
> that
> > doesn't collide with "real NIC Addresses" and is
> > accepted by all DHCP-Servers? 
> 
> On the "Dummy MAC ADDRESS" I would suggest the
> following.
> 
> You could rely an a Group (Multicast) MAC address
> i.e. by putting the first
> bit (I/G bit) of a MAC address to 1. I assume that
> DHCP servers make no
> distinction between Group MAC addresses and
> individual MAC addresses. In
> addition to avoid possible conflicts with OUI's
> (first 24 bits of a MAC
> address) from various NIC vendors I would suggest to
> put the U/L bit to 1
> (U/L= Universally administered/Locally
> administered). So in this way you
> have a dummy MAC address that is not in conflict
> with any vendor and any
> unicast MAC address. Whether the DHCP server can get
> confused is another
> matter ...
> 
> Regards - Dirk
> 
> > * Or do I really need to acquire the Hardware
> address
> > with ugly OS-dependent code (via ipconfig \all/
> > ifconfig... )?
> > 
> > thank's a lot
> > 
> > max
> >  
> >   
> > 
> > __________________________________
> > Do you Yahoo!?
> > Yahoo! SiteBuilder - Free, easy-to-use web site
> design software
> > http://sitebuilder.yahoo.com
> > 
> > _______________________________________________
> > dhcwg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/dhcwg
> > 

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Jul 2003 12:12:47 -0500

> > unicast MAC address. Whether the DHCP server can get

Eek!   If you do this, and the DHCP server is really broken, it might try to 
send a packet to that destination address.   So I think this is a bad idea.   
If you set hlen to zero, the server isn't going to be able to send a packet 
to the chaddr address, which I think is a little safer, particularly since 
there's an RFC requiring servers to handle this case.

---

From: Van Aken Dirk <[email-masked]>
Date: Wed, 30 Jul 2003 10:39:57 +0200

> Subject: [dhcwg] empty CHADDR and DHCPINFORM option 252
> 
> 
> Hi,
> 
> auto-configuration via DHCP. Therefore I'm sending a
> RFC2131 states client's hardware address is needed for
> DHCPInform requests. As accessing the MAC address is
> dependent code, I would like to do the request without
> supplying a client hardware address. In our companies
> network I get the information that I want even though
> I send an empty CHADDR. 
> 
> My questions are: 
> * Is there something like a "dummy MAC ADDRESS" that

On the "Dummy MAC ADDRESS" I would suggest the following.

You could rely an a Group (Multicast) MAC address i.e. by putting the first
bit (I/G bit) of a MAC address to 1. I assume that DHCP servers make no
distinction between Group MAC addresses and individual MAC addresses. In
addition to avoid possible conflicts with OUI's (first 24 bits of a MAC
address) from various NIC vendors I would suggest to put the U/L bit to 1
(U/L= Universally administered/Locally administered). So in this way you
have a dummy MAC address that is not in conflict with any vendor and any
unicast MAC address. Whether the DHCP server can get confused is another
matter ...

Regards - Dirk

> * Or do I really need to acquire the Hardware address