Subject: [dhcwg] client programs.

From: "yuan zhang" <[email-masked]>
Date: Mon, 28 Jul 2003 13:31:20 +0800

Hi friends,

pls help me to sort out my confusion.

I wish to run my own program in my system and
I wish to try if that program can get a different IP
address( other than my computer) from the DHCP
server. I am reading on DHCP ( rfc 2131 etc) But
i find it difficult to decide if I can get 2 IP addresses
for two programs running at the same computer.
( ie; different IPs to same MAC address).

Is it possible ?? if so .. can u give me some helpful
resources/contacts/ links on it?

Regards and Thanks

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: [email-masked]
Date: Mon, 28 Jul 2003 13:42:28 +0800

Its possible by using different 'client id(entifier)' values. Server first checks the 'client id' field. So, even though 'chaddr' value will be same for both requests, as 'client id' field is different, server assigns different IP addresses. 

regards,
swamy.  

> -----Original Message-----
> From: ext yuan zhang [mailto:[email-masked]]
> Sent: Monday, July 28, 2003 11:01 AM
> To: [email-masked]
> Subject: [dhcwg] client programs.
> 
> 
> Hi friends,
>