Subject: WG: [dhcwg] I-D ACTION:draft-ietf-dhc-server-mib-09.txt

From: "Rentschler, Markus" <[email-masked]>
Date: Wed, 3 Dec 2003 09:22:08 +0100

dhcpv4ServerAddressTable OBJECT-TYPE 
		SYNTAX	 SEQUENCE OF  Dhcpv4ServerAddressEntry 
		MAX-ACCESS  not-accessible 
		STATUS  current 
		DESCRIPTION 
			"An optional list of addresses that are known by
this server. The list MUST contain addresses that have not
expired. The list MUST NOT contain addresses that have never been assigned
by the server UNLESS the 				lease is
pre-configured in the server (e.g., a static lease for a host). Expired
leases MAY appear during the 				time they are
'remembered' by the server for subsequent assignment to the same host." 
	::= { dhcpv4ServerConfiguration 4 } 
>  
> 	Dhcpv4ServerAddressEntry ::= SEQUENCE { 
> 		dhcpv4ServerAddress
> InetAddressIPv4, 
> 		dhcpv4ServerAddressSubnetMask
> InetAddressPrefixLength, 
> 		dhcpv4ServerAddressRange
> InetAddressIPv4, 
> 		dhcpv4ServerAddressLeaseType 			INTEGER, 
> 		dhcpv4ServerAddressTimeRemaining 		Unsigned32, 
> 		dhcpv4ServerAddressAllowedProtocol		 INTEGER, 
> 		dhcpv4ServerAddressServedProtocol 		INTEGER, 
> 		dhcpv4ServerAddressPhysicalAddress 	DhcpPhysicalAddress,
> 
> 		dhcpv4ServerAddressClientId
> OCTET STRING, 
> 		dhcpv4ServerAddressHostName
> SnmpAdminString, 
> 		dhcpv4ServerAddressDomainName 		SnmpAdminString 
> 	} 
> 
> This is a table with entries that contains both trigger criteria and
> parameters that are assigned after the trigger criteria have matched. Is
> this table intended to be used to configure static leases ? To me the text
> does not make this clear.
> 
> Best Regards,
>               Markus 
> 
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Barr Hibbs" <[email-masked]>
Date: Wed, 3 Dec 2003 15:00:39 -0800

The "dhcpv4ServerAddressTable" is NOT intended to be used for configuration
of a DHCPv4 server, nor are ANY other tables declared in the proposed MIB
extension.  If the text does not make this clear I will consider suggested
wording changes that will add the needed clarity.

--Barr

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Rentschler, Markus
> Sent: Wednesday, December 03, 2003 00:22
>
> this table intended to be used to configure static leases?  To
> me the text does not make this clear.
>