Subject: [dhcwg] Use of SNMP instead of leasequery

From: Ralph Droms <[email-masked]>
Date: Tue, 06 Apr 2004 20:20:37 -0400

Bert Wijnen:

Discuss:
- what is the status of this solution vs DHCP MIB solution (I thought
   they were competing solutions some time back).
   The DHC MIB has also been submitted for PS, no? I know it is still in
   MIB Doctor review... but it is a 2nd solution to same problem.
- The reasonings for not using SNMP and MIB seem very weak to me

Ted Hardie:

Discuss:

It's too bad that SNMP is off the table here, as that would give you a 
realistic
way to limit data to specific queries and queriers.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Kim Kinnear <[email-masked]>
Date: Thu, 08 Apr 2004 16:54:17 -0400

>  they were competing solutions some time back).

        The working group felt that there was sufficient utility
        in this solution to pursue it.

>  MIB Doctor review... but it is a 2nd solution to same problem.

        I think we all saw the MIB as a solution to a moderately
        different problem, with different performance characteristics
        and different protocol interpreter requirements.

        Cheers -- Kim

>It's too bad that SNMP is off the table here, as that would give you a realistic

---

From: "Richard Barr Hibbs" <[email-masked]>
Date: Wed, 14 Apr 2004 10:31:14 -0700

comments in-line

--Barr

> -----Original Message-----
> From: Ralph Droms
> Sent: Tuesday, 06 April 2004 17:21
>
> Bert Wijnen:
> - what is the status of this solution vs. DHCP MIB
> solution (I thought they were competing solutions
> some time back).
> - The DHC MIB has also been submitted for PS,
> no? I know it is still in MIB Doctor review... but
> it is a 2nd solution to same problem.
> - The reasoning for not using SNMP and MIB seem
> very weak to me
>
...the MIB effort grew out of traffic engineering and
troubleshooting activities at Pacific*Bell, and was
primarily intended as a method of gathering performance
statistics about the servers we operated and the load
presented to them by our very large installation [for that
time.]  Despite the presence in the proposed DHCPv4 server
MIB of objects that report configuration and [status]
information. DHCPLEASEQUERY is intended to provide detailed,
specific information about individual leases, while the MIB
was intended to provide more generic, server-wide aggregated
or summarized data.  Also, the DHCPLEASEQUERY message type
is not required to be supported by all DHCPv4 servers:  the
I-D does not make that demand for either existing or new
server implementations.

> Ted Hardie:
> It's too bad that SNMP is off the table here, as
> that would give you a realistic way to limit data
> to specific queries and queries.
>
...my primary objection to making the information reported
by responses to DHCPLEASEQUERY messages accessible through
the DHCPv4 server MIB is that processing of DHCPLEASEQUERY
messages is not required of all DHCPv4 servers:  my sense
from the MIB Doctor review of the proposed server MIB is
that defining optional MIB objects and objects for optional
features is discouraged.