Subject: Renw/Confirm messages

From: [email-masked]
Date: Tue, 3 Apr 2001 16:15:24 -0700

Hi,

	I have some questions regarding the rev 18 of the DHCPv6 draft.  The
	confirm and the rebind messages are sent with the server address set
	to 0.  The servers that receive it are supposed to return

			- Nobinding
			- Renw/ConfNoMatch
			- Unavail

	errors.  There  is a  chance  that  the  client  can  receive  error
	messages  from  more  than  one  server,  as  these  (confirm/renew)
	messages are  multicast.  The section on client  behaviour  does not
	say how it should deal with this multiple error messages.

	What should be the right  behaviour ?  Should the server  address be
	set to the server it received the IA from ?  

--
Regards,
Ebi

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 4 Apr 2001 08:00:55 -0500

My feeling on this is that we may want some more errors codes. I believe that the status could indicate:
- The binding is valid (success)
- The server has no information about the binding but the prefixes are valid (Nobinding?)
- The server has no information about the binding but the prefixes are bad (??)
- The server has no information, such as it may not be authorizative for the prefix(es) (?? - no response perhaps?)

Depending on the status, the client would either (a) be done (success), (b) drop the addresses (bad prefixes status), or (c) wait for a short period of time for better information and if none received, continue using the addresses.

This would let the client know quickly that it has moved to a new subnet or that it is still on the same subnet.

Note that a CONFIRM might be better handled on networks with Router Advertisements by waiting for one of these. The "bad prefix" status is to handle cases where there are no routers.

I think I provided a more detailed explaination of the above a few weeks ago. Please check the archive (www.dhcp.org has the links).

- Bernie Volz

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 03, 2001 7:15 PM
To: DHCPv6 discussion list
Subject: Renw/Confirm messages

Hi,

			- Nobinding
			- Renw/ConfNoMatch
			- Unavail

--
Regards,
Ebi