Subject: RE: Advertise when no addresses available (was: Re: A few additi onal items re: -19 draft)

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Fri, 27 Jul 2001 09:48:06 -0500

Jitesh/Ralph:

After thinking a bit more about this, there is merit in having the server respond.
This at least indicates to the client that the server does exist. And, it may be
that the server can provide some useful information to the client even though it
is unable to give it addresses. It may well be that some addresses are stateless
and these may be of sufficient scope to allow the client to obtain other useful
configuration information from the server even if it can not get addresses.

So, I agree with Jitesh that the best response is IA w/Unavail error. My reason for
this is:
- I want the server to respond (see above).
- Responding without the IA likely means to the client that the server is not willing
to give out addresses (but is willing to give other configuration parameters).

I do not agree with Jitesh that this will flood the network - clients are supposed
to retransmit Solicits periodically and will do so if no server exists anyway. The
retransmit timers are set to keep this traffic reasonable. Sure, if you had thousands
of clients, you could get a fair amount of traffic. But that's not likely on most
link technology in use today (to have that many clients). And, if it is a problem,
we better readjust the Solicit retransmit timers anyway.

I do believe we need to spell out the server behavior clearly. So, I would suggest
text as follows:

When responding to a Solicit, the server MUST handle client IA options as follows:
- If the server is not configured to offer any addresses to the client (or link),
it MUST not include the client's IA option(s) in the Advertise.
- If the server is configured to offer addresses to the client (or link) but has
no addresses to advertise at the moment, it MUST include the client's IA option(s)
with an error of "Unavail".
- If the server is configured to offer addresses and has addresses to offer, it
MUST include the client's IA option(s) filled out with address information [either
the prefixes or the full addresses, as is TBD].

If the above is done, a client can determine whether a server is capable of offering
it addresses or not, and whether addresses are presently available or not. In this
way, it can determine which server to use (if it needs addresses, use the highest
preference server that has addresses available, if none, use the server that can
offer addresses but has none at the moment, ...).

- Bernie

-----Original Message-----
From: Jitesh N Verma [mailto:[email-masked]]
Sent: Friday, July 27, 2001 9:45 AM
To: DHCPv6 discussion list
Subject: Re: Advertise when no addresses available (was: Re: A few
additional items re: -19 draft)

Ralph,
	If the server does not respond, client will keep sending Solicit
message, flooding the network. This is particularly true when there is only
one server in the network. (If there are multiple server in the network, other
servers may respond. No problem in this case). Please keep in mind that lease
times are not going to be just few seconds. What I mean to say is that if the
IP addresses are not available currently, it may not be available for quite
some time.
	Looking at the various options, I will opt for server responding with
IA containing Unavail error. I am not in favour of server responding with 
num-addrs = 0 , since this sort of IA is used to indicate empty IA. Let us
not mix up. Let us provide more clarity to the implementer. 

- Jitesh

> I vote for the server to not respond if it has no addresses available.
> 
> - Ralph
> 
> At 12:10 PM 7/23/2001 -0500, Bernie Volz (EUD) wrote:
> >- When forming the Advertise in response to a Solicit, there
> >isn't any clear indication of what to do if no addresses may
> >be available for the client from that server at that time
> >(because all available addresses are in use). In particular,
> >should the server:
> >- Ignore the Solicit (in the hopes that by the time a subsequent
> >   Solicit arrives, addresses may be available)
> >- Send the Advertise but without the IA option
> >- Send the Advertise with the IA option but with an error (such
> >   as Unavail)
> >- Send the Advertise with the IA option with num-addrs = 0
> >
> >Or, should a client be prepared to handle all of the above?
> 
> 

-- 
-----------------------------------------------------------------------

    ~                                                             ~
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*
^ Jitesh N. Verma                     Tel. 91-80-225 1554 Ext. 1424   ^
^ HEWLETT PACKARD                     Fax. 91-80-220 0196             ^
^ INDIA SOFTWARE OPERATIONS         Email. [email-masked]        ^
^ 29, CUNNINGHAM ROAD               Pager. 9624-263608                ^
^ BANGALORE 560 052        __      Telnet. 847-1424                   ^
^                         / /                                         ^
^                        / /___ _____                                 ^
^                       / __  // __  /                                ^
^                      / / / // /_/ /                                 ^
^                     /_/ /_// ____/                                  ^
^                           / /                                       ^
^                          /_/                                        ^
*~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~*

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Fri, 27 Jul 2001 11:12:45 -0500

You're assuming that all the server does is offer addresses. It may offer other resources and configuration information. Also, don't
assume that the ONLY address assignment mechanism is DHCP. Some addresses may well be available via stateless and
these could easily be all the client may need.
 
Consider that case where all addesses are autoconfigured by the managed address flag is still set. In that case, perhaps there
are cases where most clients won't be given additional addresses but there are some that will be. Do you want those clients
to be sending Solicits forever?
 
Perhaps we should consider a new error code to tell the clients that they don't need any addresses. Or perhaps that should be
done via a returned IA option with num-addrs of 0.
 
Again, in any case the client is given other configuration information.
 
- Bernie 

-----Original Message-----
From: Thirumalesh Bhat [mailto:[email-masked]]
Sent: Friday, July 27, 2001 12:00 PM
To: DHCPv6 discussion list
Subject: RE: Advertise when no addresses available (was: Re: A few additional items re: -19 draft)

The server can remain silent if it doesn't have any addresses to offer. I don't see much upside for the client if the server says it doesn't have any addresses to offer.

thx

-----Original Message-----
From: Bernie Volz (EUD) [mailto:[email-masked]] 
Sent: Friday, July 27, 2001 7:48 AM
To: DHCPv6 discussion list
Subject: RE: Advertise when no addresses available (was: Re: A few additional items re: -19 draft)

Jitesh/Ralph: 

- Bernie 

-----Original Message----- 
From: Jitesh N Verma [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Friday, July 27, 2001 9:45 AM 
To: DHCPv6 discussion list 
Subject: Re: Advertise when no addresses available (was: Re: A few 
additional items re: -19 draft) 

Ralph, 

- Jitesh 

    ~                                                             ~