Subject: [dhcwg] doubt in rfc 3046

From: AJAY BANSAL <[email-masked]>
Date: Tue, 04 Sep 2001 16:27:42 +0530

Can anyone help in this:

In a client's dhcp request, which a DHCP server
recieves, can both,
the 'client id' option as well as the 'remote
client id'
(relay agent sub-option)  be present?
If yes, then will there be any significance of
client id field in such cases,
since client is not a trustworthy component?
Is it must for the server to copy the client id
back in its reply?

with regards
Ajay Bansal.

_______________________________________________
dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 04 Sep 2001 09:20:15 -0400

> (relay agent sub-option)  be present?

The DHCP client never sends a relay agent information option.   So if
you are implementing a client, the answer to your question is "no,
never."   If you are implementing a relay agent, it's "yes," but the
remote-id is intended to refer to a remote link, not to an individual
client.   The client-id and remote-id fields are completely
unrelated.

> since client is not a trustworthy component?

The client isn't trustworthy, but hopefully the relay agent is.   The
client id identifies the client, so you just have to trust that the
client is telling the truth.

> Is it must for the server to copy the client id

I don't think so, but you should refer to the RFC to be sure.

			       _MelloN_