Subject: [dhcwg] Re: Rebind failure behavior

From: "Guja, ArturX" <[email-masked]>
Date: Mon, 24 Sep 2001 10:58:05 +0200

Hello,

I noticed another bug here:

>    RT for each subsequent message transmission is based on the previous
>    value of RT:
>
>       RT = RTprev + RAND*RTprev

If RAND is chosen from between -0.1 and 0.1, this certainly cannot be so.

I believe it should have read:

       RT = RTprev * 2 + RAND*RTprev

Otherwise, the sequence of RT would fluctuate instead of rising. It
could even lead to negative RTs.

Artur Guja

_______________________________________________
dhcwg mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Guja, ArturX" <[email-masked]>
Date: Mon, 24 Sep 2001 08:46:09 +0200

Hello,

Thank you for the revised text on REBIND retransmission.
I incorporated it in my implementation and it seems to work,
as far as the initial testing is concerned.

Artur Guja