Subject: [dhcwg] RE: Maximum message size interpretation in DHCP packet

From: "Gopi Krishna" <[email-masked]>
Date: Tue, 19 Feb 2002 12:06:42 -0800

Hi,
Does not it include the ethernet header besides IP,UDP and DHCP in finding the Maximum DHCP Packet size?
Thanks in advance.

-Gopi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, February 19, 2002 9:01 AM
To: [email-masked]
Subject: dhcwg digest, Vol 1 #174 - 3 msgs

Send dhcwg mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the web, visit
	https://www1.ietf.org/mailman/listinfo/dhcwg
or, via email, send a message with subject or body 'help' to
	[email-masked]
You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific than
"Re: Contents of dhcwg digest..."

Today's Topics:

  1. Re: Maximum message size interpretation (Tobin Coziahr)
  2. Re: Maximum message size interpretation (Thomas Narten)
  3. Re: Maximum message size interpretation (Tobin Coziahr)

--__--__--

Message: 1
Date: Tue, 19 Feb 2002 01:22:08 -0800
From: Tobin Coziahr <[email-masked]>
Organization: Sun Microsystems
To: Bud Millwood <[email-masked]>
CC: DHCP discussion list <[email-masked]>
Subject: Re: [dhcwg] Maximum message size interpretation

Bud-

The Maximum Message Size option is also known as the "maximum DHCP
message size" option (See RFC 2131, page 9-10).  This ONLY refers to the
size of the DHCP packet itself, without the IP and UDP headers.  The
point of the option is to let servers use messages larger than 548
bytes, which is the default max.

So no, don't subtract the header size.

-Tobin 

Bud Millwood wrote:
> 
> When a client gives my server the maximum message size it can receive, should
> I interpret that as the total IP packet size the client can receive or just
> the size of the DHCP portion?
> 
> >From the description of this option, it appears that I should interpret the
> value as the size of the entire IP packet the client can receive.
> 
> In other words, should I subtract IP and UDP header sizes from a client's
> Maximum Message Size value?
> 
> - Bud
> 
> Bud Millwood
> Weird Solutions, Inc.
> http://www.weird-solutions.com
> tel: +46 70 566 7803
> fax: +46 8 758 3687
> mailto:[email-masked]
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg

-- 
Tobin Coziahr			650-786-7118 (x87118)
Solaris Networking		[email-masked]
Sun Microsystems

--__--__--

Message: 2
To: Tobin Coziahr <[email-masked]>
cc: Bud Millwood <[email-masked]>,
DHCP discussion list <[email-masked]>
Subject: Re: [dhcwg] Maximum message size interpretation
Date: Tue, 19 Feb 2002 06:34:04 -0500
From: Thomas Narten <[email-masked]>

> The Maximum Message Size option is also known as the "maximum DHCP
> message size" option (See RFC 2131, page 9-10).  This ONLY refers to the
> size of the DHCP packet itself, without the IP and UDP headers.  The
> point of the option is to let servers use messages larger than 548
> bytes, which is the default max.

> So no, don't subtract the header size.

Hmm. That's not what draft-ietf-dhc-csr-06.txt says:

>    stack is capable of reassembling fragmented IP datagrams.  In this
>    case, the client SHOULD set the value of this option to at least
>    the MTU of the interface that the client is configuring.   The
>    client MAY set the value of this option higher, up to the size of
>    the largest UDP packet it is prepared to accept. (Note that the
>    value specified in the Maximum DHCP Message Size option is the
>    total maximum packet size, including IP and UDP headers.)

Is the above text correct?

Thomas

--__--__--

Message: 3
Date: Tue, 19 Feb 2002 03:59:42 -0800
From: Tobin Coziahr <[email-masked]>
Organization: Sun Microsystems
To: Thomas Narten <[email-masked]>
CC: Bud Millwood <[email-masked]>,
DHCP discussion list <[email-masked]>
Subject: Re: [dhcwg] Maximum message size interpretation

My apologies, you're right.  All of the information I just found on the
subject notes that the minimum value for this option is 576, which along
with the RFC that you quoted shows that I was mistaken.

The Maximum Message Size option DOES include the IP and UDP headers.

Thanks for the correction, Thomas.

-Tobin

Thomas Narten wrote:
> 
> > The Maximum Message Size option is also known as the "maximum DHCP
> > message size" option (See RFC 2131, page 9-10).  This ONLY refers to the
> > size of the DHCP packet itself, without the IP and UDP headers.  The
> > point of the option is to let servers use messages larger than 548
> > bytes, which is the default max.
> 
> > So no, don't subtract the header size.
> 
> Hmm. That's not what draft-ietf-dhc-csr-06.txt says:
> 
> >    stack is capable of reassembling fragmented IP datagrams.  In this
> >    case, the client SHOULD set the value of this option to at least
> >    the MTU of the interface that the client is configuring.   The
> >    client MAY set the value of this option higher, up to the size of
> >    the largest UDP packet it is prepared to accept. (Note that the
> >    value specified in the Maximum DHCP Message Size option is the
> >    total maximum packet size, including IP and UDP headers.)
> 
> Is the above text correct?
> 
> Thomas
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg

-- 
Tobin Coziahr			650-786-7118 (x87118)
Solaris Networking		[email-masked]
Sun Microsystems

--__--__--

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

End of dhcwg Digest

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Tobin Coziahr <[email-masked]>
Date: Tue, 19 Feb 2002 13:14:14 -0800

Nope, just IP, UDP, and DHCP need to be considered.

It's stated in draft-ietf-dhc-csr-06.txt that the standard maximum size
of a DHCP message is 576 bytes.  That's 548 for the maximum basic DHCP
packet, and 28 for IP and UDP headers.  You then use the maximum message
size option to negotiate communication at larger sizes, if desired.  As
Thomas pointed out, that document also mentions that the Max DHCP
message size is the DHCP message plus IP and UDP.

-Tobin

> Does not it include the ethernet header besides IP,UDP and DHCP in finding the Maximum DHCP Packet size?

---