Subject: RE: [dhcwg] Re: Recovery of unused DHCP option codes

From: "Kostur, Andre" <[email-masked]>
Date: Fri, 28 Feb 2003 14:07:31 -0800

I guess on a related note, shouldn't those options be properly published in
a Draft then?

> -----Original Message-----
> From: Ralph Droms [mailto:[email-masked]]
> Sent: Friday, February 28, 2003 12:15 PM
> To: Michael Johnston
> Cc: [email-masked]
> Subject: Re: [dhcwg] Re: Recovery of unused DHCP option codes
> 
> 
> OK, thanks...
> 
> - Ralph
> 
> At 08:08 PM 2/28/2003 +0000, Michael Johnston wrote:
> >Ralph,
> >
> >Options 93 (client system architecture), 94 (client network 
> interface 
> >identifier) and 97 (client machine identfier (UUID)) are in 
> heavy use 
> >today and are, and have been for several years, required for all new 
> >business PCs with built-in network devices to pass Microsoft WHQL.
> >%%michael
> >
> >Ralph Droms writes:
> >>I've published a document, 
> draft-ietf-dhc-unused-optioncodes-00, that 
> >>lists several opcodes that were assigned prior to the 
> publication of 
> >>RFC2489 (which was updated by RFC2939).  For a variety of 
> reasons, the 
> >>options associated with these opcodes were never accepted 
> as standards 
> >>and published as RFCs.
> >>The publication of draft-ietf-dhc-unused-optioncodes-00 is 
> the first step 
> >>in the return of these opcodes to IANA for assignment to 
> future DHCP 
> >>options.  Here's the plan:
> >>1. Make an announcement on dhcwg asking for dhc WG
> >>    review of the draft; explicitly ask for report
> >>    of actual use of any options listed in the draft
> >>2. Revise the draft in the form of an Informational
> >>    RFC explicitly directing IANA to make the
> >>    option codes listed in the draft available for
> >>    assignment to new options in the future
> >>3. Make an announcement to the IETF as a whole asking
> >>    for review of the draft and report of any option
> >>    known to be in use
> >>4. Submit this document to the IESG for publication
> >>    as an Informational RFC
> >>This announcement is step 1 from the list.  Please review 
> >>draft-ietf-dhc-unused-optioncodes-00 and respond to the dhc 
> WG mailing 
> >>list if you know of any of the options listed in the 
> document that are in 
> >>use, or if you have any other comments on the contents of the draft.
> >>We'll take a couple of minutes to discuss the draft and 
> solicit input at 
> >>the WG meeting in SF, as well.
> >>- Ralph
> >>_______________________________________________
> >>dhcwg mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/dhcwg
> >_______________________________________________
> >dhcwg mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/dhcwg
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
>

---

From: Ralph Droms <[email-masked]>
Date: Fri, 28 Feb 2003 17:08:16 -0500

Yes, the options should be documented through the IETF standards process.

The dhc WG will have to devise a plan to make that process happen.  I'm 
trying to identify any sources of documentation for these options 
(http://www.pix.net/software/pxeboot/archive/pxespec.pdf) is a starting 
point, and who will take responsibility for shepherding the specs for the 
options through the IETF standards process.

- Ralph

At 02:07 PM 2/28/2003 -0800, you wrote:

>I guess on a related note, shouldn't those options be properly published 
>in a Draft then?
>
> > From: Ralph Droms [<mailto:[email-masked]>mailto:[email-masked]]
> > >><https://www1.ietf.org/mailman/listinfo/dhcwg>https://www1.ietf.org/ma 
> ilman/listinfo/dhcwg
> > ><https://www1.ietf.org/mailman/listinfo/dhcwg>https://www1.ietf.org/mai 
> lman/listinfo/dhcwg
> >
> <https://www1.ietf.org/mailman/listinfo/dhcwg>https://www1.ietf.org/mailman/listinfo/dhcwg 
>
> >