Subject: [dhcwg] empty CHADDR and DHCPINFORM option 252

From: Max Nitribitt <[email-masked]>
Date: Wed, 30 Jul 2003 01:06:16 -0700 (PDT)

Hi,

I'm trying to enable a java application for proxy
auto-configuration via DHCP. Therefore I'm sending a
DHCPInform request for parameter (option) 252.
Everything works fine so far. There is only one
limitation: 

RFC2131 states client's hardware address is needed for
DHCPInform requests. As accessing the MAC address is
not a  trivial task in java and requires platform
dependent code, I would like to do the request without
supplying a client hardware address. In our companies
network I get the information that I want even though
I send an empty CHADDR. 

My questions are: 
* Can I expect DHCP-Servers to send an answer on
DHCPInform requests even though I don't supply my
Mac-Address, but only my IP (CIADDR)? 
* Is there something like a "dummy MAC ADDRESS" that
doesn't collide with "real NIC Addresses" and is
accepted by all DHCP-Servers? 
* Or do I really need to acquire the Hardware address
with ugly OS-dependent code (via ipconfig \all/
ifconfig... )?

thank's a lot

max

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Jul 2003 12:04:15 -0500

> network I get the information that I want even though

I can't think of any reason why the DHCP server would need chaddr set for 
DHCPINFORM other than that then you would get client-specific parameters.   
Since presumably you don't care about those, I think it would probably work 
to set hlen to zero.   This is permitted by RFC2855, for firewire, so any 
DHCP server that's compliant with RFC2855 is going to do the right thing (the 
server would have to do a lot of work to determine that you weren't connected 
to an ieee1394 link even in cases where it would be possible for it to make 
that determination, and in most cases it wouldn't have enough information.

The catch is that if you set hlen to zero and don't send a client identifier, 
the server may not be happy (although I suspect a lot of servers won't 
notice).   But you probably don't know your client identifier.   If you make 
one up, that's probably not going to produce a good result.    If it were me, 
I would set hlen to zero and send no client identifier, and hope for the 
best, but I don't know what various DHCP servers will do in that case.

---

From: Max Nitribitt <[email-masked]>
Date: Thu, 31 Jul 2003 00:15:29 -0700 (PDT)

Hi Ted and Dirk,

I had a look at RFC2855, and decided to try out Ted's
proposal (setting hlen to 0 and sending no chaddr).
RFC2855 compliant servers should be able to unicast to
my IP supplied in ciaddr, therefore I also don't need
to set the broadcast flag (I had it set during my
first attempt).

This should be the best way to deal with this problem.
Thank's for your hints on constructing a dummy id,
Dirk. My intention was to use it for the same purpose,
but it looks like I don't need to. 

This is a great mailing list, thanks a lot for your
help! 

best regards

Max