Subject: [dhcwg] Revised agenda for dhc WG meeting

From: Ralph Droms <[email-masked]>
Date: Mon, 23 Feb 2004 09:37:43 -0500

DHC WG agenda - IETF 59
                       0900 Tue 03/04/2004 (tentative)
                      (Last revised 02/23/2004 09:35 AM)
                      ----------------------------------

Administrivia                                      Ralph Droms      05 minutes
   Agenda bashing

DHCP Option for Proxy Server Configuration         <TBD>            05 minutes
   <draft-ietf-dhc-proxyserver-opt-00>
   Technical discussion; ready for WG last call?

The Extended Remote Boot Option for DHCPv4         <TBD>            05 minutes
   <draft-ietf-dhc-opt-extrboot-00>
   Technical discussion; ready for WG last call?

DHCPv6 Support for Remote Boot                     <TBD>            05 minutes
   <draft-ietf-dhc-dhcpv6-opt-rboot-00>
   Technical discussion; ready for WG last call?

Configured Tunnel End Point Option for DHCPv6      Daniel Park      05 minutes
   <draft-ietf-dhc-dhcpv6-ctep-opt-01>
   Technical discussion; ready for WG last call?

DHCPv4 Support for Configuring IPv6-in-IPv4 Tunnels Daniel Park      05 minutes
   <draft-daniel-dhc-ipv6in4-tunnels-00>
   Technical discussion; ready for WG last call?

Requirements for Proposed Changes to DHCPv4        <TBD>            05 minutes
   <draft-ietf-dhc-changes-00>
   Technical discussion; ready for WG last call?

Node-Specific Client Identifiers for DHCPv4        <TBD>            05 minutes
   <draft-ietf-dhc-3315id-for-v4-01>
   Technical discussion; ready for WG last call?

Rapid Commit Option for DHCPv4                     <TBD>            05 minutes
   <draft-ietf-dhc-rapid-commit-opt-00>
   Technical discussion; ready for WG last call?

Micro-block IP Address Allocation With DHCP Proxy Server Naiming 
Shen     05 minutes
   <draft-shen-dhc-block-alloc-01>
   Accept as WG work item?

Renumbering Requirements for Stateless DHCPv6      Stig Venaas      10 minutes
   <draft-chown-dhc-stateless-dhcpv6-renumbering-00>
   Accept as WG work item?

Lifetime Option for DHCPv6                         Stig Venaas      10 minutes
   <draft-venaas-dhc-lifetime-01>
   Accept as WG work item?

Vendor-Specific Suboption for the DHCP Relay Agent Option 
<TBD>            05 minutes
   <draft-stapp-dhc-vendor-suboption-00>
   Accept as WG work item?

Discussion of dual-stack (DHCPv4/DHCPv6) issues    Ralph Droms      15 minutes

IPv4 and IPv6 Dual-Stack Issues for DHCPv6         Stig Venaas      10 minutes
   <draft-chown-dhc-dual-stack-00>
   Accept as WG work item?

DHCPv6 IPv4 Information Options                    <TBD>            10 minutes
   <draft-cadar-dhc-dhcpv6-v4options-00>
   Accept as WG work item?

Update on IPR issue with two drafts                Ralph Droms      15 minutes

Update of dhc WG charter                           Ralph Droms      15 minutes
                                                                    -----------
Total                                                              140 minutes

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Mon, 23 Feb 2004 14:55:00 -0500

My apologies for the profusion of draft agendas...

Please review the following drafts and post comments to [email-masked] in
preparation for the WG meeting in Seoul.

Review for WG last call:
------------------------
DHCP Option for Proxy Server Configuration
  <draft-ietf-dhc-proxyserver-opt-00>

The Extended Remote Boot Option for DHCPv4
  <draft-ietf-dhc-opt-extrboot-00>

Vendor-Identifying Vendor Options for DHCPv4
  <draft-ietf-dhc-vendor-01>

Requirements for Proposed Changes to DHCPv4
  <draft-ietf-dhc-changes-00>

Node-Specific Client Identifiers for DHCPv4
  <draft-ietf-dhc-3315id-for-v4-01>

Rapid Commit Option for DHCPv4
  <draft-ietf-dhc-rapid-commit-opt-00>

DHCPv6 Support for Remote Boot
  <draft-ietf-dhc-dhcpv6-opt-rboot-00>

Configured Tunnel End Point Option for DHCPv6
  <draft-ietf-dhc-dhcpv6-ctep-opt-01>

Review for acceptance as WG work item:
--------------------------------------
DHCPv4 Support for Configuring IPv6-in-IPv4 Tunnels
  <draft-daniel-dhc-ipv6in4-tunnels-00>

Micro-block IP Address Allocation With DHCP Proxy Server
  <draft-shen-dhc-block-alloc-01>

Renumbering Requirements for Stateless DHCPv6
  <draft-chown-dhc-stateless-dhcpv6-renumbering-00>

Lifetime Option for DHCPv6
  <draft-venaas-dhc-lifetime-01>

IPv4 and IPv6 Dual-Stack Issues for DHCPv6
  <draft-chown-dhc-dual-stack-00>

DHCPv6 IPv4 Information Options
  <draft-cadar-dhc-dhcpv6-v4options-00>

---

From: [email-masked]
Date: Tue, 24 Feb 2004 09:26:39 +0100

Hi,

>   <draft-shen-dhc-block-alloc-01>

In the above draft, how many IP addresses from a Micro-block are available
for clients? In section 3 it is mentioned that 1 address is used "on the
router", and I guess also the IP addresses where the host part is all 1's
are all 0's are not allowed to be used by clients. This makes the example
in section 4.1 inaccurate: 5000 clients with micro-blocks of 32 gives an
efficiency of 90% (instead of 99.5% as mentioned in the draft). Is this
correct?

Section 4.3 says that a DHCP server MUST NOT set both both flags in the
micro-blocking suboption. A DHCP server not supporting this, will return it
to the proxy with both flags set. Some text should be added to say what a
proxy is supposed to do when the response contains this suboption with
prefix length still equal to zero, i.e. the proxy must assume that the DHCP
server does not support it, although both flags could be set.

regards,

Stefaan

---

From: Naiming Shen <[email-masked]>
Date: Tue, 24 Feb 2004 11:00:07 -0800

Hi Stefaan,

 ] Hi,
 ] 
 ] > Micro-block IP Address Allocation With DHCP Proxy Server
 ] >   <draft-shen-dhc-block-alloc-01>
 ] > 
 ] In the above draft, how many IP addresses from a Micro-block are available
 ] for clients? In section 3 it is mentioned that 1 address is used "on the
 ] router", and I guess also the IP addresses where the host part is all 1's
 ] are all 0's are not allowed to be used by clients. This makes the example
 ] in section 4.1 inaccurate: 5000 clients with micro-blocks of 32 gives an
 ] efficiency of 90% (instead of 99.5% as mentioned in the draft). Is this
 ] correct?

It depends. If the router address allocation is for the PPP clients or
any clients over point-to-point connections, ALL the IP addresses in
a block is available to the clients/users. But if the address allocation
is for PPPoE clients, normal IPoE clients or hosts over a LAN connection,
then we(the routers) need to take 3 addresses out of that. The above
mentioned efficiency just list the maximum which is in p2p case.

 ] 
 ] Section 4.3 says that a DHCP server MUST NOT set both both flags in the
 ] micro-blocking suboption. A DHCP server not supporting this, will return it
 ] to the proxy with both flags set. Some text should be added to say what a
 ] proxy is supposed to do when the response contains this suboption with
 ] prefix length still equal to zero, i.e. the proxy must assume that the DHCP
 ] server does not support it, although both flags could be set.

Ok. What the current version of the draft does not mention is the
handling of errored condition, such as both bits set, zero prefix-len
returned, etc. Will update those in the next version. thanks for the
suggestion.

Best Regards,
- Naiming

 ] 
 ] regards,
 ] 
 ] Stefaan