Subject: [Dime] [Editorial Errata Reported] RFC5777 (2337)

From: RFC Errata System <[email-masked]>
Date: Mon, 19 Jul 2010 21:27:51 -0700 (PDT)

The following errata report has been submitted for RFC5777,
"Traffic Classification and Quality of Service (QoS) Attributes for Diameter".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5777&eid=2337

--------------------------------------
Type: Editorial
Reported by: Francois Bard <[email-masked]>

Section: 4.2.10

Original Text
-------------
The Absolute-End-Fractional-Seconds AVP (AVP Code 569) is of type
Unsigned32.  The value specifies the fractional seconds that are
added to Absolute-End-Time value in order to determine when the time
window ends.  If this AVP is absent from the Time-Of-Day-Condition
AVP, then the fractional seconds are assumed to be zero.

Corrected Text
--------------
The Absolute-Start-Fractional-Seconds AVP (AVP Code 569) is of type
Unsigned32.  The value specifies the fractional seconds that are
added to Absolute-End-Time value in order to determine when the time
window ends.  The Absolute-End-Fractional-Seconds represent 
a 32-bit fraction field giving a precision of about 232 picoseconds 
( 1/((2^32)-1)) seconds ).  If this AVP is absent from the Time-Of-Day-
Condition AVP, then the fractional seconds are assumed to be zero.
See the Network Time Protocol [RFC 1305] for more precision.

Notes
-----
The AVP description lacked a explanation about what a fractional second is.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5777 (draft-ietf-dime-qos-attributes-15)
--------------------------------------
Title               : Traffic Classification and Quality of Service (QoS) Attributes for Diameter
Publication Date    : February 2010
Author(s)           : J. Korhonen, H. Tschofenig, M. Arumaithurai, M. Jones, Ed., A. Lior
Category            : PROPOSED STANDARD
Source              : Diameter Maintanence and Extensions
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Mark Jones <[email-masked]>
Date: Tue, 20 Jul 2010 08:36:55 -0400

The RFC5777 authors have discussed this errata with Francois Bard prior to submission.

However, there is a typo in the first sentence of the proposed corrected text: "Absolute-Start-Fractional-Seconds" should read "Absolute-End-Fractional-Seconds".

With this correction, we agree that it should proceed to IESG verification.

Regards
Mark

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: July 20, 2010 12:28 AM
> To: [email-masked]; [email-masked];
> [email-masked]; Mark Jones; Avi Lior;
> [email-masked]; [email-masked]; lionel.morand@orange-
> ftgroup.com; [email-masked]
> Cc: [email-masked]; [email-masked]; rfc-editor@rfc-
> editor.org
> Subject: [Editorial Errata Reported] RFC5777 (2337)
> 
>

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 22 Jul 2010 09:40:01 +0300

>From a Dime co-chair point of view I agree with the errata #2337 if/when the
correction below asked by Mark is added.

- Jouni

On 7/20/10 3:36 PM, "ext Mark Jones" <[email-masked]>
wrote:

> However, there is a typo in the first sentence of the proposed corrected text:
> "Absolute-Start-Fractional-Seconds" should read
> "Absolute-End-Fractional-Seconds".
>