Subject: Typographical error in draft-klensin-unicode-escapes-00

From: John C Klensin <[email-masked]>
Date: Fri, 19 Jan 2007 11:38:56 -0500

Hi.

It has been called to my attention that I should have checked
the ABNF syntax rules more carefully before posting this draft.
The productions for Hex-quad and Full-form should not have
spaces between the repeat count and the token.  The right sides
should read 
   4*4HexDigit   and
   2*2Hex-Quad
respectively.

Fixed in the working draft -- I'm not going to create confusion
by re-posting at this time.

     john

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 21 Jan 2007 22:12:55 +0100

On Fri, Jan 19, 2007 at 11:38:56AM -0500,
 John C Klensin <[email-masked]> wrote 
 a message of 18 lines which said:

> It has been called to my attention that I should have checked the
> ABNF syntax rules more carefully before posting this draft.

There is another strange thing: 

   BMP-form =  "\u" Hex-quad
   Full-form =  "\U" 2*2 Hex-quad

How can you tell one from the other before you encounter the second
Hex-quad? By the case of the U, as it seems from reading the text
following the grammar?

If so, this is wrong because ABNF strings are case-insensitive so one
should use:

   BMP-form  =  "\" %x75 Hex-quad   
   Full-form =  "\" %x55 2*2Hex-quad

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Mon, 22 Jan 2007 06:40:02 +0000

John C Klensin said:
> The right sides

While these are not incorrect, they are confusing to many readers. ABNF
allows you to write these as:

    4HexDigit     and
    2Hex-Quad

respectively, and I recommend you do so.

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
THUS plc            |                            |

---

From: John C Klensin <[email-masked]>
Date: Mon, 22 Jan 2007 03:53:06 -0500

--On Monday, 22 January, 2007 06:40 +0000 "Clive D.W. Feather"
<[email-masked]> wrote:

> John C Klensin said:
>> The right sides
>> should read 
>>    4*4HexDigit   and
>>    2*2Hex-Quad
>> respectively.
> 
> While these are not incorrect, they are confusing to many
> readers. ABNF allows you to write these as:
> 
>     4HexDigit     and
>     2Hex-Quad
> 

Clive,  I actually find it less confusing to be explicit about
the lower and upper bounds.  But will think on it further,
especially if others have strong opinions.

More later today on your more recent note.

    john

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Mon, 22 Jan 2007 09:22:37 +0000

John C Klensin said:
> the lower and upper bounds.

We may have to agree to disagree. When I see "4*4XXX", it makes me wonder
if the author actually meant "4*" or "*4" and misunderstood the notation.

Incidentally, there's no significance to the groupings of 4 in the \u
notation, so I see little point in introducing "Hex-quad". The term "BMP"
is, as I understand it, deprecated these days. So I would just write:

    EmbeddedUnicodeChar = %x5C.75 4HexDigit / %x5C.55 8HexDigit

or if you really want:

    EmbeddedUnicodeChar = UnicodeShortForm / UnicodeLongForm
    UnicodeShortForm    = %x5C.75 4HexDigit
    UnicodeLongForm     = %x5C.55 8HexDigit

[Note that you omitted the / from your definition.]

---

From: John C Klensin <[email-masked]>
Date: Thu, 25 Jan 2007 09:47:51 -0500

--On Monday, 22 January, 2007 09:22 +0000 "Clive D.W. Feather"
<[email-masked]> wrote:

> We may have to agree to disagree. When I see "4*4XXX", it
> makes me wonder if the author actually meant "4*" or "*4" and
> misunderstood the notation.

I am skipping ABNF quibbles for -01, leaving it for -02 (I
hope).  It would take very little more of this particular
discussion for me to shift back to pure BNF and write a
justification for it rather than trying to use ABNF at all.  The
tool is, IMO, complicating clear expression here, rather than
aiding it.   However, see my note from yesterday.   However...
 
> Incidentally, there's no significance to the groupings of 4 in
> the \u notation, so I see little point in introducing
> "Hex-quad".

That terminology was appropriated from the C documents.

> The term "BMP" is, as I understand it, deprecated
> these days.

I thought so too, until I discovered that it is extensively used
in the Unicode 5.0 book.    Take it up with the UTC :-(

> So I would just write:

Caught and fixed.  Thanks.
    john