Subject: Comments on draft-ietf-disman-script-mib-06.txt

From: Randy Presuhn <[email-masked]>
Date: Tue, 8 Dec 1998 10:18:28 -0600 (CST)

Hi - 

Here are them comments on the script MIB that were mentioned at
the meeting in Orlando.

1)  Minor Technical.
    Clause 4.1 (3) on page 7
    The last sentence of this bullet is an over-specification.
    It is perfectly reasonable to have object identifiers not beneath
    {1 3 6 1 4 1}.
    Proposal: delete the sentence reading:
    "The object identifier value is one of the arcs below the enterprise
    object identifier {1 3 6 1 4 1}."

2)  Technical.
    description of msLaunchOwner on pages 26 and 27
    The second and third sentences of the description appear to
    be contradictory.
    Proposal:  remove the contradiction.
    David Levy knows what to do.  :-)

3)  Typo.
    Description of smLaunchScriptOwner, page 27
    Proposal: replace "this objects" with "this object"

4)  Typo / editorial?
    Description of smLaunchStart on page 30
    There is a word (or more) missing in the phrase
    "requires to perform" at the top of the page.  (What performs
    the checks?)

Randy Presuhn

---

From: Eamonn McManus <[email-masked]>
Date: Wed, 16 Dec 1998 18:20:11 +0100

Randy Presuhn writes:
> Randy> 2) Technical.  description of msLaunchOwner on pages 26 and 27
> Randy> The second and third sentences of the description appear to be
> Randy> contradictory.  Proposal: remove the contradiction.  David Levy
> Randy> knows what to do.  :-)

Juergen Schoenwaelder <[email-masked]> writes:
> Below is another attempt to write this up. We hope this version is
> more readable than the previous one.
[...]
> -        "The manager who owns this row in the smLaunchTable. Every
> -	 script started from a particular entry in the smLaunchTable
> -	 will also be owned by the same smLaunchOwner used to index
> -	 the smLaunchTable entry. However, the owner of an entry in
> -	 the smLaunchTable is not necessarily the same as the owner
> -	 of the script to be launched. "
> +	"The manager who owns this row in the smLaunchTable. Every
> +	 instance of a running script started from a particular entry
> +	 in the smLaunchTable (i.e. entries in the smRunTable) will be
> +	 owned by the same smLaunchOwner used to index the entry in
> +	 the smLaunchTable. Note however that the owner of the script
> +	 associated with entries in the smLaunchTable and
> +	 corresponding entries in the smRunTable may be different
> +	 (since the smLaunchScriptOwner object may refer to a
> +	 different owner than the smLaunchOwner object)."

I'm sorry to say that I find it *less* readable!  I thought the
original was fairly clear except that "script" in the second sentence
should have been "running script instance" or the like.  But how about
replacing that last monster sentence with just:
    This owner is not necessarily the same as the owner of the script
    itself (smLaunchScriptOwner).

Even just adding the (smLaunchScriptOwner) parenthesis to the original
sentence would make it less likely that a cursory reading would see a
contradiction between the second and third sentences.

,
Eamonn
--
The Open Group Research Institute, 2 ave de Vignate, 38610 Gieres, France.
Phone +33 476.63.48.82.  Fax +33 476.51.05.32.  http://www.gr.osf.org/~emcmanus