Subject: Re: <draft-ietf-disman-remops-mib-00.txt>

From: [email-masked]
Date: Tue, 5 Jan 1999 15:52:59 -0500

Harmen,

>Excerpt from draft-ietf-disman-remops-mib-00.txt:

>> traceRouteResultsHopIndex OBJECT-TYPE
>>       SYNTAX      Integer32 (1..255)
>>       MAX-ACCESS  not-accessible
>>       STATUS      current
>>       DESCRIPTION
>>          "An entry in this table has as its initial instance identifier
>>          the value of its corresponding traceRouteEntry's
>>          instance identifier."
>>       ::= { traceRouteResultsEntry 1 }

>Could you explain to me which part of the instance identification
>in the traceRouteTable the description is referring to? Note that the
>index of the traceRouteTable is defined as follows:

>> INDEX {
>>                 traceRouteOwnerIndex,
>>                 traceRouteHostAddress
>> }

The above are the indexes into the traceRouteTable. These indexes are also
used as the first two indexes into the traceRouteResultsTable which
has the following indexes:

   INDEX {
           traceRouteOwnerIndex,
           traceRouteHostAddress,
           traceRouteResultsHopIndex,
           traceRouteResultsProbeIndex
         }

An traceRouteResultsEntry is keep on a per traceRouteEntry, per hop and
per probe basis.

Regards,

Ken

---

From: Harmen van der Linde <[email-masked]>
Date: Tue, 05 Jan 1999 17:02:06 -0500

Ken,

>An traceRouteResultsEntry is keep on a per traceRouteEntry, per hop and

I understand that. However, what's unclear to me, based on the
traceRouteResultsHopIndex description clause, is what initial value
to assign to the traceRouteResultsHopIndex (sub)index value. 

I suppose that the initial value for the traceRouteResultsHopIndex
object is one and is incremented for each additional hop in the
traceroute path (similar to the traceRouteResultsProbeIndex). 

If this is the case the description clause for the traceRouteResultsHopIndex
object is confusing.

Feedback appreciated.

Regards,

Harmen

------------------------------------------------------------------------
Harmen van der Linde
Advanced Internetworking Services  Voice: (732) 758-4129
Bellcore, NVC 2X-119                 Fax: (732) 758-2269
331 Newman Springs Road            Email: [email-masked]          
Red Bank, NJ 07710                        [email-masked]
------------------------------------------------------------------------