Subject: Re: disman WG last call: event MIB

From: Bob Stewart <[email-masked]>
Date: Fri, 25 Jun 1999 15:24:13 -0400

At 07:44 PM 3/29/99 +0200, Frank Strauss wrote:
>draft-ietf-disman-event-mib-06.txt:
>
>> dismanEventNotificationGroup NOTIFICATION-GROUP
>>         OBJECTS {
>
>s/OBJECTS/NOTIFICATIONS/

Fixed.

	Bob

---

From: Bob Stewart <[email-masked]>
Date: Fri, 25 Jun 1999 15:26:02 -0400

At 08:28 PM 3/29/99 +0200, Frank Strauss wrote:
>> mteEventActions OBJECT-TYPE
>>     SYNTAX      BITS { notification(0), set(1) }
>> [...]
>>     DEFVAL { { 0 } }
>
>SMIv2 (draft-ops-smiv2-smi-01.txt, RFC1902 is not that clear):
>
>> [...]
>>     Defvalue ::=  -- must be valid for the type specified in
>>                   -- SYNTAX clause of same OBJECT-TYPE macro
>>                   value(ObjectSyntax)
>>                 | "{" BitsValue "}"
>> 
>>     BitsValue ::= BitNames
>>                 | empty
>> 
>>     BitNames ::=  BitName
>>                 | BitNames "," BitName
>> 
>>     BitName ::= identifier
>
>So, the DEFVAL clause should be ``{ { notification } }''.

Nope.  I intended no bits, so it looks like I should just leave it empty.

	Bob