Subject: disman issue REMOPS-5

From: Randy Presuhn <[email-masked]>
Date: Wed, 23 Jun 1999 11:20:39 -0700 (PDT)

Hi -

Issue REMOPS-5:

> From: Dave Thaler <[email-masked]>
> Subject: Review of draft-ietf-disman-remops-mib-05.txt
> To: [email-masked]
> Date: Wed, 23 Jun 1999 13:14:26 -0400 (EDT)
...
> >              HostAddressType   OCTETs    ADDRESS TYPE
> >                 none(0)         0        not specified
> none(0) should be none(1) as specified in the SYNTAX clause
> of HostAddressType.
...

 -----------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 -----------------------------------------------------------------------
 Any relationship between my opinions and BMC's is coincidental.
 -----------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 24 Jun 1999 04:39:27 -0400

>> none(0) should be none(1) as specified in the SYNTAX clause

I prefer to start the enumeration at 0 and have changed the
HostAddressType and HostAddress TCs to the following:

 HostAddressType ::= TEXTUAL-CONVENTION
     STATUS  current
     DESCRIPTION
         "The textual convention for defining the type of
         a destination address."
     SYNTAX  INTEGER {
            none(0),
            dnsName(1), -- Utf8string encoded DNS name
            ipv4(2),    -- ipv4 address
            ipv6(3)     -- ipv6 address
           }

 HostAddress ::= TEXTUAL-CONVENTION
    STATUS  current
    DESCRIPTION
        "The textual convention for specifying a host
        address.  The type of address can be determined
        by examining the value of the preceding
        HostAddressType object:

           HostAddressType   OCTETs    ADDRESS TYPE
              none(0)         0        not specified
              dnsName(1)      1-255    DNS name
              ipv4(2)         4        ipv4
              ipv6(3)         16       ipv6"
    SYNTAX OCTET STRING (SIZE (0..255))

I have also changed all references to these to use the new
enumeration.

Ken

---

From: Randy Presuhn <[email-masked]>
Date: Sat, 26 Jun 1999 00:07:11 -0700 (PDT)

Hi -

> From: [email-masked]
> To: [email-masked]
> cc: [email-masked]
> Date: Thu, 24 Jun 1999 04:39:27 -0400
> Subject: Re: disman issue REMOPS-5
> 
> 
> 
> >Issue REMOPS-5:
> 

If there are no objections to this proposed resolution,
I'll consider this issue closed.