Subject: disman issue REMOPS-2

From: [email-masked]
Date: Thu, 24 Jun 1999 10:57:03 -0400

Dave,

>Issue REMOPS-2:

> Also, it isn't clear to me why ICMP is a MUST NOT for traceroute,
> but is RECOMMENDED for ping.  This seems to be an inconsistency:
> why shouldn't traceroute have the equivalent of pingCtlType?

I found the following note from Van Jacobson:

     From: [email-masked] (Van Jacobson)
     Newsgroups: comp.protocols.tcp-ip
     Subject: Re: traceroute history: why UDP?
     Date: 8 Feb 1999 08:36:20 GMT
     Organization: Lawrence Berkeley National Laboratory, Berkeley CA
     Message-ID: <[email-masked]>
     References: <[email-masked]>

     In article <[email-masked]>,
            [email-masked] (Kevin Steves) writes:
     > Were ICMP probes considered in 1988 when Van wrote traceroute?

     The very first traceroute (never released) used icmp echo.  RFC792 (the
     icmp spec) contains the words:

         The ICMP messages typically report errors in the processing of
         datagrams.  To avoid the infinite regress of messages about messages
         etc., no ICMP messages are sent about ICMP messages.

     During the first night of testing I found that more than half the
     router vendors of the time had taken this at face value & would not
     return an ICMP Time Exceeded for an ICMP Echo.  That's when I changed
     to UDP.

Ping doesn't rely on receiving a ICMP TTL exceeded reply.

Ken

---

From: Dave Thaler <[email-masked]>
Date: Thu, 24 Jun 1999 13:22:52 -0400 (EDT)

> Ping doesn't rely on receiving a ICMP TTL exceeded reply.

That's fine but that does not by itself motivate a MUST NOT,
especially if you happen to use the half of the vendors who
did it right.  Hence, I have no problem with making ICMP
RECOMMENDED for ping, and UDP RECOMMENDED for traceroute,
but I don't yet see the motivation for MUST NOT.

-Dave