Subject: Re: disman issue REMOPS-2

From: Randy Presuhn <[email-masked]>
Date: Fri, 25 Jun 1999 23:53:04 -0700 (PDT)

Hi -

> From: Dave Thaler <[email-masked]>
> Subject: Re: disman issue REMOPS-2
> To: [email-masked]
> Date: Thu, 24 Jun 1999 13:22:52 -0400 (EDT)
> Cc: [email-masked], [email-masked]
> 
> > >Issue REMOPS-2:
> > 
> > > Also, it isn't clear to me why ICMP is a MUST NOT for traceroute,
> > > but is RECOMMENDED for ping.  This seems to be an inconsistency:
> > > why shouldn't traceroute have the equivalent of pingCtlType?
> > 
> > I found the following note from Van Jacobson:
> > 
> >      From: [email-masked] (Van Jacobson)
> >      Newsgroups: comp.protocols.tcp-ip
> >      Subject: Re: traceroute history: why UDP?
> >      Date: 8 Feb 1999 08:36:20 GMT
> >      Organization: Lawrence Berkeley National Laboratory, Berkeley CA
> >      Message-ID: <[email-masked]>
> >      References: <[email-masked]>
> > 
> >      In article <[email-masked]>,
> >             [email-masked] (Kevin Steves) writes:
> >      > Were ICMP probes considered in 1988 when Van wrote traceroute?
> > 
> >      The very first traceroute (never released) used icmp echo.  RFC792 (the
> >      icmp spec) contains the words:
> > 
> >          The ICMP messages typically report errors in the processing of
> >          datagrams.  To avoid the infinite regress of messages about messages
> >          etc., no ICMP messages are sent about ICMP messages.
> > 
> >      During the first night of testing I found that more than half the
> >      router vendors of the time had taken this at face value & would not
> >      return an ICMP Time Exceeded for an ICMP Echo.  That's when I changed
> >      to UDP.
> > 
> > Ping doesn't rely on receiving a ICMP TTL exceeded reply.
> 
> That's fine but that does not by itself motivate a MUST NOT,
> especially if you happen to use the half of the vendors who
> did it right.  Hence, I have no problem with making ICMP
> RECOMMENDED for ping, and UDP RECOMMENDED for traceroute,
> but I don't yet see the motivation for MUST NOT.
...

This is a strong argument for replacing the "MUST NOT" with language in
terms of "NOT RECOMMENDED", possibly with a brief note explaining why
anyone who DOES do it with ICMP needs to know exactly what they're doing.

Would anyone object to this as a compromise?

 -----------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 -----------------------------------------------------------------------
 Any relationship between my opinions and BMC's is coincidental.
 -----------------------------------------------------------------------

---

From: Dave Thaler <[email-masked]>
Date: Sun, 27 Jun 1999 15:05:50 -0400 (EDT)

> Would anyone object to this as a compromise?

I would object to allowing multiple methods without a 
traceRouteCtlType object.  If such an object were added,
"NOT RECOMMENDED" would be fine with me.

-Dave