Subject: disman issue REMOPS-6

From: Randy Presuhn <[email-masked]>
Date: Wed, 23 Jun 1999 11:21:46 -0700 (PDT)

Hi -

Disman issue REMOPS-6:

> From: Dave Thaler <[email-masked]>
> Subject: Review of draft-ietf-disman-remops-mib-05.txt
> To: [email-masked]
> Date: Wed, 23 Jun 1999 13:14:26 -0400 (EDT)
...
Issue REMOPS-6:
> >    PingCtlEntry ::=
> >       SEQUENCE {
> 
> Why are there traceRouteCtlSourceAddress and traceRouteCtlIfIndex
> objects, but not pingCtlSourceAddress and pingCtlIfIndex objects?
> I can imagine that they'd be useful for similar reasons.  For
> example the RTT seen by pings may depend on which source interface
> is used, and whether or not the remote system responds to pings
> may depend on the source IP address (e.g. whether it has any route
> to it).
...

 -----------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 -----------------------------------------------------------------------
 Any relationship between my opinions and BMC's is coincidental.
 -----------------------------------------------------------------------

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 28 Jun 1999 14:07:12 -0700 (PDT)

Hi -

> Subject: Re: disman issue REMOPS-6
> To: [email-masked]
> Date: Thu, 24 Jun 1999 13:28:24 -0400 (EDT)
> Cc: [email-masked], [email-masked]
> 
> > >Disman issue REMOPS-6:
> > 
> > > >    PingCtlEntry ::=
> > > >       SEQUENCE {
> > >
> > So perhaps does traceRouteCtlByPassRouteTable. I can add these objects
> > to a ping entry, however I have always viewed traceroute as a more
> > sophisticated form of ping and don't think ping needs to have all of the
> > options that traceroute provides. This is true by the way on most versions
> > of the commands that I have seen.
> 
> I don't disagree with that, but if you're interested in (say)
> monitoring RTT over time, you may not want the extra overhead
> or time of traceroute.  One option would be to put them in
> a separate conformance group if you feel strongly that many
> implementations would not want them.
> 
> -Dave
> 

Without passing judgement on this specific proposal, I note that
the IETF process makes it much easier to remove unused features
than to add new ones during advancement along the standards track.

Are there any strong objections to the additions Dave Thaler proposes?