Subject: Re: disman issue REMOPS-7

From: [email-masked]
Date: Thu, 1 Jul 1999 08:40:54 -0400

Dave,

> > >    pingCtlDataSize OBJECT-TYPE
> > ...
> > >           request is usually an ICMP message encoded
> > >           into an IP packet.  An IP packet has a maximum size
> > >           of 65535 octets.  Subtracting the size of the ICMP
> > >           header (8 octets) and the size of the IP header
> > >           (20 octets) yields a maximum size of 65507 octets."
> >
> > Might be helpful to say "Subtracting the size of the ICMP or
> > UDP header (both 8 octets)..." since both are allowed.
> ...
>
> >Randy: As a technical contributor, I agree with this clarification.

>> I can't see what is wrong with the existing text. An IP packet is
>> limit to 65535 octets. The text says that substracting the ICMP and IP
>> headers you end up with 65507. The IP header is 20 octets since no options
>> are specified. The ICMP header is 8 octets. 65535 - 28 is 65507.
>> What am I missing?

>You're missing the fact that pings can be sent via UDP, in which
>case the size of the ICMP header is completely irrelevant.
>The SIZE clause has to cover the UDP case, and this clarification
>shows that the existing range works for UDP also.

OK. Text changed.

Ken

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 1 Jul 1999 09:39:24 -0700 (PDT)

Hi -

Based on this exchange, I will consider disman issue REMOPS-7 closed if
there are no objections.

> From [email-masked] Thu Jul  1 05:42:34 PDT 1999
> From: [email-masked]
> X-Lotus-FromDomain: IBMUS
> To: Dave Thaler <[email-masked]>
> cc: [email-masked], [email-masked]
> Date: Thu, 1 Jul 1999 08:40:54 -0400
> Subject: Re: disman issue REMOPS-7
> Content-Disposition: inline
> 
> 
> 
> Dave,
> 

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------