Subject: Re: disman issue REMOPS-1

From: Randy Presuhn <[email-masked]>
Date: Thu, 1 Jul 1999 09:37:30 -0700 (PDT)

Hi -

Based on this exchange, if there are no objections, I will consider
issue REMOPS-1 closed.

> From [email-masked] Thu Jul  1 01:58:03 PDT 1999
> From: [email-masked]
> X-Lotus-FromDomain: IBMUS
> To: Dave Thaler <[email-masked]>
> cc: [email-masked], [email-masked]
> Date: Thu, 1 Jul 1999 04:56:06 -0400
> Subject: Re: disman issue REMOPS-1
> Content-Disposition: inline
> 
> 
> 
> Dave,
> 
> > > ICMP Echo Request packets MUST NOT be used.  Many PC implementations do
> > > it incorrectly, which, in turn, causes intermediate hops to be invisible
> > >   ^^
> > > What is "it"?  It would be nice to elaborate on this in the text.
> 
> >> It is using ICMP Echo Request packets (probes) to determine a traceroute
> path.
> 
> >Ok, so if you're saying that Many PC implementations use ICMP probes
> >incorrectly to determine a path, then I would say that "PC"s don't
> >use probes to determine the path, the traceroute program does,
> >so you should say
> >"Many PC implementations of traceroute ..."
> >since it's not an OS issue if it's problems with the way they "use" the
> >probes, and I don't see how that would affect a new implementation for a MIB.
> 
> >On the other hand, if you mean the OS stack has bugs, then I think
> >your definition of "it" above needs to be clarified.
> 
> I have added "of traceroute" to the text.
> 
> Ken
> 

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------

---

From: Dave Thaler <[email-masked]>
Date: Thu, 1 Jul 1999 13:23:46 -0400 (EDT)

> Based on this exchange, if there are no objections, I will consider

I don't know whether I object or not, but I still have an
unanswered question...

> > I have added "of traceroute" to the text.

You didn't answer my last question "how does that affect the implementation
of a MIB"?  Is the reasoning that:
   someone implementing this MIB might start from some implementation
   of an ICMP-based traceroute which contains bugs
?

Is it POSSIBLE to do a traceroute implementation which does not contain
said bugs?  If so, then MUST NOT seems a bit strong to me.

If it is NOT possible to do such an implementation, then the wording
still isn't right.

-Dave