Subject: Re: disman issue REMOPS-1

From: Randy Presuhn <[email-masked]>
Date: Thu, 1 Jul 1999 11:12:42 -0700 (PDT)

Hi -

Ken, could you post the amended text for this paragraph to this thread?

I think the question Dave is raising here ("MUST NOT" vs "NOT RECOMMENDED"
for traceroute implementation based on ICMP) is disman issue REMOPS-2.
If so, can we close REMOPS-1, which was simply a question of what the
referent for "it" was?

> From: Dave Thaler <[email-masked]>
> Subject: Re: disman issue REMOPS-1
> To: [email-masked] (Randy Presuhn)
> Date: Thu, 1 Jul 1999 13:23:46 -0400 (EDT)
> Cc: [email-masked]
> 
> > Based on this exchange, if there are no objections, I will consider
> > issue REMOPS-1 closed.
> 
> I don't know whether I object or not, but I still have an
> unanswered question...
> 
> > > > > ICMP Echo Request packets MUST NOT be used.  Many PC implementations do
> > > > > it incorrectly, which, in turn, causes intermediate hops to be invisible
> > > > >   ^^
> > > > > What is "it"?  It would be nice to elaborate on this in the text.
> > > 
> > > >> It is using ICMP Echo Request packets (probes) to determine a traceroute
> > > path.
> > > 
> > > >Ok, so if you're saying that Many PC implementations use ICMP probes
> > > >incorrectly to determine a path, then I would say that "PC"s don't
> > > >use probes to determine the path, the traceroute program does,
> > > >so you should say
> > > >"Many PC implementations of traceroute ..."
> > > >since it's not an OS issue if it's problems with the way they "use" the
> > > >probes, and I don't see how that would affect a new implementation for a MIB.
> 
> > > I have added "of traceroute" to the text.
> 
> You didn't answer my last question "how does that affect the implementation
> of a MIB"?  Is the reasoning that:
>    someone implementing this MIB might start from some implementation
>    of an ICMP-based traceroute which contains bugs
> ?
> 
> Is it POSSIBLE to do a traceroute implementation which does not contain
> said bugs?  If so, then MUST NOT seems a bit strong to me.
> 
> If it is NOT possible to do such an implementation, then the wording
> still isn't right.
> 
> -Dave
> 

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------

---

From: Dave Thaler <[email-masked]>
Date: Thu, 1 Jul 1999 14:36:24 -0400 (EDT)

> for traceroute implementation based on ICMP) is disman issue REMOPS-2.

Yes, sorry for crossing issues :)

> > said bugs?  If so, then MUST NOT seems a bit strong to me.

If this is the case (it is possible), then yes I agree we can close 
REMOPS-1 (and leave REMOPS-2 open).

> > If it is NOT possible to do such an implementation, then the wording

If this is the case (it's not possible), then REMOPS-1 should remain open
since the proposed change would be incorrect.

Dave