Subject: RE: Comments on notification-log MIB

From: "Sharon Chisholm" <[email-masked]>
Date: Thu, 14 Oct 1999 11:28:39 -0400

hi

I would have to agree that SNMP-NOTIFICATION-LOG-MIB better
fits since the MIB will also be used in a non-distributed manner.

An unrelated question: Does nlmStatsLogNotificationsLogged minus
nlmStatsLogNotificationsBumped give me the current Log Index?
Is it too late to request one object to query to get this number?

thanks

Sharon

> -----Original Message-----
> From:	Sandra Durham [SMTP:[email-masked]]
> Sent:	October 13, 1999 3:54 PM
> To:	Juergen Schoenwaelder; [email-masked]
> Cc:	[email-masked]
> Subject:	Re: Comments on notification-log MIB
> 
> 
> At 07:25 PM 10/13/99 +0200, Juergen Schoenwaelder wrote:
> 
> >I will certainly not object against DISMAN-NOTIFICATION-LOG-MIB, but I
> >think that there is some truth in Bob's argument that this MIB really
> >belongs to SNMP core infrastructure and that it is likely that this
> >MIB goes into devices that have absolutely no intention to do
> >distributed management.
> 
> As a potential implementor of said mib, i'd agree w/ Juregen - my use is
> purely a core snmp feature.
> 
> Sandra Durham
> cisco systems
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 14 Oct 1999 18:40:09 +0200

>>>>> Sharon Chisholm writes:

Sharon> An unrelated question: Does nlmStatsLogNotificationsLogged
Sharon> minus nlmStatsLogNotificationsBumped give me the current Log
Sharon> Index?  Is it too late to request one object to query to get
Sharon> this number?

I do not think this behaviour is specified. (Note that these are
defined as counters.) And even if it were specified, doing

  get(nlmStatsLogNotificationsLogged.0, nlmStatsLogNotificationsBumped.0)
  x = calc_last_index()
  get(<somethinghere>.x)

will not necessarily give you the latest one in all cases.

/js

-- 
Juergen Schoenwaelder      Technical University Braunschweig
<[email-masked]>  Dept. Operating Systems & Computer Networks
Phone: +49 531 391 3289    Bueltenweg 74/75, 38106 Braunschweig, Germany
Fax:   +49 531 391 5936    <URL:http://www.ibr.cs.tu-bs.de/~schoenw/>