Subject: Re: Ref: Event MIB

From: Randy Presuhn <[email-masked]>
Date: Mon, 13 Dec 1999 16:32:43 -0800 (PST)

Hi -

> Date: Fri, 19 Nov 1999 10:43:48 +0100
> From: Juergen Schoenwaelder <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
> Subject: Re: Ref: Event MIB
> References:  <4.1.19991119141301.00a19320@cbinmail>
> List-Id: IETF disman Working Group mailing list <[email-masked]>
> 
> 
> 
> >>>>> aseem sethi writes:
> 
> aseem> Can someone please take a look at the following proposed
> aseem> changes in the Event MIB, to see if they make sense, and
> aseem> whether we should modify the MIB.
> 
> I argued several times in the past that the indexing structure of the
> tables in the Event MIB is, let me say ugly. Bob did not want to
> discuss this and so I finally gave up on it. Sure, this does not mean
> I changed my mind and hence I agree with comment 1 below (although
> this addresses only one of the problems I see).
...

It does indeed look like mteEventName (rather than
mteTriggerName) should be used as an index for
mteEventNotificationEntry and mteEventSetTable.

I wasn't able to make out that this was what Aseem was
asking for until I read Alan Luchuk's description of
the problem.

 -------------------------N-E-W---A-D-D-R-E-S-S--------------------------
 Randy Presuhn           [email-masked]       http://www.bmc.com/
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141  2141 N. First Street
 Fax:   +1 408 965-0359  San Jose, California 95131  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's should be coincidental.
 ------------------------------------------------------------------------

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 20 Dec 1999 11:55:37 -0800 (PST)

Hi -

> Date: Sun, 19 Dec 1999 01:51:20 -0800
> To: Randy Presuhn <[email-masked]>, [email-masked]
> From: Ramanathan Kavasseri <[email-masked]>
...
> I can go with option (b). The clincher for me is the part about
> "which mteEventActions was the one governing the behaviour of
> a given mteEventSetEntry or mteEventNotificationEntry..."
> 
> I didn't hear voices for option (a) other than mine, so
> I'm assuming we've got consensus on this?
...

Yup.  As WG chair, I declare consensus for (b).  (We're really
at the stage of resolving IESG reviewer comments, but I didn't
want anyone to be surprised by what came out of the process.)
Ram, I think you understand the edits.  :-)