Subject: Schedule MIB enhancements (Was: Re: snmpconf Interim Meeting Notes Day Two)

From: Randy Presuhn <[email-masked]>
Date: Tue, 12 Sep 2000 09:45:42 -0700 (PDT)

Hi -

> Date: Tue, 12 Sep 2000 17:45:10 +0200
> Message-Id: <[email-masked]>
> From: Juergen Schoenwaelder <[email-masked]>
> To: [email-masked]
> CC: DISMAN Mailing List <[email-masked]>
> In-reply-to: <[email-masked]> (message from Steve
> 	Moulton on Thu, 07 Sep 2000 18:37:50 -0400)
> Subject: Re: snmpconf Interim Meeting Notes Day Two
> References:  <[email-masked]>
...
> From reading the snmpconf minutes, I do not understand what your
> proposed change actually looks like. So please come up with some more
> details quickly and please get the DISMAN WG involved by CC'ing them
> or moving discussion of the proposed scheduling MIB change to the
> DISMAN list itself.
...

If there are to be proposed changes to the schedule MIB, please
make those proposals NOW.  The WG last call on this document was
to have ended months ago, and it's just been a matter of editor
availability that's kept this from being handed to the AD for
presentation to the IESG.  If changes are necessary, please
spell them out now.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

---

From: Jon Saperia <[email-masked]>
Date: Tue, 12 Sep 2000 13:16:54 -0400

> presentation to the IESG.  If changes are necessary, please

Randy and Juergen,

Hongal had been pursuing this issue and we talked a bit about it at the IETF
meeting. I do not think there is consensus yet.

From the posted minutes, there were the following relevant points:

> .  When using the schedule MIB, you would need to create a MIB entry
> that would point back to the entry that would be started.
> Actually you would need two entries in the schedule MIB one for starting
> (setting the admin status to enable) and one for stopping
> (setting the admin status to disable).  We may be able
> to add an augments clause to the schedule MIB to pack the
> information into one entry.
> 
> .  One needs to make sure that the forward and backward pointers
> stay in sync.  To do this, there should be a one-to-one pairing.
> Have two schedule entries pointing to one ifAdminStatus would be
> difficult to maintain.
> 
> .  If we use the schedule MIB, we need to bear in mind that it has
> up to one minute latency after one presses the go button.
> 
> In summary, we are talking about augmenting the schedule MIB so
> that we have the start and stop times rather than having multiple
> entries.  This is a proposed change.

You will note from David Partain's note that he is organizing our list of
issues and actions. I can ask that we get to this ASAP by can not promise a
specific resolution in a specific time.  That said, we have the following
choices. If time pressure makes it right to move forward with the Schedule
MIB then, we will have to work out some other solution. If it is possible to
wait until we conclude our interim meeting and post to the mail list, then
we might get good input to your effort.

Folks, Randy and Juergen have a point about the disman work. When we bring
these topics up on this [snmpconf] list we should be sure to cross post them
to the disman group.

Thanks
/jon

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 13 Sep 2000 09:59:53 +0200

>>>>> Jon Saperia writes:

Jon> Folks, Randy and Juergen have a point about the disman work. When
Jon> we bring these topics up on this [snmpconf] list we should be
Jon> sure to cross post them to the disman group.

I am not really a big fan of extensive cross postings (since I happen
to be on both lists anyway). I think a few cross posts to tell people
on which list a certain issue is handled is more appropriate. 

It might be helpful if the chairs of the WGs can actually negotiate
how the WGs can best cooperate. For example, if the snmpconf folks can
formulate a clear requirement what they need from the schedule MIB,
then the disman folks may be able to provide a solution without
extensive cross postings in both WG mailing lists.

/js

-- 
Juergen Schoenwaelder      Technical University Braunschweig
<[email-masked]>  Dept. Operating Systems & Computer Networks
Phone: +49 531 391 3289    Bueltenweg 74/75, 38106 Braunschweig, Germany
Fax:   +49 531 391 5936    <URL:http://www.ibr.cs.tu-bs.de/~schoenw/>

---

From: Jon Saperia <[email-masked]>
Date: Wed, 13 Sep 2000 07:59:46 -0400

> extensive cross postings in both WG mailing lists.

Juergen, 

I think this is an excellent idea and good way to collect the input for this
one. David Partain and I talked about this and would like to propose that
the SNMNPCONF WG give you a short set of requirements bullets and a set of
ideas about how we could use the schedule MIB with some changes.

I will send out a separate note starting this off.

/jon