Subject: RE: alarm definitions

From: "Ayers, Mike" <[email-masked]>
Date: Fri, 16 Mar 2001 11:36:44 -0600

> From: Juergen Schoenwaelder [mailto:[email-masked]]
> 
> I am looking at it from a manager's point of view. A severity level of
> 42 which just means it is worse than 41 and nothing else is just
> useless for me since I do not know whether the possible range for the
> implementation that generated this alarm^H^H^H^H^Hsomething is 1-42,
> 1-100, 1-1000 or 1-2147483647 nor do I know that the values are evenly
> distributed in the ranges and so on.

	Aaaaahhh....

	This bit had eluded me - thanks for the clarification.  So, it seems
we'll have to guess after all.  How about this:

	0: clear
	1: indeterminate
	2: informational (verbose)
	3: informational
	4: warning
	5: minor
	6: medium
	7: major
	8: critical
	9: extreme

	This will fit the ITU model, as well as any of the few models I've
dealt with.  The neat property is that you can sort into four general
categories (indeterminate, informational, alarms, panics) just by anding on
the severity.  Actually, I'd be most comfortable with more states, but this
would be good enough, I suspect.

/|/|ike

---

From: Lauren Heintz <[email-masked]>
Date: Fri, 16 Mar 2001 09:50:01 -0800

You got medium in there, but what about small and large?

:-)

Lauren

P.S. Or is medium really a small, and if you really
want a medium you have to order a large (because a
true large is really a jumbo).

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 16 Mar 2001 11:35:39 -0800

HI,

These categories below are for syslog messages. A syslog message is
not an alarm, and the categories are not the perceived severity of
an alarm. 

Mike - are you trying to be satirical?

regards,
/david t. perkins

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 16 Mar 2001 11:37:14 -0800

HI,

So I guess mike was joking and lauren has the follow up.

Regards,
/david t. perkins