Subject: Re: comments on schedule MIB

From: Randy Presuhn <[email-masked]>
Date: Thu, 22 Mar 2001 08:31:15 -0800 (PST)

Hi -

WG chair says: I've alerted our AD to the fact that these issues
have been raised, and he's agreed that we should iron this out
in the WG, rather than waiting until IESG review or IETF last call
to deal with it.

As a technical contributor:

> Date: Thu, 22 Mar 2001 07:35:18 +0100
> Message-Id: <[email-masked]>
> From: Juergen Schoenwaelder <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
> In-reply-to: <[email-masked]> (message from Tammy Ferris on
> 	Wed, 21 Mar 2001 10:16:46 -0600)
> Subject: Re: comments on schedule MIB
> References:  <[email-masked]>
...
> (a) Events in non-existant times just do not happen.

I like this, especially since it makes the handling
of non-existant dates consistent with the handling
of non-existant times.

> (b) Events in ambiguous times may invoke actions multiple times.

This does not bother me, especially since the examples cited
fit better into the "periodic" rather than the "calendar"
paradigm.  Something about hammers and nails comes to mind. :-)

> These rules seem to be simpler to implement. Whether the behaviour is
> more desirable depends on what you are scheduling. I personally do not
> have a strong opinion on this issue (except that making the behaviour
> configurable seems like real overkill to me).
...

I agree that making the behaviour configurable would be excessive.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

---

From: "Ayers, Mike" <[email-masked]>
Date: Thu, 22 Mar 2001 11:02:07 -0600

> From: Juergen Schoenwaelder [mailto:[email-masked]]
> 
> Am I understanding correctly that your propose the following:
> 
> Any other opinions on this, please?
> 

	I favor this interpretation.  This would prevent the Schedule MIB
from wedging its host, which is a possibility under the current text.

/|/|ike