Subject: Shared Textual Conventions for Alarms/Conditions

From: "Sharon Chisholm" <[email-masked]>
Date: Thu, 5 Apr 2001 16:39:31 -0400

hi

We had discussed sharing textual conventions across
the two sets of MIBs.  Here are some generic textual
conventions for ITU parameters.  Were there others
we wanted to share?  Did we want to create a separate
textual conventions MIB, or is everyone fine with
importing them from the ITU Alarm MIB?

Tom had some issues with the way we are all defining
probable cause.  Did we want IANA to manage the value
instead?

-- Textual Conventions

ItuProbableCause ::= TEXTUAL-CONVENTION   
     STATUS current
     DESCRIPTION
             "ITU probable cause values for the alarms as per []."    
     SYNTAX         INTEGER
             {
              other (1),
              adapterError (2),
              applicationSubsystemFailure (3),
              bandwidthReduced (4),
              callEstablishmentError (5),
              communicationsProtocolError (6),
              communicationsSubsystemFailure (7),
              configurationOrCustomizationError (8),
              congestion (9),
              corruptData (10),
              cpuCyclesLimitExceeded (11),
              dataSetOrModemError (12),
              degradedSignal (13),
              dteDceInterfaceError (14),
              enclosureDoorOpen (15),
              equipmentMalfunction (16),
              excessiveVibration (17),
              fileError (18),
              fireDetected (19),
              floodDetected (20),
              framingError (21),
              heatingVentCoolingSystemProblem (22),
              humidityUnacceptable (23),
              inputOutputDeviceError (24),
              inputDeviceError (25),
              lanError (26),
              leakDetected (27),
              localNodeTransmissionError (28),
              lossOfFrame (29),
              lossOfSignal (30),
              materialSupplyExhausted (31),
              multiplexerProblem (32),
              outOfMemory (33),
              ouputDeviceError (34),
              performanceDegraded (35),
              powerProblem (36),
              pressureUnacceptable (37),
              processorProblem (38),
              pumpFailure (39),
              queueSizeExceeded (40),
              receiveFailure (41),
              receiverFailure (42),
              remoteNodeTransmissionError (43),
              resourceAtOrNearingCapacity (44),
              responseTimeExecessive (45),
              retransmissionRateExcessive (46),
              softwareError (47),
              softwareProgramAbnormallyTerminated (48),
              softwareProgramError (49),
              storageCapacityProblem (50),
              temperatureUnacceptable (51),
              thresholdCrossed (52),
              timingProblem (53),
              toxicLeakDetected (54),
              transmitFailure (55),
              transmitterFailure (56),
              underlyingResourceUnavailable (57),
              versionMismatch (58),
              authenticationFailure (59),
              breachOfConfidentiality (60),
              cableTamper (61),
              delayedInformation (62),
              denialOfService (63),
              duplicateInformation (64),
              informationMissing (65),
              informationModificationDetected (66),
              informationOutOfSequence (67),
              intrusionDetection (68),
              keyExpired (69),
              nonRepudiationFailure (70),
              outOfHoursActivity (71),
              outOfService (72),
              proceduralError (73),
              unauthorizedAccessAttempt (74),
              unexpectedInformation (75)
              } 

ItuEventType ::= TEXTUAL-CONVENTION   
     STATUS current
     DESCRIPTION
             "The ITU event Type values as per []"    
     SYNTAX         INTEGER
            { 
            other (1),  
            communicationsAlarm (2),
            qualityOfServiceAlarm (3),
            processingErrorAlarm (4),
            equipmentAlarm (5),
            environmentalAlarm (6),
            integrityViolation (7),
            operationalViolation (8),
            physicalViolation (9),
            securityServiceOrMechanismViolation (10),
            timeDomainViolation (11)
            } 	

ItuPerceivedSeverity ::= TEXTUAL-CONVENTION   
     STATUS current
     DESCRIPTION
             "ITU perceived severity values as per []"    
     SYNTAX         INTEGER
			{
            cleared (1),
            indeterminate (2),
            critical (3),
            major (4),
            minor (5),
            warning (6)
            } 	

Sharon Chisholm
Preside Management
Nortel Networks
Ottawa, Ontario

---

From: "Huynh, An-Ni (Anni)" <[email-masked]>
Date: Wed, 11 Apr 2001 14:36:28 -0400

Sharon:

I looked at the two lists from X.733 and M.3100.  None of them covers
all the alarm types.  I like to structure of M.3100 though.  Under the 
commuication alarms, it is more for transport NEs, we need to add other
alarm types that are specific to Ethernet HUB, LAN, etc...

In M.3100 the probable causes are listed in sections:
*	Communications alarms (AIS, LOS, LOF, BER)
*	Equipment alarm (backplan failure, processor problem, power problem)
*	Environmental alarm (low battery, generator failure, air
conditioning failure..)
*	Processing error or software alarm
*	service problem (not specified).

I would like to recommend that we use the M.3100 list, and
*	add to the list the missing fault type.
*	modify where it is needed (for example, lineCardProblem can be
replaced by equipment failure,
	the entity identifier will tell that it is a lineCard or other type
of circuit packs)
*	get IANA to manage the value
*	provide a section for proprietary uses

Anni.

List below is the list from M.3100 for reference:

indeterminate	ProbableCause ::= localValue : 0
-- The following are used with communications alarm.
aIS ProbableCause ::= localValue : 1 
callSetUpFailure ProbableCause ::= localValue : 2
degradedSignal ProbableCause ::= localValue : 3
farEndReceiverFailure ProbableCause ::= localValue : 4
framingError ProbableCause ::= localValue : 5
lossOfFrame ProbableCause ::= localValue : 6
lossOfPointer ProbableCause ::= localValue : 7
lossOfSignal ProbableCause ::= localValue : 8
payloadTypeMismatch ProbableCause ::= localValue : 9
transmissionError ProbableCause ::= localValue : 10
remoteAlarmInterface ProbableCause ::= localValue : 11
excessiveBER ProbableCause ::= localValue : 12
pathTraceMismatch ProbableCause ::= localValue : 13
unavailable ProbableCause ::= localValue : 14
signalLabelMismatch ProbableCause ::= localValue : 15
lossOfMultiFrame ProbableCause ::= localValue : 16
-- Values 17-50 are reserved for communications alarm related probable
causes
-- The following are used with equipment alarm.
backplaneFailure	ProbableCause ::= localValue : 51
dataSetProblem ProbableCause ::= localValue : 52
equipmentIdentifierDuplication ProbableCause ::= localValue : 53
externalIFDeviceProblem ProbableCause ::= localValue : 54
lineCardProblem ProbableCause ::= localValue : 55
multiplexerProblem ProbableCause ::= localValue : 56
nEIdentifierDuplication ProbableCause ::= localValue : 57
powerProblem ProbableCause ::= localValue : 58
processorProblem ProbableCause ::= localValue : 59
protectionPathFailure ProbableCause ::= localValue : 60
receiverFailure ProbableCause ::= localValue : 61
replaceableUnitMissing ProbableCause ::= localValue : 62
replaceableUnitTypeMismatch ProbableCause ::= localValue : 63
synchronizationSourceMismatch ProbableCause ::= localValue : 64
terminalProblem ProbableCause ::= localValue : 65
timingProblem ProbableCause ::= localValue : 66
transmitterFailure ProbableCause ::= localValue : 67
trunkCardProblem ProbableCause ::= localValue : 68
replaceableUnitProblem ProbableCause ::= localValue : 69
-- Values 70-100 are reserved for equipment alarm related probable causes

-- The following are used with environmental alarm.
airCompressorFailure ProbableCause ::= localValue : 101
airConditioningFailure ProbableCause ::= localValue : 102
airDryerFailure ProbableCause ::= localValue : 103
batteryDischarging ProbableCause ::= localValue : 104
batteryFailure ProbableCause ::= localValue : 105
commercialPowerFailure ProbableCause ::= localValue : 106
coolingFanFailure ProbableCause ::= localValue : 107
engineFailure ProbableCause ::= localValue : 108
fireDetectorFailure ProbableCause ::= localValue : 109
fuseFailure ProbableCause ::= localValue : 110
generatorFailure ProbableCause ::= localValue : 111
lowBatteryThreshold ProbableCause ::= localValue :112
pumpFailure ProbableCause ::= localValue : 113
rectifierFailure ProbableCause ::= localValue : 114
rectifierHighVoltage ProbableCause ::= localValue : 115
rectifierLowFVoltage ProbableCause ::= localValue : 116
ventilationsSystemFailure ProbableCause ::= localValue : 117
enclosureDoorOpen ProbableCause ::= localValue : 118
explosiveGas ProbableCause ::= localValue : 119
fire ProbableCause ::= localValue : 120
flood ProbableCause ::= localValue : 121
highHumidity ProbableCause ::= localValue : 122
highTemperature ProbableCause ::= localValue : 123
highWind ProbableCause ::= localValue : 124
iceBuildUp ProbableCause ::= localValue : 125
intrusionDetection ProbableCause ::= localValue : 126
lowFuel ProbableCause ::= localValue : 127
lowHumidity ProbableCause ::= localValue : 128
lowCablePressure ProbableCause ::= localValue : 129
lowTemperatue ProbableCause ::= localValue : 130
lowWater ProbableCause ::= localValue : 131
smoke ProbableCause ::= localValue : 132
toxicGas ProbableCause ::= localValue : 133
-- Values 134-150 are reserved for environmental alarm related probable
causes

-- The following are used with Processing error alarm.
storageCapacityProblem ProbableCause ::= localValue : 151
memoryMismatch ProbableCause ::= localValue : 152
corruptData ProbableCause ::= localValue : 153
outOfCPUCycles ProbableCause ::= localValue : 154
sfwrEnvironmentProblem ProbableCause ::= localValue : 155
sfwrDownloadFailure ProbableCause ::= localValue : 156

-- Service ProblemType is for further study

> ----------
> From: 	Sharon Chisholm[SMTP:[email-masked]]
> Sent: 	Thursday, April 05, 2001 4:39 PM
> To: 	[email-masked]
> Subject: 	Shared Textual Conventions for Alarms/Conditions
> 
> 
> hi
>