Subject: RE: draft 51stIETF DISMAN WG Minutes

From: "Lam, Hing-Kam (Kam)" <[email-masked]>
Date: Mon, 13 Aug 2001 10:47:30 -0400

Hi Laruen,

I think the action item of
"to bring discussion to list regarding notification-log MIB security issues"
belongs to someone else.

Regards,
Kam

-----Original Message-----
From: Lauren Heintz [mailto:[email-masked]]
Sent: Friday, August 10, 2001 3:15 PM
To: [email-masked]
Cc: Randy Presuhn
Subject: draft 51stIETF DISMAN WG Minutes

Hi,

Here is the first cut at the DISMAN minutes.
Please send any corrections/omissions/etc.

In the next few days I may consolidate
another set of notes I am shortly expecting
into this set (or vice versa).

Thanks, Lauren

--------------------------------------------------------

51st IETF (London) DISMAN WG, 06/08/2001, 0900 GMT

Meeting chaired by Randy Presuhn

Minutes compiled by Lauren Heintz

Note: Search for "***" for action items.

Randy opened with agenda bashing.  David Perkins
requested to add a review of the notification
log MIB to the agenda, and this was accepted.

Randy gave status updates for various MIBs:
the script MIB is now in IETF last call;
the schedule MIB is in the hands of IESG;
there may be an inconsistency between
the expression and event MIBs; the remote OPs,
event and notification-log MIBs are proposed
stds; the noitification-log MIB apparently has one
object that needs deprecation.

The latest Alarm MIB draft is now at v02,
and incorporates the ITU-Alarm MIB.

The Condition MIB, v01, is now being written
and is slated to replace older condition,
Alarm and ARC MIBs.  An issue was raised that
only published drafts should be discussed,
but the group decided to allow discussion of the
forthcoming Condition MIB.

David Perkins suggested that the Alarm MIB may
not have fully considered Telcordia requirements
and asks that Telcordia Alarm models and terminology
be considered/adopted.  Kam suggested ITU is a superset
of Telcordia.

Bert asked David to research Telcordia documents
and perhaps coordinate a "loan" of such to the IETF
DISMAN WG.  ***David agreed to take an action item
on this.

Sharon presented the ITU Active Alarm MIB:
overview, changes since Minneapolis, Issues.

The v02 draft now includes these changes:
- architecture goals section
- alignment with condition and ARC
- added optional generic alarm notifications
- made alarm state transitions to be more flexible
- combined drafts. though MIBs remain in separate MODULEs
- added more examples
- created ITU IANA TC

Active alarm MIB is independant of condition MIB;
may need more work to decouple them more

May want IANA to control certain TCs (e.g. probable cause).
As a rule of thumb, it was stated that IANA should control
TCs that change over time.

It was stated there was no need to create a new ID
for TCs not destined for IANA.  Instead,
they should be put in the Active Alarm MIB document.
This caused some debate: Dan Rom' cautioned about linking
IDs and the need to avoid cyclical dependencies, Sharon
wanted stand-alone TC MIB within the Alarm ID, Mike Ayers
does not want too many IDs.  It was decided that consolidation
was a good short term strategery and that things could change
a bit later on if the situation warranted it.

David (?) - Alarm Model State in example 6 incorrectly
uses ITU Severity states, which are unordered.

David Perkins raised new issues about terminology,
incorrect usage of SHOULD/MUST/etc.  ***David
should send these detailed issues to the list.
*** Randy promised/volunteered that the editors would
track all raised issues.

*** Randy took an action item to update
the charter with the revised/consolidated
MIB lists.

David Perkins raised concern whether the
ActiveAlarmTable could be used by a manager.
He is mainly concerned about the use of TimeFilter,
which he contends is incorrectly used in this case.
Dan Rom' indicated TimeFilter was added as an index
to help managers efficiently determine whether a specific
Alarm had been cleared or not.  This is because another
mechanism does not exist in the MIB to determine what
alarms had been cleared since a prior manager/agent
alarm sync.  No objections were heard to a proposed
requirement to have an efficient mechanism to determine
cleared alarms.

A debate ensued about whether or not alarms need to be
reportable without notifications.  Randy indicated that
for implementations that chose to use the AgentX notify
PDU, notifications would result.

A question was raised about whether the current
mechanism for matching notifications to conditions
is sufficient.  ***Sharon took an action item
to provide audit results to the list for further
discussion.

Kam discussed the new, as of yet unpublished, condition
MIB.

It was pointed out that TimeInterval has potential issues
in distributed architectures if provided as a scalar
instead of within a table.

Sharon raised an issue about inconsistent indexing in the
v00 draft MIB version and suggested ARC and alarm MIBs
should use consistent indices that are also conducive
to the entity MIB.

Mike raised concerns about whether it is proper to
tie alarms and entities together, and Dale suggested
that entPhysicalIndex is very appropriate to use.
*** Mike took an action item to raise a thread on
the list about the mechanism to identify alarm
sources and whether the entity MIB is useful.
It was suggested we need to refrain from
defining custom alarm source defs and to
perhaps instead use OIDs to allow generic source IDs.

*** Kam took an action item to bring discussion
to list regarding notification-log MIB
security issues.

The group was asked whether there were
suggestions for further script MIB work
within DISMAN WG?  No respone.

Charter updates were considered and it was
decided that the March 01 date for recycling
the log-mib needed more thought.  It was also
suggested that the August01 milestone (alarm MIB)
needed a new date.

Dan Rom' suggested a last-call was possible for the
Alarm mgmt MIB for a late December or early January.
*** Randy took an action item to get Bert suitably
sauced to get this accepted.

It was stated that the current December charter
milestones were still feasible as of now.
NOTE: I see no December milestone on the charter
(which was last updated 9 August -- today).  Perhaps
we were instead talking about the "proposed" December
milestones above?

*** Mike took an action item to discuss
arch' issues about justification for
differences between alarm and condition
MIBs.

*** Kam and Sharon took an action item to ensure
docs are clearer about the distinction and
also the complimentary nature of alarm and condition
MIB.

EOF

---

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 20 Aug 2001 15:29:54 -0400

hi

Some very minor clarifications from the minutes ...

-----Original Message-----

Lauren> Sharon presented the ITU Active Alarm MIB:
Lauren> overview, changes since Minneapolis, Issues.

That's actually the Alarm MIB.  It also includes the
ITU Alarm MIB, but the title is Alarm MIB.

Lauren> Sharon raised an issue about inconsistent indexing in the
Lauren> v00 draft MIB version and suggested ARC and alarm MIBs
Lauren> should use consistent indices that are also conducive
Lauren> to the entity MIB.

It was not the indexing I raised the issue against, but rather
the way that resources were identified.  Mainly with the 
arcIndex(OID) in the ARC mib and condActiveLocation(SnmpAdminString).
The Alarm MIB currently has an pointer to entPhysicalIndex which
can be used to identify the resource in a consistent manner.  Notification
varbinds can also be used, but in a less consistent manner.

Sharon