Subject: Re: simple question on pingCtlMaxRows - pingMIB (rfc2925)

From: Randy Presuhn <[email-masked]>
Date: Tue, 30 Oct 2001 14:11:21 -0800 (PST)

Hi -

I haven't seen any response to this query, so I figured it's
time for someone to give it a try.  Will we need to make any
changes or clarifications to RFC 2925?

I think the answer to question 1 below is (A).

Regarding question 2...
As I read 2925, garbage collection of entries after a change
to pingCtlMaxRows isn't required to happen until a new history
entry is to be added to the table.  The special value "0"
is singled out as disabling the creation of new entries.
So, I'd interpret the current text as saying that the effect
would be of "freezing" the log, rather than emptying it.

Would it be desireable to add language stipulating that
changes to *MaxRows trigger garbage collection?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

> Message-ID: <[email-masked]>
> Date: Tue, 05 Jun 2001 10:10:45 -0700
> From: Paul Fraley <[email-masked]>
> X-Accept-Language: en
> To: [email-masked], [email-masked]
> CC: [email-masked]
> Subject: simple question on pingCtlMaxRows - pingMIB (rfc2925)
> List-Id: IETF disman Working Group mailing list <disman.dorothy.bmc.com>
> 
> 
> I need to know what happens when pingCtlMaxRows is set to a number
> less than the number of entries CURRENTLY in the History table for
> a given ping test.
> 
> Consider the following scenario, for a given Ping test:
>    Run 1
>        pingCtlProbeCount  == 15
>        pingCtlMaxRows     == 30
> 
>    At the end of this run, I have 15 entries in the History table,
>    numbered 1-15
> 
>    Run 2
>        pingCtlProbeCount  == 15
>        pingCtlMaxRows     == 30
> 
>    At the end of this run, I have 30 entries in the History table,
>    numbered 1-30
> 
>    Run 3
>        pingCtlProbeCount  == 15
>        pingCtlMaxRows     == 30
> 
>    At the end of this run, I have 30 entries in the History table,
>    numbered 16-45
> 
>    Run 4
>        pingCtlProbeCount  == 15
>        pingCtlMaxRows     ==  5
> 
> Question 1.
>     What should have at the end of the end of Run 4?
> 
>     A.  5 entries numbered 56-60?
>     B. 30 entries numbered 31-60?
>     C. something else?  if so, what?
> 
> Question 2.
>     What happens when I set pingCtlMaxRows to 0?  Do I delete any 
>     current History entries for this test?  If so, I would assume
>     that I would do this when I STARTED the test, and NOT when
>     pingCtlMaxRows is set 0.
> 
> Thanks,
> 
> Paul
> [email-masked]
>

---

From: "Kenneth White" <[email-masked]>
Date: Wed, 31 Oct 2001 14:56:44 -0500

Hi,

> I think the answer to question 1 below is (A).

I agree.

>>     that I would do this when I STARTED the test, and NOT when

I would delete all related entries as the action of setting
pingCtlMaxRows to 0.

Ken