Subject: draft-ietf-disman-alarm-mib-05.txt Just Submitted

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 6 Feb 2002 09:12:07 -0500

hi

We've just sent -05 of the alarm MIB into
internet drafts. It should be appearing
shortly.

Newly Closed Issues
-------------------

Alarm #11 Resource Identification

In the interest of working group consensus and the
fact that we claim to be providing a generic alarm
model, we have gone with the OID for the resource
identifier. We've hopefully provided enough guidance
that it gets used consistently.

We also included an alarmActiveDescription to the
alarmActiveTable to serve people looking for something
displayable without any processing.

Alarm #18 Active & Cleared Shared Indices

We created an alarmClearIndex that has the same value
as the alarmActiveIndex had, but continues to exist
after the alarm is no longer active.

Alarm #20 OID Aesthetics

We made this change to prevent to "0 1" thing appearing
in the SMI.

Sharon Chisholm
Preside Management
Nortel Networks
Ottawa, Ontario

---

From: David Partain <[email-masked]>
Date: Mon, 11 Feb 2002 17:39:39 +0100

Hi Sharon,

In glancing through the new alarm MIB, there are a few things
that need to be changed:

I see you did what I recommended and changed some indices
to accessible-for-notify.  Unfortunately, as David Perkins
correctly pointed out, this is illegal. :-)  They must
be not-accessible.  This applies to alarmModelIndex,
alarmModelState.  That also means that you have to change
alarmSet to include a different object from the alarmModelTable
and remove alarmModelIndex and alarmModelState.  I put in the
description object for the diff below.

Your "ResourceId" TC violates the SMI because RowPointer is a
TC itself.  You need either to change this to OBJECT IDENTIFIER
or simply give alarmActiveResourceId and alarmClearResourceId
the SYNTAX RowPointer and explain in the DESCRIPTION where it
should point.  If you just use RowPointer, it would mean you
can remove the TC completely.

The name of alarmActiveStatsLastRaise in one of the object
groups needs to be changed.

Note that this diff doesn't reflect your mail about calling the
notification alarmActive.

Hope this helps.

Cheers,

dlp

--- ALARM-MIB.orig	Mon Feb 11 17:27:50 2002
+++ ALARM-MIB	Mon Feb 11 17:32:17 2002
@@ -6,8 +6,7 @@
    TimeTicks, Counter32, Counter64,
    IpAddress, Opaque, mib-2            FROM SNMPv2-SMI
    DateAndTime,
-   RowStatus, RowPointer,
-   TEXTUAL-CONVENTION                  FROM SNMPv2-TC
+   RowStatus, RowPointer               FROM SNMPv2-TC
    SnmpAdminString, SnmpEngineID       FROM SNMP-FRAMEWORK-MIB
    InetAddressType, InetAddress        FROM INET-ADDRESS-MIB
    MODULE-COMPLIANCE, OBJECT-GROUP,
@@ -52,22 +51,6 @@

 alarmClear OBJECT IDENTIFIER ::= { alarmObjects 3 }

--- Textual Conventions
-
-ResourceId ::= TEXTUAL-CONVENTION
-    STATUS current
-    DESCRIPTION
-            "A unique identifier for this resource.
-
-            The type of the resource can be determined by looking
-            at the OID that describes the resource.
-
-            Resources must be identified in a consistent manner.
-            For example, if this resource is an interface, this
-            object MUST point to an ifIndex."
-    SYNTAX         RowPointer
-
-
 -- Alarm Model

 alarmModelLastChanged  OBJECT-TYPE
@@ -118,7 +101,7 @@

 alarmModelIndex OBJECT-TYPE
    SYNTAX     Unsigned32 (1..4294967295)
-   MAX-ACCESS accessible-for-notify
+   MAX-ACCESS not-accessible
    STATUS     current
    DESCRIPTION
        "An integer that acts as an alarm Id
@@ -128,7 +111,7 @@

 alarmModelState OBJECT-TYPE
    SYNTAX  Unsigned32 (1..4294967295)
-   MAX-ACCESS	accessible-for-notify
+   MAX-ACCESS	not-accessible
    STATUS       current
    DESCRIPTION
         "A value of 1 MUST indicate a clear alarm state.
@@ -261,7 +244,7 @@
    alarmActiveContextName           SnmpAdminString,
    alarmActiveVariables             Unsigned32,
    alarmActiveNotificationID        OBJECT IDENTIFIER,
-   alarmActiveResourceId            ResourceId,
+   alarmActiveResourceId            RowPointer,
    alarmActiveDescription           SnmpAdminString,
    alarmActiveLogIndex              Unsigned32,
    alarmActiveModelPointer          RowPointer,
@@ -374,7 +357,7 @@
    ::= { alarmActiveEntry 9 }

 alarmActiveResourceId    OBJECT-TYPE
-   SYNTAX      ResourceId
+   SYNTAX      RowPointer
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
@@ -706,7 +689,7 @@
    alarmClearEngineAddress         InetAddress,
    alarmClearContextName           SnmpAdminString,
    alarmClearNotificationID        OBJECT IDENTIFIER,
-   alarmClearResourceId            ResourceId,
+   alarmClearResourceId            RowPointer,
    alarmClearLogIndex              Unsigned32,
    alarmClearModelPointer          RowPointer
    }
@@ -794,7 +777,7 @@
    ::= { alarmClearEntry 7 }

 alarmClearResourceId    OBJECT-TYPE
-   SYNTAX      ResourceId
+   SYNTAX      RowPointer
    MAX-ACCESS  read-only
    STATUS      current
    DESCRIPTION
@@ -829,25 +812,26 @@

 alarmSet NOTIFICATION-TYPE
- OBJECTS     { alarmModelIndex,
-               alarmModelState,
+ OBJECTS     { alarmModelDescription,
                alarmActiveResourceId }
  STATUS      current
  DESCRIPTION
-    "An instance of the alarm indicated by alarmModelIndex
-    has been set against the entity indicated by
-    alarmActiveResourceType and alarmACtiveResourceId."
+    "An instance of the alarm indicated by alarmModelIndex/
+    alarmModelState (found by gleaning the index from
+    alarmModelDescription) has been set against the
+    entity indicated by alarmActiveResourceId."
  ::= { alarmNotifications 1 }

 alarmCleared NOTIFICATION-TYPE
-   OBJECTS     { alarmModelIndex,
+   OBJECTS     { alarmModelDescription,
                  alarmActiveResourceId }
    STATUS      current
    DESCRIPTION
-     "An instance of the alarm indicated by alarmModelIndex
-     has been cleared against the entity indicated by
-     alarmActiveResourceType and alarmACtiveResourceId."
-   ::= { alarmNotifications 0 2 }
+     "An instance of the alarm indicated by alarmModelIndex/
+     alarmModelState (found by gleaning the index from
+     alarmModelDescription) has been cleared against
+     the entity indicated by alarmActiveResourceId."
+   ::= { alarmNotifications 2 }

 -- Conformance

@@ -872,8 +856,6 @@
 alarmModelGroup OBJECT-GROUP
    OBJECTS {
        alarmModelLastChanged,
-       alarmModelIndex,
-       alarmModelState,
        alarmModelNotificationId,
        alarmModelVarbindIndex,
        alarmModelVarbindValue,
@@ -923,7 +905,7 @@
           OBJECTS  {
                    alarmActiveStatsTotalActive,
                    alarmActiveStatsCurrentActive,
-                   alarmActiveStatsLastRaise,
+                   alarmActiveStatsLastSet,
                    alarmActiveStatsLastClear
                     }
           STATUS   current