Subject: schedule mib question: schedLocalTime

From: Wes Hardaker <[email-masked]>
Date: Thu, 14 Mar 2002 18:59:10 -0800

Can someone explain the difference between
DISMAN-SCHEDULE-MIB::schedLocalTime and
HOST-RESOURCES-MIB::hrSystemDate ?

IE, if there is no difference there probably shouldn't be a duplicated
object within the schedule MIB?

-- 
Wes Hardaker
NAI Labs
Network Associates

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 18 Mar 2002 11:39:30 -0800 (PST)

Hi -

> To: [email-masked]
> Subject: schedule mib question: schedLocalTime
> From: Wes Hardaker <[email-masked]>
> Date: Thu, 14 Mar 2002 18:59:10 -0800
> Message-ID: <[email-masked]>
...
> object within the schedule MIB?
...

The difference is that HOST-RESOURCES-MIB.hrSystemDate
fails to require that the time zone offset be returned, and
DISMAN-SCHEDULE-MIB.schedLocalTime is explicitly constrained
to include the time zone offset.  Being able to determine
the time zone offset is essential to many applications of
the schedule MIB.

I suppose a devil's advocate might argue that this could be
reconstructed by the management system calculating the offset
between its own time and hrSystem date. 

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------