Subject: RE: Ping MIB Issue?

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 26 Mar 2002 23:10:58 +0100

The WG can report an error to be put on the errata page at
the RFC-Editor website. We have more of those errata
reported already. Would be good to propose an acceptable
piece of text to be posted.

Bert 

> -----Original Message-----
> From: Steve Moulton [mailto:[email-masked]]
> Sent: Tuesday, March 26, 2002 4:39 PM
> To: [email-masked]
> Subject: Re: Ping MIB Issue? 
> 
> 
> 
> Sharon,
> 
> I spoke to the programmer who is responsible for our 
> implementation, and his comment was "looks like a typo to me".
> This should probably be attended to as part of the edits when
> we look at promoting this document. 
> 
> To the working group in general:
> 
> Are we close to considering the
> 
> Definitions of Managed Objects for Remote Ping, Traceroute, and
>                            Lookup Operations
> 
> document for draft status?  We're shipping lookup and pieces of
> ping as product, and are implementing traceroute.
> 
> 	- Steve
> 
> 
> 
> On Tuesday, March 26 2002, "Sharon Chisholm" 
> <[email-masked]> wrot
> e:
> 
> > hi
> > 
> > I did a quick search of the archives, and I did not see this
> > discussed.
> > 
> > I've just received a question on the ping MIB that makes
> > me think there is either a typo in the MIB or an 
> > explanation is missing. testCompletion is (2) in
> > pingCtlTrapGeneration, but the text of pingTestCompleted 
> > describes a value of (4):
> > 
> >   pingCtlTrapGeneration OBJECT-TYPE
> >     SYNTAX      BITS {
> >                    probeFailure(0),
> >                    testFailure(1),
> >                    testCompletion(2)
> >                   }
> >     MAX-ACCESS  read-create
> >     STATUS      current
> >     DESCRIPTION
> >         "The value of this object determines when and if
> >         to generate a notification for this entry:
> > 
> >         probeFailure(0)   - Generate a pingProbeFailed
> >             notification subject to the value of
> >             pingCtlTrapProbeFailureFilter.  The object
> >             pingCtlTrapProbeFailureFilter can be used
> >             to specify the number of successive probe failures
> >             that are required before a pingProbeFailed
> >             notification can be generated.
> >         testFailure(1)    - Generate a pingTestFailed
> >             notification. In this instance the object
> >             pingCtlTrapTestFailureFilter can be used to
> >             determine the number of probe failures that
> >             signal when a test fails.
> >         testCompletion(2) - Generate a pingTestCompleted
> >             notification.
> > 
> >         The value of this object defaults to zero, indicating
> >         that none of the above options have been selected."
> >     ::= { pingCtlEntry 13 }
> > 
> >   ...
> > 
> >   pingTestCompleted NOTIFICATION-TYPE
> >       OBJECTS {
> >         pingCtlTargetAddressType,
> >         pingCtlTargetAddress,
> >         pingResultsOperStatus,
> >         pingResultsIpTargetAddressType,
> >         pingResultsIpTargetAddress,
> >         pingResultsMinRtt,
> >         pingResultsMaxRtt,
> >         pingResultsAverageRtt,
> >         pingResultsProbeResponses,
> >         pingResultsSentProbes,
> >         pingResultsRttSumOfSquares,
> >         pingResultsLastGoodProbe
> >       }
> >       STATUS  current
> >       DESCRIPTION
> >           "Generated at the completion of a ping test when the
> >           corresponding pingCtlTrapGeneration object is set to
> >           testCompletion(4)."
> >       ::= { pingNotifications 3 }
> > 
> > 
> > Sharon
> 
> ---
> Steve Moulton        SNMP Research, Inc            voice: +1 
> 865 573 1434
> Sr Software Engineer 3001 Kimberlin Heights Rd.    fax: +1 
> 865 573 9197
> [email-masked]     Knoxville, TN 37920-9716 USA  http://www.snmp.com
> 
>

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 26 Mar 2002 23:56:09 +0100

> Does anyone object to this:
> 
> RFC 2925, "Definitions of Managed Objects for Remote Ping, 
> Traceroute, and
> Lookup Operations", September 2000.
> 
> On page 32, there is a typo in the DESCRIPTION of pingTestCompleted.
> 
> Should be:
>           testCompletion(2)."
Sounds good to me

Bert

---

From: "Kenneth White" <[email-masked]>
Date: Tue, 26 Mar 2002 18:12:51 -0500

>           corresponding pingCtlTrapGeneration object is set to
I also agree.

Ken