Subject: Re: Expression MIB questions

From: Randy Presuhn <[email-masked]>
Date: Tue, 21 May 2002 11:15:33 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> From: "Rui Lopes" <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: Expression MIB questions
> Date: Tue, 14 May 2002 09:39:26 GMT
> List-Id: IETF disman Working Group mailing list <disman.dorothy.bmc.com>
> 
> 
> Hi. I hope I am not asking trivial questions but after reading carefuly the
> RFC I still cannot understand some small details... 
> 
> In the functions sum(*) and exists(*), the parameter is supposed to be an
> OID, a variable ($x) or other type of object? 

See the DESCRIPTION of expExpression for details.  The parameter will
be an OID, expressed in dotted-decimal or $N notation.  Do you have
any suggestions for improving the text?

> The statistical functions average, maximum and minimum receive only an
> Integer compatible type by sample? 

The DESCRIPTION of expExpression says:

|    average/maximum/minimum(integer) - calculates the average,
|    minimum, or maximum value of the integer valued object over
|    multiple sample times. 

Could this be made clearer?

>                                    If the expression is Absolute, they
> may also be used? 

I would expect so.  I don't see anything to preclude the possibility.

> Finally, having nothing to do with it, does any one knows if exists some
> RFC with the SNMP URL scheme definition? 
...

Maria Greene posted a proposal to the SNMPv2 mailing list
in March of 1996.  Does anyone know of anything that's been
fleshed out and published?  I've been thinking about using
webdav in conjunction with SNMP in order to provide more
structured configuration management than what snmpconf has
done so far.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: RP <[email-masked]>
Date: Thu, 23 May 2002 11:01:06 +0100

>Could this be made clearer?

Does this mean that the parameter to these functions (average/max/min), 
besides constants and $N,
  can also be an OID in dotted-decimal notation?
If the answer is no, then why is it possible to use OIDs, expressed in 
dotted-decimal notation for
sum() and exists() and not for (a/m/m) functions?

>structured configuration management than what snmpconf has

As far as I know, there are three products and/or projects that use some 
form of SNMP URL.
iosnmp - SNMP URL for SNMPv3 only
cricket - SNMP URL for SNMP v1 and v2c only
and one of my own - v1, v2c, v3.

I also did not find any references to SNMP URLs in conferences, the web, 
journals or magazines.
It is also unregistered in IANA. I think that it is usefull in several 
management situations.
In fact we are currently putting in a paper some of these ideias.

I hope that my opinions are not too naive but it may be more useful to talk 
about them
than to keep them to myself... ;)

Best regards,

Rui Pedro