Subject: RE: Updated Alarm MIB Issues

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 8 May 2002 13:31:26 +0300

I am not sure that I agree with any of you!

Randy, I thought that we agree that we do not mandate the awareness of the UTC. So the MUST refers to the case when UTC is available, and is not defeated by anything in the next phrase which refers at the opposite case.

Francisco, we like using the UTC offset, thus the second phrase. Life being stronger than our stronger desires, this case is possible but NOT RECOMMENDED.

Regards,

Dan

> -----Original Message-----
> From: Dale Francisco [mailto:[email-masked]]
> Sent: Tuesday, May 07, 2002 9:47 PM
> To: Randy Presuhn; [email-masked]
> Subject: RE: Updated Alarm MIB Issues
> 
> 
> Then you should also remove the sentence "Implementation
> in environments in which the UTC offset is not available
> is NOT RECOMMENDED."  Since not only would it be "not
> recommended", it would be "not possible".
> 
> > Regarding #43...
> > >           Implementations MUST include the offset from UTC,
> > >           if available.  Implementation in environments in which
> > >           the UTC offset is not available is NOT RECOMMENDED."
> > ...
> > 
> > Please remove the "if available."
> > It defeats the purpose of the "MUST".
> 
>

---

From: "Dale Francisco" <[email-masked]>
Date: Wed, 8 May 2002 07:06:39 -0700

Dan,

What I intended to do was comment on the logic
of the prose--nothing more.  If you were to remove
the phrase "if available", then logically you should
remove the following sentence as well, since you would
be mandating implementations only where the UTC
offset is available.

If it's the sense of the WG that implementations are
allowed even where the UTC offset isn't available, then
I agree that the paragraph in question should stand exactly
as written.

Best regards,
Dale

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> Sent: Wednesday, May 08, 2002 3:31 AM
> To: [email-masked]; Randy Presuhn; [email-masked]
> Randy, I thought that we agree that we do not mandate the 
> awareness of the UTC. So the MUST refers to the case when UTC is 
> available, and is not defeated by anything in the next phrase 
> which refers at the opposite case.
> 
> Francisco, we like using the UTC offset, thus the second phrase. 
> Life being stronger than our stronger desires, this case is 
> possible but NOT RECOMMENDED.
> 
> Regards,
> 
> Dan