Subject: Re: Expression MIB questions

From: Randy Presuhn <[email-masked]>
Date: Thu, 23 May 2002 12:50:46 -0700 (PDT)

Hi -

> Message-Id: <[email-masked]>
> Date: Thu, 23 May 2002 11:01:06 +0100
> To: Randy Presuhn <[email-masked]>, [email-masked]
> From: RP <[email-masked]>
> Subject: Re:  Expression MIB questions
> Cc: [email-masked], [email-masked]
> In-Reply-To: <[email-masked]>
> 
> At 11:15 21-05-2002 -0700, Randy Presuhn wrote:
> > > In the functions sum(*) and exists(*), the parameter is supposed to be an
> > > OID, a variable ($x) or other type of object?
> >
> >See the DESCRIPTION of expExpression for details.  The parameter will
> >be an OID, expressed in dotted-decimal or $N notation.  Do you have
> >any suggestions for improving the text?
> >
> > > The statistical functions average, maximum and minimum receive only an
> > > Integer compatible type by sample?
> >
> >The DESCRIPTION of expExpression says:
> >
> >|    average/maximum/minimum(integer) - calculates the average,
> >|    minimum, or maximum value of the integer valued object over
> >|    multiple sample times.
> >
> >Could this be made clearer?
> 
> Does this mean that the parameter to these functions (average/max/min), 
> besides constants and $N,
>   can also be an OID in dotted-decimal notation?

Of course.  Why not?  The $N notation is an extension of the dotted-
decimal form.

> If the answer is no, then why is it possible to use OIDs, expressed in 
> dotted-decimal notation for
> sum() and exists() and not for (a/m/m) functions?
...

What led you to think that these would be different?

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

---

From: RP <[email-masked]>
Date: Fri, 24 May 2002 11:00:43 +0100

>Of course.  Why not?  The $N notation is an extension of the dotted-
Dear Randy,
Thank you for your support and helpful comments on my "not so well 
described" questions. You confirm my suspicious about this.
In fact the main reason for the questions is that we are exploring the 
possibility of using remote objects in expObjectTable ....
This way an expression can be a powerful tool over distributed objects.

Best regards,

Rui Pedro Lopes