Subject: RE: [Disman] traceRouteCtlMiscOptions

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Tue, 19 Jul 2005 22:06:23 +0300

I would argue that this object should be deprecated anyway. I do not
understand what kind of interoperability this object can provide.
Regards, Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Juergen Quittek
> Sent: Monday, July 18, 2005 8:52 PM
> To: [email-masked]
> Subject: [Disman] traceRouteCtlMiscOptions
> 
> Dear all,
> 
> The traceRouteCtlMiscOptions in the DISMAN-TRACEROUTE-MIB is 
> defined as follows:
> 
>  traceRouteCtlMiscOptions OBJECT-TYPE
>     SYNTAX      SnmpAdminString
>     MAX-ACCESS  read-create
>     STATUS      current
>     DESCRIPTION
>         "Enables an application to specify implementation
>         dependent options."
>     DEFVAL { ''H }
>     ::= { traceRouteCtlEntry 15 }
> 
> It can serve for passing additional, non-standardized 
> parameters to remote traceroute execution.  The standard does 
> not give a hint what it could be used for.
> 
> The question to the group is:
> 
> Has anyone ever used this object or at least implemented it?
> 
> If not, Juergen S. suggest to deprecate or obsolete it:
> 
> --On 5/3/2005 5:15 PM +0200 Juergen Schoenwaelder wrote:
> > - I am wondering what traceRouteCtlMiscOptions is good for 
> other than
> >   proprietary extensions which IMHO should go into table 
> augmentations.
> >   Otherwise, we could put opaque options in almost all 
> tables. I suggest
> >   to document how this object is actually used by existing 
> implementations
> >   or to deprecate or even obsolete it.
> 
> Thanks,
> 
>     Juergen Q.
> -- 
> Juergen Quittek        [email-masked]       Tel: +49 
> 6221 90511-15
> NEC Europe Ltd.,       Network Laboratories        Fax: +49 
> 6221 90511-55
> Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   
> http://www.netlab.nec.de
> 
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 26 Jul 2005 18:03:14 -0700

Hi -

> From: "Romascanu, Dan (Dan)" <[email-masked]>
> To: "Juergen Quittek" <[email-masked]>; <[email-masked]>
> Sent: Tuesday, July 19, 2005 12:06 PM
> Subject: RE: [Disman] traceRouteCtlMiscOptions
>
...

Not much, but more than having each vendor use their own object for
any miscellaneous options.  I'd still like to hear from implementors
to find out if this object is actually used, and, if so, what it is used for.

If no one actually needs it, then I'd most happily support deprecating it.
If it is used, then I'd like to know more before deciding what to do
with it.

Randy