Subject: [Disman] Last Call: 'Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup Operations' to Proposed Standard

From: The IESG <[email-masked]>
Date: Thu, 23 Feb 2006 15:21:13 -0500

The IESG has received a request from the Distributed Management WG to consider the following document:

- 'Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup 
   Operations '
   <draft-ietf-disman-remops-mib-v2-09.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send any comments to the
[email-masked] or [email-masked] mailing lists by 2006-03-09.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-disman-remops-mib-v2-09.txt

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 28 Feb 2006 13:16:02 -0800

Hi -

If the document gives a false impression that the values of
traceRouteHopsHopIndex could be interpreted as hop numbers,
an editorial change to dispel that notion would make sense.
(Likewise, if "consecutive integers starting at one" was the intent, and
is what current implementations actually do, then we should say so.)

I can see how the last two sentences of the last paragraph of
the DESCRIPTION might lead to such a reading.  Does
someone have some replacement text they'd like to propose
to make things clearer?

Randy, disman chair

----- Original Message ----- 
From: "Bill Fenner" <[email-masked]>
To: <[email-masked]>; "Tom.Petch" <[email-masked]>; "Bill Strahm" <[email-masked]>; "iesg" <[email-masked]>;
"ietf" <[email-masked]>
Sent: Monday, February 27, 2006 10:48 PM
Subject: Re: Last Call: 'Definitions of Managed Objects for Remote Ping,Traceroute, and Lookup Operations' to Proposed Standard

Juergen,

  I assumed, from reading in traceRouteHopsHopIndex about the behavior
when a path changes, that the only safe thing for a manager to do is
to read the hops from the table and render them to the user in order
of increasing traceRouteHopsHopIndex but without necessarily showing
the traceRouteHopsHopIndex to the user -- that it was perfectly
reasonable for hops 1,2,3,4 of a 4-hop path to be numbered 1,8,12,35
(assuming that they started 1,2,3,4 but there were lots of path
changes during the test).

  I think some people are assuming that the intention was that the
values should be 1,2,3,4 (i.e., HopIndex == hop number) and that's why
they're asking for a different definition.  Perhaps the right
direction could be to clarify that there is no connection between the
value of HopIndex and traceroute hop, other than the ordering.

  Bill

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf