Subject: [Disman] I-D ACTION:draft-ietf-disman-remops-mib-v2-09.txt

From: [email-masked]
Date: Wed, 22 Feb 2006 15:50:01 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Distributed Management Working Group of the IETF.

	Title		: Definitions of Managed Objects for Remote Ping, Traceroute, and Lookup Operations
	Author(s)	: J. Quittek, K. White
	Filename	: draft-ietf-disman-remops-mib-v2-09.txt
	Pages		: 97
	Date		: 2006-2-22
	
This memo defines Management Information Bases (MIBs) for performing
ping, traceroute and lookup operations at a host.  When managing a
network it is useful to be able to initiate and retrieve the results
of ping or traceroute operations when performed at a remote host.  A
Lookup capability is defined in order to enable resolution of either
an IP address to an DNS name or a DNS name to an IP address at a
remote host.

Currently, there are several enterprise-specific MIBs for performing
remote ping or traceroute operations.  The purpose of this memo is to
define a standards-based solution to enable interoperability.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-disman-remops-mib-v2-09.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-disman-remops-mib-v2-09.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-disman-remops-mib-v2-09.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Kumar, Rajesh" <[email-masked]>
Date: Fri, 24 Feb 2006 08:06:35 -0800

Dear Juergen,
It does answer my question. You might want to add this clarifying text
in the document.

Thanks for the quick response.

Rajesh 

> -----Original Message-----
> From: Juergen Quittek [mailto:[email-masked]] 
> Sent: Friday, February 24, 2006 8:03 AM
> To: Kumar, Rajesh; [email-masked]; Randy Presuhn; Bert 
> Wijnen; David Kessens
> Cc: Jon Heaton; Jim Whitten; Azita Kia (akia); Biskner, 
> Robert; Mostafa, Mohamed; Liu , Jenny; Michael Hammer 
> (mhammer); Randy Ethier (rethier); Dinesh Goyal (digoyal); 
> Sachin Saswade; Wing, Dan; Lantz, Keith; [email-masked]
> Subject: RE: I-D ACTION:draft-ietf-disman-remops-mib-v2-09.txt 
> 
> Dear Rajesh,
> 
> Thanks for the comment.
> 
> --On 2/23/06 4:10 PM -0800 Kumar, Rajesh wrote:
> >
> > Kenneth and Juergen,
> >
> > Congratulatons on your internet draft on reporting ping/traceroute 
> > results being in last call.
> >
> > Basically, it is a good draft. I  do have one concern. When 
> you do a 
> > UDP or ICMP traceroute from any node, yoy typically get three delay 
> > approximations for each stimulus-response with increasing TTLs. 
> > Granted that this is an approximation, I did not see a 
> mechanism for 
> > reporting this inforation in your internet draft. Maybe I missed it 
> > and it is there?
> 
> It is indeed important to store and make available all these 
> measured values.
> 
> The DISMAN-TRACEROUTE-MIB contains the information you are 
> looking for in the traceRouteProbeHistoryTable.
> 
> For clarifying terminology: In the draft a traceroute test 
> includes sending several probes with different hopCount (TTL) values.
> 
> Table traceRouteProbeHistoryTable contains one entry per probe.
> Entries are indexed (among other indices) by
>              traceRouteProbeHistoryHopIndex,
>              traceRouteProbeHistoryProbeIndex.
> 
> Now, if you configure the MIB module to perform three 
> traceroute probes per hop that deliver three delay 
> approximations, then this table will contain three entries 
> with the same value for traceRouteProbeHistoryHopIndex but 
> with different values for traceRouteProbeHistoryProbeIndex.  
> Each of these entries will contain one of the delay approximations.
> 
> Does this answers your question?
> 
> Thanks,
> 
>     Juergen
> -- 
> Juergen Quittek        [email-masked]       Tel: +49 
> 6221 90511-15
> NEC Europe Ltd.,       Network Laboratories        Fax: +49 
> 6221 90511-55
> Kurfuersten-Anlage 36, 69115 Heidelberg, Germany   
> http://www.netlab.nec.de
> 
> >
> > Best regards,
> >
> > Rajesh Kumar
> >
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]]
> >> Sent: Wednesday, February 22, 2006 3:50 PM
> >> To: [email-masked]
> >> Cc: [email-masked]
> >> Subject: I-D ACTION:draft-ietf-disman-remops-mib-v2-09.txt
> >>
> >> This draft is a work item of the Distributed Management 
> Working Group 
> >> of the IETF.
> >>
> >> ping, traceroute and lookup operations at a host.
> >> When managing a network it is useful to be able to initiate and 
> >> retrieve the results of ping or traceroute operations when 
> performed 
> >> at a remote host.  A Lookup capability is defined in order 
> to enable 
> >> resolution of either an IP address to an DNS name or a DNS 
> name to an 
> >> IP address at a remote host.
> >>
> >> http://www.ietf.org/internet-drafts/draft-ietf-disman-remops-m
> >> ib-v2-09.t
> >> xt
> >>
> >> [email-masked] with the word unsubscribe in 
> the body 
> >> of the message.
> >> You can also visit 
> >> https://www1.ietf.org/mailman/listinfo/I-D-announce
> >> Internet-Drafts are also available by anonymous FTP. Login 
> with the 
> >> username "anonymous" and a password of your e-mail address. After 
> >> logging in, type "cd internet-drafts" and then
> >> http://www.ietf.org/shadow.html or 
> >> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >>
> >>