Subject: [dmarc-ietf] Implementing psddmarc

From: Alessandro Vesely <[email-masked]>
Date: Tue, 24 Sep 2019 16:16:08 +0200

Hi all,
I added psddmarc to the latest zdkimfilter.

After some thought, I chose to use and distribute a file like the one attached.  Two reasons for doing so are as follows:

1. Avoid to invent yet another file format, specifying header line, initial dot, comments, and the like.

2. Reuse the library calls already available for parsing and searching the PSL.

On the second call, the software passes the organizational domain resulting from the first call, and thus retrieves the "super organizational" domain, if any.  The file only contains the domain from psddmarc.org registry which actually sports a DMARC record.  While the experiment is ongoing, the file will have to be updated.

It would be convenient, if more implementations will find the above reasons convincing, if such a list would be maintained and distributed by psddmarc.org along with (or instead of) the csv format.  After all, since this list extends the PSL, keeping the same format may make some sense.

Best
Ale
--

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 25 Sep 2019 17:23:04 -0400

On Tuesday, September 24, 2019 10:16:08 AM EDT Alessandro Vesely wrote:
> After some thought, I chose to use and distribute a file like the one
> attached.  Two reasons for doing so are as follows:
> 
> On the second call, the software passes the organizational domain resulting
> from the first call, and thus retrieves the "super organizational" domain,
> if any.  The file only contains the domain from psddmarc.org registry which
> actually sports a DMARC record.  While the experiment is ongoing, the file
> will have to be updated.
> 
> It would be convenient, if more implementations will find the above reasons
> convincing, if such a list would be maintained and distributed by
> psddmarc.org along with (or instead of) the csv format.  After all, since
> this list extends the PSL, keeping the same format may make some sense.

I think we should include this in the options for the experiment about how to 
keep track of which PSDs are doing PSD DMARC.

Can you provide what you'd like me to add about your implementation for 
Appendix C?

Scott K

---

From: Alessandro Vesely <[email-masked]>
Date: Fri, 27 Sep 2019 13:19:59 +0200

> Can you provide what you'd like me to add about your implementation for 

If needed, a short characterization can be as follows:

    The zdkimfilter module is a separately available add-on to
    Courier-MTA.

    Mostly used for DKIM signing, it can be configured to also
    verify, apply DMARC policies, and send aggregate reports.

Best
Ale
--