Subject: [dmarc-ietf] understanding section 7.2

From: Michael Thomas <[email-masked]>
Date: Tue, 26 Jan 2021 11:04:19 -0800

So I'm an outsider who has not tried to digest what's going on in the 
reports until recently so my eyes are fresh. Basically section 7.2 is 
extremely hard to understand what is in the reports. I know that the XML 
is what ought to be normative, but a little bit of ascii art could go a 
long way to helping people understand what the reports do and don't 
have. I've been staring at the XML all morning trying to understand it 
and it is very difficult when all you're trying to do is figure out what 
the reports supply or not. It would be extremely helpful to layout what 
is in each record for human consumption to just understand what the 
reports do and don't contain.

Mike

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 27 Jan 2021 12:14:14 -0800

The schema's already pretty large, and probably has to be, but maybe a
trivial example report would be reasonable to craft and include?

On Tue, Jan 26, 2021 at 11:05 AM Michael Thomas <[email-masked]> wrote:

> _______________________________________________
> dmarc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmarc
>

---

From: Michael Thomas <[email-masked]>
Date: Wed, 27 Jan 2021 12:18:50 -0800

> trivial example report would be reasonable to craft and include?

Yeah, that might do too. I think it's important that it be in section 
7.2 though because you should be able to read that section and 
understand what the report is and isn't.

Mike

>
> On Tue, Jan 26, 2021 at 11:05 AM Michael Thomas <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/dmarc>
>

---

From: "Brotman, Alex" <[email-masked]>
Date: Wed, 27 Jan 2021 20:40:43 +0000

Murray,

That is on my to-do (though not ticketed).  I’m not quite sure how elaborate the example should be, but at least enough to demonstrate a basic report.

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

From: dmarc <[email-masked]> On Behalf Of Murray S. Kucherawy
Sent: Wednesday, January 27, 2021 3:14 PM
To: Michael Thomas <[email-masked]>
Cc: [email-masked]
Subject: Re: [dmarc-ietf] understanding section 7.2

The schema's already pretty large, and probably has to be, but maybe a trivial example report would be reasonable to craft and include?

On Tue, Jan 26, 2021 at 11:05 AM Michael Thomas <[email-masked]<mailto:[email-masked]>> wrote:

Mike

_______________________________________________
dmarc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dmarc<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/dmarc__;!!CQl3mcHX2A!XHBRnmNygN4XJF4RJeXG6QsEmD5hqthDOCL9GnTgTRWbiOF1XJHzfjeZUVLUatVMWOxh$>

---

From: Michael Thomas <[email-masked]>
Date: Wed, 27 Jan 2021 12:42:33 -0800

On 1/27/21 12:40 PM, Brotman, Alex wrote:
>
> Murray,
>
> That is on my to-do (though not ticketed). I’m not quite sure how 
> elaborate the example should be, but at least enough to demonstrate a 
> basic report.
>
I opened a ticket on this yesterday. I think it's 102.

Mike

> *From:* dmarc <[email-masked]> *On Behalf Of * Murray S. Kucherawy
> *Sent:* Wednesday, January 27, 2021 3:14 PM
> *To:* Michael Thomas <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [dmarc-ietf] understanding section 7.2
>
>     <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/dmarc__;!!CQl3mcHX2A!XHBRnmNygN4XJF4RJeXG6QsEmD5hqthDOCL9GnTgTRWbiOF1XJHzfjeZUVLUatVMWOxh$>
>
>

---

From: Alessandro Vesely <[email-masked]>
Date: Thu, 28 Jan 2021 13:24:12 +0100

On Wed 27/Jan/2021 21:18:50 +0100 Michael Thomas wrote:
> Yeah, that might do too.

+1.  It can be produced starting from a real report and replacing IPs and 
domain names with exemplifying ones.

> I think it's important that it be in section 7.2 though because you should
> be able to read that section and understand what the report is and isn't.

The full report should go in an appendix, because it is too long to make sense 
in the middle of text.  Section 7.2 may show the corresponding tabular form[*], 
which provides for a visual summary of fields, and reference the appendix.

Best
Ale
-- 

[*] A tabular form is showed here:
https://en.wikipedia.org/wiki/DMARC#Aggregate_reports