Subject: [dmarc-ietf] ABNF update to dmarc-psd

From: Tim Wicinski <[email-masked]>
Date: Mon, 7 Jun 2021 18:10:16 -0400

All

When I raised the point for dmarc-bis making sure that new tags define
their ABNF, I realized that the PSD document does no such thing.
It does describe the definition, as it's the same as the "sp" tag.

I added the following section to dmarc-psd updating 7489 as such:

3.3.  Changes in Section 6.4 "Formal Definition"

   The ABNF for DMARC shall updated to include a new definition "dmarc-
   nprequest" which is defined as:

               dmarc-nprequest =  "np" *WSP "=" *WSP
                   ( "none" / "quarantine" / "reject" )

   The "dmarc-record" definition is also updated to include the
   following:

                 [dmarc-sep dmarc-nprequest]

I am well aware that the dmarc-bis draft has much cleaner ABNF, but this
document still updates 7489, so
we must follow what is there.

I've pushed a new version -15 into my own repo:
https://github.com/moonshiner/draft-ietf-dmarc-psd

I'd like the WG to double check what is here, making sure this will be
enough.  I'll push out -15 by the
end of the week.

thanks
tim

---

From: Dave Crocker <[email-masked]>
Date: Mon, 7 Jun 2021 15:26:17 -0700

>          ( "none" / "quarantine" / "reject" )

I suggest adding a comment that makes the linkage of 'nprequest' to the 
prose text explicit.

d/

-- 
Dave Crocker
[email-masked]
408.329.0791

Volunteer, Silicon Valley Chapter
Information & Planning Coordinator
American Red Cross
[email-masked]

---

From: Tim Wicinski <[email-masked]>
Date: Tue, 8 Jun 2021 09:53:49 -0400

Dave,

I agree but was scrabbling with the wording. How about

which will go in the next to last line of the definition, as so:

[dmarc-sep dmarc-percent]

[dmarc-sep]

My first instinct is some sort of diff type output, but that isn't right.

tim

On Mon, Jun 7, 2021 at 6:26 PM Dave Crocker <[email-masked]> wrote:

> Dave [email-masked]
> 408.329.0791
>
> American Red [email-masked]
>
>