Subject: [dmm] this is a test

From: "MELIA, TELEMACO (TELEMACO)" <[email-masked]>
Date: Tue, 17 Aug 2010 11:06:42 +0200

Please ignore

telemaco

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 17 Aug 2010 13:20:35 -0700

Hello folks,

I've got problems with HMIP.  I think in the context
of DMM, we should consider a new design for Hierarchical
Mobile IP.  One major problem is that there's only one
level of hierarchy. Experience with LTE and EVDO network
designs already shows this is wrong.

I co-authored drafts for both IPv4 and IPv6 with the
necessary multi-level protocol specification.  Due
to political wrangling, that text did not survive,
and the IPv6 document was replaced by what has now
become HMIPv6.

Would anyone on this mailing list support a new effort
for such a multi-level hierarchy for Mobile IP?

It also seems to me that some levels of the hierarchy
should be able to use a proxy-based design -- something
perhaps using elements of PMIP.  This should be done
smoothly so we do not experience the ambiguities which
have been under discussion in the netlmm/netext working
groups.

Regards,
Charlie P.

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 17 Aug 2010 14:13:44 -0700

Hi Charlie:

The chaining models based on client-based mobility alone will not carry
too much value. Given the industry direction towards non-client centric
models, HMIP faces the same issue. Nothing wrong with the protocol, it's
the lack of alignment with network-based mobility models that's the
reason for lack of adoption.

The chaining models completely based on network-based approach, or the
mix of client-centric and network-centric surely will have some value.
We did try to cover some of these cases in RFC-5213, but we had to take
that out from the spec for scoping reasons. Some of this work got moved
into Gerardo's consolidated spec from many drafts:

http://www.ietf.org/id/draft-ietf-netlmm-mip-interactions-06.txt

If you have some proposal, it will be good to know the chaining
approaches that you have in mind. To your specific question, surely it
makes sense to solve few issues in this space, but not sure if we have a
clear picture on the problem set.

Regards
Sri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Charles E. Perkins
Sent: Tuesday, August 17, 2010 1:21 PM
To: [email-masked]
Subject: [dmm] Hierarchical Mobile IP [proxy or otherwise]

Hello folks,

Regards,
Charlie P.

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 17 Aug 2010 14:36:10 -0700

Hi,

> reason for lack of adoption.

=> IMHO, network based mobility alone falls also in the same category than 
client-based mobility alone (and PMIP is one proof!).

> mix of client-centric and network-centric surely will have some value.

=> IMHO, it is the second model (i.e., mix) which would be better positioned to 
answer future requirements.

Regards,

Wassim H.

Regards,

Wassim H.

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 17 Aug 2010 14:53:09 -0700

> reason for lack of adoption.

=> IMHO, network based mobility alone falls also in the same category
than 
client-based mobility alone (and PMIP is one proof!).

[Sri] Ok. Fair enough, given the GTP dominance.

> mix of client-centric and network-centric surely will have some value.

=> IMHO, it is the second model (i.e., mix) which would be better
positioned to 
answer future requirements.

Regards,

Wassim H.

Regards,

Wassim H.

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 17 Aug 2010 14:59:13 -0700

One additional comment.

But, honestly I do not see any development which suggests we are going
to see a client stack insertion in every mobile or fixed terminal. 

Not to take the discussion thread in a new direction, but this should be
a key consideration in the chaining models.

Sri

---

From: liu dapeng <[email-masked]>
Date: Thu, 19 Aug 2010 11:38:09 +0800

Hi Charlie:

> designs already shows this is wrong.
==>
May I ask a clarification question?
Why LTE and EVDO network designs shows that is wrong of one level of hierachy?

Regards,
Dapeng Liu

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 19 Aug 2010 17:02:50 -0700

Hello Liu,

Suppose there is a home agent somewhere in the
Internet.  Its link to the LTE P-GW would treat
the P-GW's address as the CoA.

The P-GW itself should have a home agent.  This
home agent "could" be used for tunnel management
within LTE, retargeting the S5 GTP tunnel to
whichever S-GW currently serves the mobile device.

Furthermore, it would be sensible to use the
same protocol for S-GW re-tunneling to eNodeB.

Each of these "could" be either Client MIPv6
or Proxy MIPv6.  The exact security arrangements
are a matter of some interest, but all signaling
with the UE "should" depend on the UE's security
association with its home agent.

This is so far distant from the actual design
of LTE that I have a hard time explaining it
even to myself, but so far it seems to make
a great deal more engineering sense than the
hodge-podge of signaling and IEs that constitute
the heavy-weight and confusing signaling as it
is current specified by 3GPP.  In fact, I do
not think there are very many people who really
understand it.  Constrast this with the quite
simple matter of understanding a Mobile-IP
based design.

The same considerations hold for EVDO, although
each component has different names and functions.
One begins to wonder whether it was a matter of
honor and principle for the 3GPP and 3GPP2 protocol
architects to select incompatible names and
functions for achieving the same goals.

Regards,
Charlie P.

On 8/18/2010 8:38 PM, liu dapeng wrote:
> Hi Charlie:
>
> 2010/8/18, Charles E. Perkins<[email-masked]>:
>>
>> Hello folks,
>>

---

From: liu dapeng <[email-masked]>
Date: Fri, 20 Aug 2010 10:57:56 +0800

Hi Charlie ,

Thanks for the detailed explanation, pls see comments inline.

> whichever S-GW currently serves the mobile device.
==>
In my understanding, normally, the UE's handover will only happen
within a P-GW/HA domain. i.e. there is no inter-P-GW handover. If that
is the case, is there any problem when an Internet HA connect to a LTE
P-GW? The Internet HA may just consider the LTE UE as a static CN.

Best Regards,
Dapeng