Subject: [dmm] DMM problem statement

From: liu dapeng <[email-masked]>
Date: Wed, 8 Sep 2010 01:33:51 +0800

Hi all,

Base on some offline discussion, we have the following PS key points,
any comments are welcomed and appreciated.

Problem statement:

Existing mobile networks are hierarchical. Existing mobility solutions
deployed with centralized mobility anchoring have the following
problems or limitations:
(1) Routing via a centralized anchor leads to non-optimized routes.
(2) Routes are set up for a large number of mobile hosts even though
the majority are not moving : scalability and performance.
(3) Mobility contexts are maintained irrespective of whether the host
will actually move: wasted resources to maintain mobility contexts for
motionless hosts. In addition, maintaining mobility contexts in a
central entity has scalability issue.
(4) Single point of failure in the centralized architecture
(5) As the volume of wireless data traffic continues to increase
exponentially, the revenue growth is falling far behind. Hierarchical
architecture is more costly than the more flattened network, so that
mobility management deployment with distributed architecture is
needed.

Work items: (We will need to further elaborate the work items.)

•  Give best current practices of deploying current mobility protocols
in flat architecture. Describe how mobility functions of current
protocols could could be distributed. The goal is not to modify
MIP/PMIP but to consider a particular deployment.

•  Document performances limitations of above approaches and propose
modification/extension of current mobility protocol for flat
architecture e.g. Inter-LMA/HA handover enhancement, Direct MN-MN
communication (simplified routing optimization) etc.

Regards,
Dapeng Liu

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 07 Sep 2010 15:33:04 -0700

Hello folks,

Here are some other points that I would
like to see included:

- Integration of HMIP/PMIP/FMIP/MIP into one
   coherent architecture.  For instance, if we
   have a multilevel routing hierarchy, the
   specific technique(s) used at one level
   should not prevent other techniques to be
   used at other levels.

- Key distribution for mobiles as they move
   from one point to another in the DMM.
   If one mobility agent caches a security
   association for a MN, and the MN moves to
   a new location, the SA might well migrate
   to the new mobility agent.

- Particular attention to FMIP versus existing
   techniques for pre-registration/authentication

- Hetergeneous radio-access technologies

Regards,
Charlie P.

On 9/7/2010 10:33 AM, liu dapeng wrote:
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

---

From: "Heeyoung JUNG" <[email-masked]>
Date: Wed, 8 Sep 2010 10:04:47 +0900

Hello Dapeng,

I have a question just for clarification.
What we are talking about is MM for IP based mobile networks (like 3GPP SAE)
or whole Internet scale MM?
My understanding based on your I-D and BoF presentation materials is the
former.
If my understanding isn't right, please correct it.

BRs,

Heeyoung JUNG

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of liu
> dapeng
> Sent: Wednesday, September 08, 2010 2:34 AM
> To: dmm
> Subject: [dmm] DMM problem statement
> 
> 
> Hi all,
> 
> Base on some offline discussion, we have the following PS key points, any
> comments are welcomed and appreciated.
> 
> Problem statement:
> 
deployed
> with centralized mobility anchoring have the following problems or
limitations:
> (2) Routes are set up for a large number of mobile hosts even though the
> majority are not moving : scalability and performance.
> (3) Mobility contexts are maintained irrespective of whether the host will
actually
> move: wasted resources to maintain mobility contexts for motionless hosts.
In
> addition, maintaining mobility contexts in a central entity has
scalability issue.
> (5) As the volume of wireless data traffic continues to increase
exponentially, the
> revenue growth is falling far behind. Hierarchical architecture is more
costly than
> the more flattened network, so that mobility management deployment with
> distributed architecture is needed.
> 
> .  Give best current practices of deploying current mobility protocols in
flat
> architecture. Describe how mobility functions of current protocols could
could be
> distributed. The goal is not to modify MIP/PMIP but to consider a
particular
> deployment.
> 
> .  Document performances limitations of above approaches and propose
> modification/extension of current mobility protocol for flat architecture
e.g. Inter-
> LMA/HA handover enhancement, Direct MN-MN communication (simplified
> routing optimization) etc.
> 
> 
> Regards,
> Dapeng Liu

---

From: Anthony Chan <[email-masked]>
Date: Wed, 08 Sep 2010 17:07:47 -0500

Heeyoung,

I understand that it is good to clarify whether DMM is used in mobile
network only because most of the current MM deployment is probably in the
mobile network. Yet I don't know whether we want to distinguish DMM this
way. MM is obviously for mobile hosts only and not for fixed hosts, and
mobile hosts are obviously connected to wireless access networks. Yet the
mobile hosts can move to any wireless access network, which connects to the
Internet. (if this is what you mean by Internet scale MM)

A different view may be in the introductory sentence in the proposed problem
statement for discussion:
"Existing mobile networks are hierarchical. Existing mobility solutions
deployed with centralized mobility anchoring have the following problems or
limitations:"

The distinction for mobility management may be centralized versus
distributed. 

The distinction for network may be hierarchical versus flattened. 

I think these are separate distinctions. 

Existing mobile networks (3GPP) are hierarchical, and existing mobility
management solutions are centralized. Yet it is not necessarily true that
the mobility management for the hierarchical network must be centralized. In
addition the trend for future mobile network is to be more flattened and to
merge with the Internet. So the distinction of mm based on the network may
not hold in future. 

H Anthony Chan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Heeyoung JUNG
Sent: Tuesday, September 07, 2010 8:05 PM
To: 'liu dapeng'
Cc: 'dmm'
Subject: Re: [dmm] DMM problem statement

Hello Dapeng,

BRs,

Heeyoung JUNG

deployed
actually
In
scalability issue.
exponentially, the
costly than
flat
could be
particular
e.g. Inter-

---

From: "Seok Joo Koh" <[email-masked]>
Date: Thu, 9 Sep 2010 08:38:34 +0900

Dear Anthony,

Does DMM focus on the current MM protocols, such as MIP/PMIP/HMIP, and their extensions ?
Or, can we consider a new MM protocol to support the hierarchical DMM ?

Regards,

*************************
Seok Joo Koh
[email-masked]
http://protocol.knu.ac.kr/

---

From: "Heeyoung JUNG" <[email-masked]>
Date: Thu, 9 Sep 2010 09:50:40 +0900

Anthony,
I see your point.
Thanks for your kind explanation.

BRs,

Heeyoung JUNG

> From: Anthony Chan [mailto:[email-masked]]
> Sent: Thursday, September 09, 2010 7:08 AM
> To: [email-masked]; 'liu dapeng'
> Cc: 'dmm'
> Subject: RE: [dmm] DMM problem statement
> 
> 
> Heeyoung,
> 
network
> only because most of the current MM deployment is probably in the mobile
> network. Yet I don't know whether we want to distinguish DMM this way. MM
is
> obviously for mobile hosts only and not for fixed hosts, and mobile hosts
are
> obviously connected to wireless access networks. Yet the mobile hosts can
move
> to any wireless access network, which connects to the Internet. (if this
is what
> you mean by Internet scale MM)
> 
deployed
limitations:"
distributed.
> management solutions are centralized. Yet it is not necessarily true that
the
> mobility management for the hierarchical network must be centralized. In
not
> hold in future.
former.
> > liu dapeng
> > will
> > the more flattened network, so that mobility management deployment
> > with distributed architecture is needed.
> >
> > architecture

---

From: Anthony Chan <[email-masked]>
Date: Thu, 09 Sep 2010 18:53:08 -0500

Dear Seok,
I think your question is regarding the proposed work item for DMM, which is
still in the discussion stage. Please feel free to make suggestions. If
there are good reasons to include certain approach, please bring it up so
that we can draft a strong problem statement to propose a BOF. 

H Anthony Chan

-----Original Message-----
From: Seok Joo Koh [mailto:[email-masked]] 
Sent: Wednesday, September 08, 2010 6:39 PM
To: Anthony Chan; [email-masked]; 'liu dapeng'
Cc: 'dmm'
Subject: Re: [dmm] DMM problem statement

Dear Anthony,

Does DMM focus on the current MM protocols, such as MIP/PMIP/HMIP, and their
extensions ?
Or, can we consider a new MM protocol to support the hierarchical DMM ?

Regards,

----- Original Message ----- 
From: "Anthony Chan" <[email-masked]>
To: <[email-masked]>; "'liu dapeng'" <[email-masked]>
Cc: "'dmm'" <[email-masked]>
Sent: Thursday, September 09, 2010 7:07 AM
Subject: Re: [dmm] DMM problem statement

will

---

From: liu dapeng <[email-masked]>
Date: Fri, 10 Sep 2010 20:36:01 +0800

Hi Charlies,

Please see comments inline.

>    should not prevent other techniques to be

[Dapeng] In the scenario of flat network architecture, there may have
different level of anchor point deployed. In this case, different
level of mobility solutions may be needed to deploy together. So I
personally aggree that this is a valid point. let us discuss the words
how to describe this point as a problem statement.

>    techniques for pre-registration/authentication

[Dapeng] This maybe solution related. At current stage, I personally
suggest that we focus the discussion on defining the problem that we
want to solve.

---

From: liu dapeng <[email-masked]>
Date: Fri, 10 Sep 2010 20:40:02 +0800

Hi Heeyoung,

We are talking about the hole Internet scale MM.

regards,
Dapeng Liu

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Fri, 10 Sep 2010 15:31:41 +0200

Hi, all.

> how to describe this point as a problem statement.

I support the integration of all (possible) mobility management protocols
into one coherent architecture, but the approach allowing different (or
multiple) levels would make the flatten mobility architecture less
meaningful.

> suggest that we focus the discussion on defining the problem that we

The performance gain we could expect by the flatten mobility architecture
mainly depends on the locations of authentication and key management
servers.

Cheers.

-- 
IMARA Team, INRIA, France.
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random.

#email: hurryon (at) gmail (dot) com || jong-hyouk.lee (at) inria (dot) fr
#webpage: https://sites.google.com/site/hurryon/