Subject: Re: [DMM] User Plane Protocol Study in 3GPP

From: Uma Chunduri <[email-masked]>
Date: Wed, 23 May 2018 17:07:46 +0000

Dear All,

For the Dino's question -

> Do you think carriers will build an IPv6-only NGC at this point in time?

I don't think so (from the existing deployments perspective, including early 5G transitions). 

So, IMO - any mobility solution ought to be underlay independent - to allow flexibility for the operators. I see this discussion is independent of address space exhaustion or IPv6 address to UE..

--
Uma C.

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Dino Farinacci
Sent: Tuesday, March 20, 2018 5:02 PM
To: Satoru Matsushima <[email-masked]>
Cc: dmm <[email-masked]>
Subject: Re: [DMM] User Plane Protocol Study in 3GPP

That sounds like you want to do IPv4 over IPv6. Do you think carriers will build an IPv6-only NGC at this point in time?

Dino

> On Mar 20, 2018, at 6:33 PM, Satoru Matsushima <[email-masked]> wrote:
> 
> Next header type maybe?
> Interestingly GTP-U doesn’t have it.
> 
> Sent from my iPhone
> 
> 2018/03/20 18:17、Dino Farinacci <[email-masked]>のメール:
> 
>> How? Please summarize in one sentence and don’t me to a draft.
>> 
>> Dino
>> 
>>> On Mar 20, 2018, at 10:24 AM, Satoru Matsushima <[email-masked]> wrote:
>>> 
>>> Yes , supports IPv4 PDU with minimum effort.
>>> 
>>> Sent from my iPhone
>>> 
>>> 2018/03/20 16:47、Lyle Bertz <[email-masked]>のメール:
>>> 
>>>> I did not get to ask but I know your presentation talks about IPv6 but is there a requirement to support IPv4 mobile or dual stack?
>>>> 
>>>> Lyle
>>> 
>>> _______________________________________________
>>> dmm mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/dmm
>> 

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 30 May 2018 10:22:37 +0900

Hello Uma, let me clarify something. 

Are you proposing that we need to work on mobile user plane protocol with IPv4 NAPT?
Or, does your employer plan to develop NAPT traversal cellular equipments and application gateway for the user plane protocol?

It seems reinvent of PPTP.

Cheers,
-satoru

> 2018/05/24 2:07、Uma Chunduri <[email-masked]>のメール:
> 
> Dear All,
>

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 30 May 2018 01:36:04 +0000

Hi Satoru,

In-line [Uma]:

Cheers!
--
Uma C.
(responding as an individual)

-----Original Message-----
From: Satoru Matsushima [mailto:[email-masked]] 
Sent: Tuesday, May 29, 2018 6:23 PM
To: Uma Chunduri <[email-masked]>
Cc: Dino Farinacci <[email-masked]>; dmm <[email-masked]>
Subject: Re: [DMM] User Plane Protocol Study in 3GPP

Are you proposing that we need to work on mobile user plane protocol with IPv4 NAPT?
[Uma]: Nope, I did not say that.
Or, does your employer plan to develop NAPT traversal cellular equipments and application gateway for the user plane protocol?
[Uma]:  You are assuming on something which I didn't say anything about.  I was just responding to Dino's question on "IPv6 only NGC" ..

Cheers,
-satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 30 May 2018 10:54:34 +0900

Uma, I’m happy to hear that from you. 

I was just afraid that some vendors are trying to sell NAPT traversal cellular boxes with additional license fee. 
As you all know, 5G radio requires us to deploy APs much dense that we expect several or many IPv4 10/8 and even 100.64/10 should be required to cover the footprint of operators.

What I imagined was if a business person in a vendor finds that hidden bottleneck, I expected that the guy proposes NAPT traversal products to his company and easily convinced to get the go sign.
I have to admit that he/she must be a smart business person. If a operator who fully depends on IPv4 as backhaul/core transport, I expect that the operator couldn't resist to that attractive proposal. 

I hope you don’t do that even after you know my imagination.

Cheers,
--satoru

> 2018/05/30 10:36、Uma Chunduri <[email-masked]>のメール:
> 
> Hi Satoru,
> 
> In-line [Uma]:
> 
> Cheers!
> --
> Uma C.

---

From: Arashmid Akhavain <[email-masked]>
Date: Wed, 30 May 2018 18:57:13 +0000

You are right Uma,

Any deployment scenario (aside from green-field) will involve a combination of both address types.
IPv4 will be the dominant type at first while IPv6 gets introduced gradually.
Any mobility solution must address migration. Blank canvas is a nonstarter for operators.

Arashmid

> From: dmm [mailto:[email-masked]] On Behalf Of Uma Chunduri
> Sent: 23 May 2018 13:08
> To: Dino Farinacci <[email-masked]>; Satoru Matsushima
> <[email-masked]>
> Cc: dmm <[email-masked]>
> So, IMO - any mobility solution ought to be underlay independent - to allow
> flexibility for the operators. I see this discussion is independent of address
> space exhaustion or IPv6 address to UE..
> 
> --
> Uma C.
> 
> 
> That sounds like you want to do IPv4 over IPv6. Do you think carriers will
> build an IPv6-only NGC at this point in time?
> 
> Dino
> 
> >>>> I did not get to ask but I know your presentation talks about IPv6 but is
> there a requirement to support IPv4 mobile or dual stack?
> >>>>
> >>>> Lyle
> >>>