Subject: [DMM] Overall review on "draft-bogineni-dmm-optimized-mobile-user-plane-00"

From: Satoru Matsushima <[email-masked]>
Date: Wed, 6 Jun 2018 15:57:06 +0900

Dear Kalyani, and the draft authors,

Thank you so much for working on this I-D which brings much information regarding user plane protocols in IETF. It looks very promising work on IETF side corresponding to the user plane protocol study work (FS_UPPS) in 3GPP CT4.

Since I’m in the loop in the offline discussion of updating the draft, let me leave to bring detail comments on this version but instead here I’d bring following my overall comments on the draft as the rapporteur of FS_UPPS on 3GPP side.

1. Clarification on the TR/TSes

As the LS(*) pointed the User Plane protocol and several User Plane related specs in 3GPP, clarifying those specs in terms of user plane are highly appreciated. As I presented in London(**), the approach for this study in CT4 will be investigation and comparison for the candidates protocols including existing protocol that needs criteria to do that. Clarifying 5G specs in terms of user plane based on IETF expert’s analysis would be very helpful to figure out that criteria.

In CT4 side, we don’t have prefer logistic for the outcome of the clarification. The I-D has just a section of overview of 5G system but it looks quite a document already so that another concise clarify focused document in Internet Draft style sounds make sense to me. 

2. Contents organization

The I-D contains SRv6, LISP and ILA as the candidate user plane protocols. Those protocols seem to have each characteristics and certain level of impacts to the 3GPP 5G architecture. However it was difficult to find those features and impacts when I went thorough the draft. Though the LS asks DMM to provide any information regarding User Plane protocol, it would be nice at least if you can provide over-the-wire packet format, for instance, with the features of each protocol. And it would be followed by expected impacts to the 3GPP control plane of each candidates, as I said in London. In addition to that, distinguishably describing more impacts to the architecture beyond Release 15 would be much helpful to clearly understand on what those candidates require the architecture to be changed, as INT AD, Suresh, stated in London if I recall correctly. It would be also highly appreciated if those can be found out at a glance from the draft. That make us easy to digest it.

Please note that it does not mean the candidates need to be in apple-to-apple evaluation. It just needs the clear differences between the candidates to be highlighted in terms of user plane, control plane and architectural impact.

3. Use of term ‘Optimization'

The word “optimized” in the draft title seems ambiguous on that optimize for what. If you try to introduce how those candidates optimize something, it would be better to make clear the target of the optimization. But again the LS asks any information on user plane, the I-D doesn’t necessarily describe it. 

(*) https://datatracker.ietf.org/liaison/1572/
(**)https://datatracker.ietf.org/meeting/101/materials/slides-101-dmm-study-on-user-plane-protocol-at-3gpp-00

Hope that helps, and I’m happy to cooperate together on the user plane study on both IETF/3GPP sides.

Best regards,
--satoru

---

From: Shunsuke Homma <[email-masked]>
Date: Wed, 6 Jun 2018 18:10:07 +0900

Hi Satoru-san

Your review seems very pertinent and informative for me. Actually, there 
are various proposals such as SRv6, LISP, ILA etc., and we need to 
prepare criteria for 3GPP-side to judge which technologies have worth to 
be used in 5GS. For providing such criteria, it would be required to 
analyze 5GS requirements and GTP-U specs (as the current user plane 
protocol) from neutral position.

I assume the work is very important for both IETF and 3GPP, and I can 
cooperate on it.

Best regards,

Shunsuke

On 2018/06/06 15:57, Satoru Matsushima wrote:
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
> 

-- 
----------------------------------
Shunsuke Homma
<[email-masked]>
TEL: +81 422 59 3486
FAX: +81 422 60 7460

NTT Network Service Systems Labs.
Musashino city, Tokyo, Japan
----------------------------------