Subject: [DMM] I-D Action: draft-ietf-dmm-5g-uplane-analysis-04.txt

From: [email-masked]
Date: Mon, 02 Nov 2020 07:31:01 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Distributed Mobility Management WG of the IETF.

        Title           : User Plane Protocol and Architectural Analysis on 3GPP 5G System
        Authors         : Shunsuke Homma
                          Takuya Miyasaka
                          Satoru Matsushima
                          Daniel Voyer
	Filename        : draft-ietf-dmm-5g-uplane-analysis-04.txt
	Pages           : 42
	Date            : 2020-11-02

Abstract:
   This document analyzes the mobile user plane protocol and the
   architecture specified in 3GPP 5G documents.  The analysis work is to
   clarify those specifications, extract protocol and architectural
   requirements and derive evaluation aspects for user plane protocols
   on IETF side.  This work is corresponding to the User Plane Protocol
   Study work on 3GPP side.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dmm-5g-uplane-analysis-04
https://datatracker.ietf.org/doc/html/draft-ietf-dmm-5g-uplane-analysis-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-5g-uplane-analysis-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Flinck, Hannu (Nokia - FI/Espoo)" <[email-masked]>
Date: Sun, 15 Nov 2020 19:33:28 +0000

Hello authors of the draft-ietf-dmm-5g-uplane-analysis-04.txt draft,

As I have said earlier 3GPP CT4 as concluded the user plane study that the draft is indirectly referring through the liaison statements in the intro section.
The study listed a number of issues why Srv6 is not considered suitable for the user plane. Please review 3GPP TR 29.892 and take that into account in the analysis.

I also would like to note that the Rel 16 is completed and 3GPP is working on Rel 17.

Therefore the sentences like " The study description mentions that the study would be based on
   Release 16 requirement while only Release 15 specifications has been
   available now.  However we believe that to provide adequate
   information for 3GPP, we need to clearly understand what the current
   user plane protocol is in Release 15, and architectural requirements
   for the user plane." is very weird considering that you are addressing completed Release.

I cannot understand why and what is the benefit of such.

Best regards
Hannu

-----Original Message-----
From: dmm <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, November 2, 2020 5:31 PM
To: [email-masked]
Cc: [email-masked]
Subject: [DMM] I-D Action: draft-ietf-dmm-5g-uplane-analysis-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm

---

From: "Pablo Camarillo (pcamaril)" <[email-masked]>
Date: Mon, 16 Nov 2020 20:14:03 +0000

Hannu,

> The study listed a number of issues why Srv6 is not considered suitable for the user plane. Please review 3GPP TR 29.892 and take that into account in the analysis.

That is an interesting reading of TR 29.892.

" 8.3 SRv6 user plane protocol (without GTP-U) 
...
The solution supports all the 3GPP architectural requirements for user plane specified in Rel-16 
...
CT4 could not reach consensus on the final assessment and conclusion for the SRv6 user plane protocol (without GTP-U) solution. A technical vote took place during CT4#93 (26-30 August 2019) with the following question and results:
Question: Do you want to standardize SRv6 user plane protocol (w/o GTP-U) as described in clause 6.2.2 of TR 29.892?
...
It was therefore concluded to not standardize the SRv6 user plane protocol (without GTP-U) solution within the scope of this study (i.e. based on stage 2 requirements specified in Rel-16)."

Note that the fact that 3GPP voting decided not to standardize SRv6 as a replacement to GTP-U for the N9 interface in Release 16 does not imply that 3GPP cannot standardize it in a later Release.
Also I don't recall any "number of issues why Srv6 is not considered suitable for the user plane" in TR29.892.

Thank you,
Pablo.

-----Original Message-----
From: dmm <[email-masked]> On Behalf Of Flinck, Hannu (Nokia - FI/Espoo)
Sent: domingo, 15 de noviembre de 2020 20:33
To: [email-masked]
Subject: Re: [DMM] I-D Action: draft-ietf-dmm-5g-uplane-analysis-04.txt

Best regards
Hannu

-----Original Message-----
From: dmm <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, November 2, 2020 5:31 PM
To: [email-masked]
Cc: [email-masked]
Subject: [DMM] I-D Action: draft-ietf-dmm-5g-uplane-analysis-04.txt

Abstract:

---

From: Shunsuke Homma <[email-masked]>
Date: Tue, 17 Nov 2020 09:41:14 +0900

Hi Hannu,

Thank you for informing the status of 3GPP.

Unfortunately, we did not have enough time to restructure the whole of
document at this update. We’ll modify introduction, conclusion and any
other sections at next updating with referring the result of 3GPP.

Meanwhile, we’d like to make this document be valuable for future IETF work
relevant to 3GPP, and need feedback and opinion how to forward this work
from WG.

Best regards,

Shunsuke behalf of authors

2020年11月16日(月) 4:33 Flinck, Hannu (Nokia - FI/Espoo) <
[email-masked]>:

> As I have said earlier 3GPP CT4 as concluded the user plane study that the
> draft is indirectly referring through the liaison statements in the intro
> section.
> The study listed a number of issues why Srv6 is not considered suitable
> for the user plane. Please review 3GPP TR 29.892 and take that into account
> in the analysis.
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>

---

From: Takuya Miyasaka <[email-masked]>
Date: Wed, 18 Nov 2020 22:39:28 +0900

Hi all,

Due to a presentation order change and time shortage, we were not able 
to present the 5g-uplane-analysis draft yesterday. The presentation 
materials are uploaded below, so if you are interested in them, please 
check them out.
https://datatracker.ietf.org/meeting/109/materials/slides-109-dmm-user-plane-protocol-and-architectural-analysis-on-3gpp-5g-system-01

Also, as you can see in the email from Shunsuke, we're looking for 
feedback on the future direction of this draft, so please let us know if 
you have any ideas.

Regards,
Takuya

On 2020/11/17 9:41, Shunsuke Homma wrote:
> Meanwhile, we’d like to make this document be valuable for future IETF 
> work relevant to 3GPP, and need feedback and opinion how to forward 
> this work from WG.
>
> Best regards,
>
> 2020年11月16日(月) 4:33 Flinck, Hannu (Nokia - FI/Espoo) 
> <[email-masked] 
> <mailto:[email-masked]>>:
>
>     As I have said earlier 3GPP CT4 as concluded the user plane study
>     that the draft is indirectly referring through the liaison
>     statements in the intro section.
>     The study listed a number of issues why Srv6 is not considered
>     suitable for the user plane. Please review 3GPP TR 29.892 and take
>     that into account in the analysis.
>
>     From: dmm <[email-masked] <mailto:[email-masked]>> On
>     Behalf Of [email-masked] <mailto:[email-masked]>
>     To: [email-masked] <mailto:[email-masked]>
>     Cc: [email-masked] <mailto:[email-masked]>
>     <https://datatracker.ietf.org/doc/draft-ietf-dmm-5g-uplane-analysis/>
>
>     <https://tools.ietf.org/html/draft-ietf-dmm-5g-uplane-analysis-04>
>     <https://datatracker.ietf.org/doc/html/draft-ietf-dmm-5g-uplane-analysis-04>
>
>     <https://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-5g-uplane-analysis-04>
>
>
>     tools.ietf.org <http://tools.ietf.org>.
>
>     <ftp://ftp.ietf.org/internet-drafts/>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/dmm>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/dmm>
>
>