Subject: RE: [DNA] Considerations for DNA Schemes with multiple Interface andLayer 2 Technologies

From: YGHONG <[email-masked]>
Date: Thu, 28 Oct 2004 22:38:33 +0900

Hi.. Brilesh Kumar..

 My understanding for current DNA scheme is that a host can determine the
change of link 
only after a new link-layer connection is made and it receives link
information when the change 
of link-layer connection happens.

 If a host can have the ability to make a new link-layer connection before
an old link-layer connection 
is disconnected (make-before-break), I think that the host can determine
whether link is changed 
before it receives RAs through a new link-layer connection from routers. . 
(To do this, Access Points (or Base Stations) must be tightly interacted
with routers (PDSNs) 
like CDMA packet service.) 
Actually, in CDMA, L3 information in not necessary when moving between Base
Stations which are 
connected to same PDSN. The host can directly use same IP configuration
because it knows that 
link is same by L2 information 

I think that current DNA schemes are sufficient for currently used L2
technology such as Ethernet or WLAN.
If we consider other (existing and future) wireless technologies, how about
considering this fact?

Yong-Geun..

> -----Original Message-----
> From: Brijesh Kumar [mailto:[email-masked]] 
> Sent: Saturday, October 23, 2004 2:53 AM
> To: JinHyeock Choi; [email-masked]
> Cc: YGHONG; [email-masked]; ???; ???
> Subject: RE: [DNA] Considerations for DNA Schemes with 
> multiple InterfaceandLayer 2 Technologies
> 
> 
> Yong-Geun;
> 
> Like JinHyeock and Greg, I am too curious why CDMA soft 
> handoff should impact the DNA scheme specially since CDMA 
> provides make before break ability.
> 
> Since with CDMA, it is possible to combine the data received 
> from two or more different sites to ease the transition from 
> one to the other, I am unable to see why this will have any 
> DNA issues at all.
> 
> Can you please elaborate a little bit more clearly.
> 
> Cheers,
> 
> --bk
> 
> 
> 
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of 
> JinHyeock 
> > Dear Yong-Geun
> >
> > I think that the case 3.2, 'Single interface with Make before Break'
> > will affect DNA solution design. I agree that we are not 
> familiar with 
> > this case, so it would be of much help, if you elaborate the below 
> > with more detail.
> >
> >      We think that we are not familiar with this case. But 
> in CDMA[7], a
> >      mobile station can access two or more different base stations
> >      simultaneously. In this case, a host can make a new link-layer
> >      connection before an old link-layer connection is torn down.
> >
> > Especially I wonder whether it's possible for a host to distinguish 
> > the IP packets from the old link-layer connection FROM the 
> ones from 
> > the new link-layer connection.
> 
> 
> 
> 
> >
> > However, it's not clear to me the relationship between 'DNA schemes'
> > and 'multiple interfaces' from Case 3.3 & 3.4 description. I still 
> > can't see how multiple interfaces would affect DNA schemes 
> > substantially. Kindly elaborate this more.
> >
> > Thanks for your kind consideration.
> >
> > Best Regards
> >
> > JinHyeock
>

---

From: Brijesh Kumar <[email-masked]>
Date: Thu, 28 Oct 2004 12:25:17 -0400

Yong-Geun,

thanks for responding to my earlier comment.

> of link-layer connection happens.

In theory, you can get both link up and down events.
But, if you have only one interface, there is not much
any one can do after you get a link down event.

> link is same by L2 information

You are right here. In this case, the link change
will be taken care of by the layer 2 hand-off mechanisms,
and DNA mechanism wouldn't be needed. It can be seen as
one layer 2 interface that has two independent link layer
sessions (or two virtual links). The link is not until
down both sessions are down.

Clearly above is different than the mutiple physical interface
scenarios where a node can be connected to a 802.11 network and
at the same time connected to a GPRS or CDMA-1XRTT etc.

> If we consider other (existing and future) wireless technologies,
> how about considering this fact?

OK - I see your point now.

Cheers,

--bk