Subject: RE: [DNA] Considerations for DNA Schemes with multiple Interface and Layer 2 Technologies

From: NJEDJOU Eric RD-RESA-REN <[email-masked]>
Date: Wed, 27 Oct 2004 17:52:50 +0200

Actually the DNA scheme would better not be the same depending on wether i am able to attach to more than one link or not. Effectively, if i am attached for instance to two links at the same time, i may not need to go into the DNA process whenever i receive a hint that one of those links (L2 or L3) is no more valid, if i am able to switch my flows onto the other link without noticeable service interruption (after checking that my IP configuration on that other link is valid).

This is why i do not really like the sentence
"DNA schemes are typically run per interface.  When a host has
   multiple interfaces, the host separately checks for link changes on
   each interface."
As said in the introduction of the dna goals document. I think DNA would better run on an overall basis i.e seeing all of the links (which my Ip layer is capable of for that matter).

Eric Njedjou

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Pekka Nikander
Envoyé : lundi 25 octobre 2004 08:59
À : Dna
Cc : Erik Nordmark; YGHONG; ???; Greg Daley; JinHyeock Choi; ???
Objet : Re: [DNA] Considerations for DNA Schemes with multiple Interface and Layer 2 Technologies

>> I think that the case 3.2, 'Single interface with Make before Break'
>> will affect DNA solution design. I agree that we are not familiar 
>> with this case, so it would be of much help, if you elaborate the 
>> below with more detail.
>>
>>                 ... But in CDMA[7], a
>>      mobile station can access two or more different base stations
>>      simultaneously. In this case, a host can make a new link-layer
>>      connection before an old link-layer connection is torn down.
>
> I hope that L2 can actually tell the packets apart.
> If this is possible, then the implementation could present the packets 
> from the different links are arriving on different interfaces to IP.

I agree with Erik and others that the apparently cleanest way is to model the situation with distinct (virtual) interfaces, each corresponding to a wireless connection.

However, I am also wondering how often we need that in practise.
As far as I've understood (which may be completely wrong), in the typical case the CDMA network models the whole base station network as a single link, with a single excess router.  OTOH, I have no idea whether soft handovers between operators is defined or not.
If they are, then we probably need some care there.

Taking a slightly wider angle, we can imagine various anomalies like someone inadvertedly connecting two (wireline) LAN segments together.  That would (temporarily) create a similar situation.
Hence, I'm afraid that we need to make the DNA scheme(s) robust against these kinds of situations.  However, my current opinion (subject to change) is that we should not worry too much about these kinds of situations, and it would be perfectly OK if it takes some more time to system to recover in such a situation.  In other words, if some hosts unnecessarily run DNA and autoconfiguration, that wouldn't be too bad.

Network operators have to live with the limits of technology anyway.  If our DNA effort results in a piece of technology that has a number of well documented limitations, that is OK, as long as the WG agrees on the limitations.

--Pekka

---

From: Greg Daley <[email-masked]>
Date: Thu, 28 Oct 2004 12:21:58 +1000

Hi Eric,
(this is as an author and WG member, not as a chair).

NJEDJOU Eric RD-RESA-REN wrote:
> Actually the DNA scheme would better not be the same depending on wether i
 > am able to attach to more than one link or not. Effectively, if i am
 > attached for instance to two links at the same time, i may not need to
 > go into the DNA process whenever i receive a hint that one of those
 > links (L2 or L3) is no more valid, if i am able to switch my flows onto
 > the other link without noticeable service interruption (after checking
 > that my IP configuration on that other link is valid).
> 
> As said in the introduction of the dna goals document. I think DNA would
 > better run on an overall basis i.e seeing all of the links (which my
 > Ip layer is capable of for that matter).

There is some text in the BCP document draft-narayanan-dna-bcp-01.txt
which relates to situations with multiple interfaces in that
it talks about inactive interfaces.

It doesn't describe what should be discovered, but a means for
handling interfaces which are not being used (for example, a
second WLAN interface), and how to start DNA for them.

The actual change discovery is largely the same, since it is based
on link-local signalling.  The requirement to initiate within a
time bound may not be, due to the make-before-break nature of the
operations.

The coordination and policy decisions about interface preferences
and which, though I'm not sure that this is in scope, because it varies
dependent on upper layer protocols.

If we need to add extra information to the BCP then I think it's worth
discussing.

As an aside, there's text about multiple connections through the
same interface in the BCP too.

Greg

---

From: JinHyeock Choi <[email-masked]>
Date: Fri, 29 Oct 2004 19:30:29 +0900

Dear Eric Njedjou

I think we have confusion about what DNA schemes accomplish. DNA 
schemes aim to detect the identity of currently attached link to verify IP 
configuration. It's closely related, but not identical, to handoff process. 

> Actually the DNA scheme would better not be the same depending on wether i am able to 
> attach to more than one link or not. Effectively, if i am attached for instance to two links at
 > the same time, i may not need to go into the DNA process whenever i receive a hint that 
> one of those links (L2 or L3) is no more valid, if i am able to switch my flows onto the 
> other link without noticeable service interruption (after checking that my IP configuration on 
> that other link is valid).

Even in the above case, DNA scheme is needed. Without DNA process, a host will 
switch flow onto the other link whenever it receive a hint, resulting in undue signaling. 
Also DNA schemes enable a host to check whether its IP configuration on a link is 
valid or not.  
 
> As said in the introduction of the dna goals document. I think DNA would better run on 
> an overall basis i.e seeing all of the links (which my Ip layer is capable of for that matter).

I think we have confusion about what DNA schemes accomplish. 

> In the same respect,
> the sentence "Today, a link change necessitates an IP configuration change."
> in the dna goals document introduction let the reader believe that a node would 
> not be having interfaces attached to other links. Because if it is so, then the 
> a configuration that might have been built on the non used link could start being 
> used  without requiring new IP configuration. 

Some IP configuration, such as IP addres, is assigned to an interface. When 
an interface attaches to a new link, its existing IP address is no longer valid. 
Hence the interface needs a new IP address, irrespective of whether the host 
it belongs has other interfaces or not.   

Best Regards

JinHyeock