Subject: RE: [DNA] Considerations for DNA Schemes with multiple Interface and Layer 2 Technologies

From: YGHONG <[email-masked]>
Date: Thu, 28 Oct 2004 20:52:19 +0900

Dear JinHyeock..

 Because I am not a specialist about CDMA, I can be wrong in some points.
 As my understanding (with discussion with other CDMA specialists), 
it is possible for a host to distinguish the IP packets from the old
link-layer connection FROM the ones
from the new link-layer connection. The reason is that a host in CDMA can
have two link-layer connections 
during handover between base stations. One link-layer connection is for an
old base station, the other link-layer
connection is for a new base station. When handover happens and by using
make-before-break, a host can have 
the ability to distinguish the IP packets. (Actually, current IPv4 based
CDMA packet service in Korea, unfortunately
only supports break-before-make(hard handover) because there are no needs
for make-before-break(soft handover) )
 So, if this situation is valuable for DNA schemes,  we can ask CDMA
operators to support make-before-break in 
IPv6 based CDMA packet service. 

 But, if two(old and new) base stations are connected to different PDSN
(Packet Data Serving Node, similar to router), 
during handover between base stations, an old PPP connection between the
host and an old PDSN is disconnected 
and then a new PPP connection between the host and a new PDSN is connected.
In this case, only break-before-make is used.

 Yong-Geun..

 > -----Original Message-----
> From: JinHyeock Choi [mailto:[email-masked]] 
> Sent: Saturday, October 23, 2004 1:55 AM
> To: [email-masked]
> Cc: YGHONG; [email-masked]; ???; ???
> Subject: Re: [DNA] Considerations for DNA Schemes with 
> multiple Interface and Layer 2 Technologies
> 
> 
> Dear Yong-Geun
> 
> I think that the case 3.2, 'Single interface with Make before Break'
> will affect DNA solution design. I agree that we are not 
> familiar with this case, so it would be of much help, if you 
> elaborate the below with more detail. 
> 
>      We think that we are not familiar with this case. But in 
> CDMA[7], a
>      mobile station can access two or more different base stations
>      simultaneously. In this case, a host can make a new link-layer
>      connection before an old link-layer connection is torn down.
> 
> Especially I wonder whether it's possible for a host to 
> distinguish the IP packets from the old link-layer connection 
> FROM the ones from the new link-layer connection.  
> 

> However, it's not clear to me the relationship between 'DNA schemes' 
> and 'multiple interfaces' from Case 3.3 & 3.4 description. I 
> still can't see how multiple interfaces would affect DNA 
> schemes substantially. Kindly elaborate this more. 
> 
> Thanks for your kind consideration. 
> 
> Best Regards
> 
> JinHyeock
>

---

From: JinHyeock Choi <[email-masked]>
Date: Sat, 30 Oct 2004 01:23:14 +0900

Dear Yong-Geun

Thanks for your reply. 

> from the new link-layer connection. 

Glad & relieved to hear that. 

> The reason is that a host in CDMA can
> the ability to distinguish the IP packets. 

I am confused. Why does a host need 'make-before-break' 
technology to distinguish the IP packets?

In case there is no 'make-before-break', only one link-layer connection 
is allowed per interface. Hence, all the packets come from the same 
link-layer connection. No need to distinguish packets at all.  

> (Actually, current IPv4 based

Allow me to present it more logically. 

First,  
If CDMA supports 'make-before-break', it's possible for an interface 
to establish multiple link-layer connections at the same time. 

Second,  
If so, it's difficult for an interface to detect the identity of the currently 
attached link, because there may be more than one currently attached links. 

Third,  
In this case, it would help DNA scheme if an interface can distinguish 
the packets from one link-layer connection from another. 

Purely DNA point of view, it would be better if CDMA doesn't support 
'make-before-break' at all. It would make DNA much simpler. 
 
Best Regards

JinHyeock

---

From: Greg Daley <[email-masked]>
Date: Mon, 01 Nov 2004 09:46:16 +1100

Hi JinHyeock,

JinHyeock Choi wrote:
[cut]
> 'make-before-break' at all. It would make DNA much simpler. 

I know this was a throw-away line, but it's hard to throw away.

I think that MBB will have to be supported, in DNA.  This is especially
the case where Unreachability is to be determined from certain tests.

We mainly need to be clear about which tests are applicable and
what inference is taken from received messages.  I think this
is still in coverage for the BCP and Goals though.

Greg

---

From: Pekka Nikander <[email-masked]>
Date: Mon, 01 Nov 2004 06:49:37 +0200

> is still in coverage for the BCP and Goals though.

I have to admit that I am totally confused now.  Maybe I just
don't know the facts.  So, let me ask some stupid questions:

1. Are people planning to use make-before-break with CDMA
    with PPP or not?  Or both?  (If PPP is used, I see no
    problem wrt. DNA as PPP is then the link layer to IPv6,
    and the situation has to be handled below the IPv6 layer.)

2. Assuming no PPP is used, are there any actual plans of
    supporting make-before-break between networks that actually
    have different IPv6 configuration at different base stations?
    (If not, again, I don't see what we have to worry about.)

3. Assuming no PPP is used and make-before-break is supported
    between base stations that potentially have different
    network configuration, is there any reason why the link
    layer cannot model the situation as two different interfaces?

That is, even in the case that the CDMA link layer does not use
PPP but is directly visible to IPv6, if we can model the radio
layer connections to different base stations as different interfaces,
as seen by IPv6, I don't see any problem.  The worst that can there
happen is that the two interfaces, corresponding to the two radio
layer connections, are connected to the same IPv6 network.  But that
is a case that we have to handle otherwise, too.

There may be some problems related to link layer addresses, etc,
but someone should really point us to the right documents, or better,
write a problem statement draft of the situation, trying to clarify
the current plans of running IPv6 over make-before-break CDMA (and
other such radio links).  I don't see much use to argue about this
until we properly understand the details, and at least I can't
possibly claim understanding them.  I don't even know what documents
I should read; sorry about my ignorance.

--Pekka